update to 20201230 [release 20201230-1mamba;Sun Dec 26 2021]
This commit is contained in:
parent
3371703d9b
commit
cb60641d5e
36
libewf-20201230-openssl-3.patch
Normal file
36
libewf-20201230-openssl-3.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From 033ea5b4e5f8f1248f74a2ec61fc1be183c6c46b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Joachim Metz <joachim.metz@gmail.com>
|
||||||
|
Date: Thu, 18 Nov 2021 06:51:25 +0100
|
||||||
|
Subject: [PATCH] Changes for building with OpenSSL 3 #164
|
||||||
|
|
||||||
|
---
|
||||||
|
ewftools/ewftools_output.c | 12 +++++++++++-
|
||||||
|
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ewftools/ewftools_output.c b/ewftools/ewftools_output.c
|
||||||
|
index 07ef5e24..07312055 100644
|
||||||
|
--- a/ewftools/ewftools_output.c
|
||||||
|
+++ b/ewftools/ewftools_output.c
|
||||||
|
@@ -238,11 +238,21 @@ void ewftools_output_version_detailed_fprint(
|
||||||
|
LIBHMAC_VERSION_STRING );
|
||||||
|
|
||||||
|
#if defined( HAVE_LIBCRYPTO )
|
||||||
|
+#if defined( SHLIB_VERSION_NUMBER )
|
||||||
|
fprintf(
|
||||||
|
stream,
|
||||||
|
" (libcrypto %s)",
|
||||||
|
SHLIB_VERSION_NUMBER );
|
||||||
|
-#endif
|
||||||
|
+
|
||||||
|
+#elif defined( OPENSSL_VERSION_MAJOR ) && defined( OPENSSL_VERSION_MINOR )
|
||||||
|
+ fprintf(
|
||||||
|
+ stream,
|
||||||
|
+ " (libcrypto %d.%d)",
|
||||||
|
+ OPENSSL_VERSION_MAJOR,
|
||||||
|
+ OPENSSL_VERSION_MINOR );
|
||||||
|
+
|
||||||
|
+#endif /* defined( SHLIB_VERSION_NUMBER ) */
|
||||||
|
+#endif /* defined( HAVE_LIBCRYPTO ) */
|
||||||
|
#endif /* defined( HAVE_LIBHMAC ) || defined( HAVE_LOCAL_LIBHMAC ) */
|
||||||
|
|
||||||
|
#if defined( HAVE_LIBODRAW ) || defined( HAVE_LOCAL_LIBODRAW )
|
23
libewf.spec
23
libewf.spec
@ -1,15 +1,22 @@
|
|||||||
Name: libewf
|
Name: libewf
|
||||||
Version: 20140608
|
Version: 20201230
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A library to access the Expert Witness Compression Format (EWF)
|
Summary: A library to access the Expert Witness Compression Format (EWF)
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://code.google.com/p/libewf
|
URL: https://code.google.com/archive/p/libewf
|
||||||
Source: https://53efc0a7187d0baa489ee347026b8278fe4020f6.googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/libewf-%{version}.tar.gz
|
Source: https://github.com/libyal/libewf/releases/download/%{version}/libewf-experimental-%{version}.tar.gz
|
||||||
|
Patch0: libewf-20201230-openssl-3.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libfuse-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
%description
|
%description
|
||||||
libewf is a library to access the Expert Witness Compression Format (EWF).
|
libewf is a library to access the Expert Witness Compression Format (EWF).
|
||||||
@ -21,7 +28,7 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
libewf is a library to access the Expert Witness Compression Format (EWF).
|
libewf is a library to access the Expert Witness Compression Format (EWF).
|
||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
%package -n ewf-tools
|
%package -n ewf-tools
|
||||||
Summary: Tools for the Expert Witness Compression Format (EWF)
|
Summary: Tools for the Expert Witness Compression Format (EWF)
|
||||||
@ -31,8 +38,11 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n ewf-tools
|
%description -n ewf-tools
|
||||||
Tools using Libewf for support of the Expert Witness Compression Format (EWF), it support both the SMART format (EWF-S01) and the EnCase format (EWF-E01).
|
Tools using Libewf for support of the Expert Witness Compression Format (EWF), it support both the SMART format (EWF-S01) and the EnCase format (EWF-E01).
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .openssl-3
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -82,6 +92,9 @@ Tools using Libewf for support of the Expert Witness Compression Format (EWF), i
|
|||||||
%{_mandir}/man1/ewfverify.1*
|
%{_mandir}/man1/ewfverify.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 26 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20201230-1mamba
|
||||||
|
- update to 20201230
|
||||||
|
|
||||||
* Thu Sep 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 20140608-1mamba
|
* Thu Sep 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 20140608-1mamba
|
||||||
- update to 20140608
|
- update to 20140608
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user