package created by silvan using the webbuild interface [release 20130506git-1mamba;Mon May 06 2013]

This commit is contained in:
Silvan Calarco 2024-01-06 04:11:58 +01:00
parent b21f8e22c4
commit 80d0351dfd
3 changed files with 104 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libetpan
Mail Framework for C Language.

View File

@ -0,0 +1,27 @@
--- a/src/low-level/imap/mailimap_id_sender.c
+++ b/src/low-level/imap/mailimap_id_sender.c
@@ -1,3 +1,4 @@
+#include <stdlib.h>
#include "mailimap_id_sender.h"
#include "mailimap_sender.h"
--- libetpan-20130506git.orig/src/data-types/mailstream_compress.c 2013-05-07 11:13:20.000000000 +0200
+++ libetpan-20130506git/src/data-types/mailstream_compress.c 2013-05-07 12:30:02.867004893 +0200
@@ -31,6 +31,7 @@
/* Created by Ian Ragsdale on 3/8/13. */
+#include <config.h>
#include "mailstream_compress.h"
#if !HAVE_ZLIB
--- libetpan-20130506git.orig/src/low-level/imap/mailimap_compress.c 2013-05-07 11:13:20.000000000 +0200
+++ libetpan-20130506git/src/low-level/imap/mailimap_compress.c 2013-05-07 12:29:29.436336744 +0200
@@ -29,6 +29,7 @@
* SUCH DAMAGE.
*/
+#include <stdlib.h>
#include "mailimap_compress.h"
#include "mailimap.h"

75
libetpan.spec Normal file
View File

@ -0,0 +1,75 @@
Name: libetpan
Version: 20130506git
Release: 1mamba
Summary: Mail Framework for C Language
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.etpan.org/
## GITSOURCE git://github.com/dinhviethoa/libetpan.git
Source: git://github.com/dinhviethoa/libetpan.git/master/libetpan-%{version}.tar.bz2
Patch0: libetpan-20130506git-NULL-missing-include.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libdb51-devel
BuildRequires: libgcc
BuildRequires: libopenssl-devel
BuildRequires: libsasl-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Mail Framework for C Language.
%package devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q
%patch0 -p1
%build
./autogen.sh
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libetpan.so.*
%doc COPYRIGHT
%files devel
%defattr(-,root,root)
%{_bindir}/libetpan-config
%{_includedir}/libetpan.h
%dir %{_includedir}/libetpan
%{_includedir}/libetpan/*.h
%{_libdir}/libetpan.a
%{_libdir}/libetpan.la
%{_libdir}/libetpan.so
%doc ChangeLog NEWS
%changelog
* Mon May 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 20130506git-1mamba
- package created by silvan using the webbuild interface