rebuilt by autoport with build requirements: librpm-devel>=4.16.1.2-1mamba [release 0.60.0-2mamba;Sun Mar 07 2021]
This commit is contained in:
parent
a851c5f5e1
commit
1f24a18375
@ -1,19 +0,0 @@
|
|||||||
diff -ru libdnf-0.54.2.orig/libdnf/dnf-context.cpp libdnf-0.54.2/libdnf/dnf-context.cpp
|
|
||||||
--- libdnf-0.54.2.orig/libdnf/dnf-context.cpp 2020-10-17 14:26:56.928000000 +0200
|
|
||||||
+++ libdnf-0.54.2/libdnf/dnf-context.cpp 2020-10-17 14:31:32.900000000 +0200
|
|
||||||
@@ -1073,8 +1073,13 @@
|
|
||||||
dnf_context_get_installonly_pkgs(DnfContext *context)
|
|
||||||
{
|
|
||||||
static const gchar *installonly_pkgs[] = {
|
|
||||||
- "kernel",
|
|
||||||
- "kernel-PAE",
|
|
||||||
+ "kernel-mamba-longterm","kernel-mamba-longterm-headers","keernel-mamba-longterm-source",
|
|
||||||
+ "kernel-mamba-longterm-4GB","kernel-mamba-longterm-4GB-headers","kernel-mamba-longterm-4GB-source",
|
|
||||||
+ "kernel-mamba","kernel-mamba-headers","kernel-mamba-source",
|
|
||||||
+ "kernel-mamba-64GB","kernel-mamba-64GB-headers","kernel-mamba-64GB-source",
|
|
||||||
+ "kernel-mamba-x86_64","kernel-mamba-x86_64-headers","kernel-mamba-x86_64-source",
|
|
||||||
+ "kernel-mamba-arm","kernel-mamba-arm-headers","kernel-mamba-arm-source",
|
|
||||||
+ "kernel-mamba-aarch64","kernel-mamba-aarch64-headers","kernel-mamba-aarch64-source",
|
|
||||||
"installonlypkg(kernel)",
|
|
||||||
"installonlypkg(kernel-module)",
|
|
||||||
"installonlypkg(vm)",
|
|
14
libdnf-0.60.0-openmamba-kernel-packages.patch
Normal file
14
libdnf-0.60.0-openmamba-kernel-packages.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- libdnf-0.60.0/libdnf/conf/Const.hpp.orig 2021-03-04 01:14:46.835662828 +0100
|
||||||
|
+++ libdnf-0.60.0/libdnf/conf/Const.hpp 2021-03-04 01:16:06.957159489 +0100
|
||||||
|
@@ -36,6 +36,11 @@
|
||||||
|
|
||||||
|
const std::vector<std::string> GROUP_PACKAGE_TYPES{"mandatory", "default", "conditional"};
|
||||||
|
const std::vector<std::string> INSTALLONLYPKGS{"kernel", "kernel-PAE",
|
||||||
|
+ "kernel-mamba","kernel-mamba-headers","kernel-mamba-source",
|
||||||
|
+ "kernel-mamba-64GB","kernel-mamba-64GB-headers","kernel-mamba-64GB-source",
|
||||||
|
+ "kernel-mamba-x86_64","kernel-mamba-x86_64-headers","kernel-mamba-x86_64-source",
|
||||||
|
+ "kernel-mamba-arm","kernel-mamba-arm-headers","kernel-mamba-arm-source",
|
||||||
|
+ "kernel-mamba-aarch64","kernel-mamba-aarch64-headers","kernel-mamba-aarch64-source",
|
||||||
|
"installonlypkg(kernel)",
|
||||||
|
"installonlypkg(kernel-module)",
|
||||||
|
"installonlypkg(vm)",
|
14
libdnf.spec
14
libdnf.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libdnf
|
Name: libdnf
|
||||||
Version: 0.58.0
|
Version: 0.60.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Software management library
|
Summary: Software management library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -13,7 +13,7 @@ Patch1: libdnf-0.22.0-rpm5.patch
|
|||||||
Patch2: libdnf-0.22.0-rpm5-2.patch
|
Patch2: libdnf-0.22.0-rpm5-2.patch
|
||||||
Patch3: libdnf-0.22.0-rpm5-additional.patch
|
Patch3: libdnf-0.22.0-rpm5-additional.patch
|
||||||
Patch4: libdnf-0.31.0-x86_64-disable_inferior_arch_check.patch
|
Patch4: libdnf-0.31.0-x86_64-disable_inferior_arch_check.patch
|
||||||
Patch5: libdnf-0.55.2-openmamba-kernel-packages.patch
|
Patch5: libdnf-0.60.0-openmamba-kernel-packages.patch
|
||||||
Patch6: libdnf-0.43.1-arm-detect-arch-using-uname.patch
|
Patch6: libdnf-0.43.1-arm-detect-arch-using-uname.patch
|
||||||
Patch7: libdnf-0.58.0-i586-default-basearch.patch
|
Patch7: libdnf-0.58.0-i586-default-basearch.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
@ -37,13 +37,13 @@ BuildRequires: libsolv-devel
|
|||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: librpm-devel >= 4.16.1.2-1mamba
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: libsolv >= 0.7.5
|
BuildRequires: libsolv >= 0.7.5
|
||||||
BuildRequires: libmodulemd >= 2.5.0
|
BuildRequires: libmodulemd >= 2.5.0
|
||||||
#BuildRequires: libmodulemd-devel
|
#BuildRequires: libmodulemd-devel
|
||||||
Provides: libhawkey
|
Provides: libhawkey
|
||||||
Obsoletes: libhawkey
|
Obsoletes: libhawkey
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Software management library.
|
Software management library.
|
||||||
@ -115,6 +115,12 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 07 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.60.0-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: librpm-devel>=4.16.1.2-1mamba
|
||||||
|
|
||||||
|
* Thu Mar 04 2021 Automatic Build System <autodist@mambasoft.it> 0.60.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Jan 29 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.58.0-1mamba
|
* Fri Jan 29 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.58.0-1mamba
|
||||||
- update to 0.58.0
|
- update to 0.58.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user