libdirectfb/libdirectfb.spec

208 lines
7.3 KiB
RPMSpec

%define majver %(echo %version | cut -d. -f 1-2)
%define patchver %(echo %version | cut -d. -f 3)
Name: libdirectfb
Version: 1.7.7
Release: 3mamba
Summary: Graphics abstraction library for the Linux Framebuffer Device
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/deniskropp/DirectFB
Source: http://www.directfb.org/downloads/Core/DirectFB-%{majver}/DirectFB-%{version}.tar.gz
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libdrm-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libglvnd-devel
BuildRequires: libjasper-devel
BuildRequires: libjpeg-devel
BuildRequires: libmesa-devel
BuildRequires: libpng-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtiff-devel
BuildRequires: libvdpau-devel
BuildRequires: libwebp-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libdrm >= 1:2.4.112
%description
DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers on top of the Linux Framebuffer Device.
It is a complete hardware abstraction layer with software fallbacks for every graphics operation that is not supported by the underlying hardware.
DirectFB adds graphical power to embedded systems and sets a new standard for graphics under Linux.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{version}-%{release}
%description devel
DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers on top of the Linux Framebuffer Device.
This package contains static libraries and header files needed for development.
%package -n directfb-tools
Group: System/Tools
Summary: Tools provided with the DirectFB library
Requires: %{name} = %{version}-%{release}
%description -n directfb-tools
DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers on top of the Linux Framebuffer Device.
This package contains the tools that are provided with the library distribution.
%debug_package
%prep
%setup -q -n DirectFB-%{version}
%build
%configure \
--enable-zlib \
%ifarch arm
--with-gfxdrivers=gl,pxa3xx
%endif
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -n directfb-tools
%defattr(-,root,root)
%{_bindir}/dfbfx
%{_bindir}/dfbg
%{_bindir}/dfbinput
%{_bindir}/dfbdump
%{_bindir}/dfbdumpinput
%{_bindir}/dfbinfo
%{_bindir}/dfbinspector
%{_bindir}/dfbmaster
%{_bindir}/dfblayer
%{_bindir}/dfbpenmount
%{_bindir}/dfbplay
%{_bindir}/dfbscreen
%{_bindir}/dfbshow
%{_bindir}/dfbswitch
%{_bindir}/mkdfiff
%{_bindir}/mkdgiff
%{_bindir}/mkdgifft
%{_bindir}/pxa3xx_dump
%{_mandir}/man1/dfbg.1*
%{_mandir}/man1/directfb-csource.1*
%{_mandir}/man5/directfbrc.5*
%files
%defattr(-,root,root)
%{_libdir}/*.so.*
%dir %{_libdir}/directfb-%{majver}-*/
%dir %{_libdir}/directfb-%{majver}-*/gfxdrivers
%{_libdir}/directfb-%{majver}-*/gfxdrivers/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/inputdrivers
%{_libdir}/directfb-%{majver}-*/inputdrivers/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces
%dir %{_libdir}/directfb-%{majver}-*/interfaces/ICoreResourceManager
%{_libdir}/directfb-%{majver}-*/interfaces/ICoreResourceManager/libicoreresourcemanager_test.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBFont
%{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBFont/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBImageProvider
%{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBImageProvider/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBVideoProvider
%{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBVideoProvider/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBWindows
%{_libdir}/directfb-%{majver}-*/interfaces/IDirectFBWindows/libidirectfbwindows_default.so
%dir %{_libdir}/directfb-%{majver}-*/interfaces/IWater
%{_libdir}/directfb-%{majver}-*/interfaces/IWater/libiwater_default.so
%dir %{_libdir}/directfb-%{majver}-*/systems
%{_libdir}/directfb-%{majver}-*/systems/lib*.so
%dir %{_libdir}/directfb-%{majver}-*/wm
%{_libdir}/directfb-%{majver}-*/wm/lib*.so
%dir %{_datadir}/directfb-%{version}
%{_datadir}/directfb-%{version}/*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%{_bindir}/directfb-config
%{_bindir}/directfb-csource
%dir %{_includedir}/directfb-internal
%{_includedir}/directfb-internal/*
%dir %{_includedir}/directfb
%{_includedir}/directfb/*
%dir %{_includedir}/++dfb/
%{_includedir}/++dfb/*
%{_libdir}/lib++dfb.so
%{_libdir}/libdirectfb.so
%{_libdir}/libdirect.so
%{_libdir}/libfusion.so
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog NEWS README TODO
%changelog
* Mon May 06 2024 Automatic Build System <autodist@openmamba.org> 1.7.7-3mamba
- rebuild to remove .la files
* Sat Jul 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.7-2mamba
- rebuilt with libdrm 2.4.112
* Wed Mar 11 2015 Automatic Build System <autodist@mambasoft.it> 1.7.7-1mamba
- automatic update by autodist
* Sat Sep 20 2014 Automatic Build System <autodist@mambasoft.it> 1.7.6-1mamba
- automatic update by autodist
* Thu Jul 31 2014 Automatic Build System <autodist@mambasoft.it> 1.7.5-1mamba
- automatic version update by autodist
* Sun Jun 01 2014 Automatic Build System <autodist@mambasoft.it> 1.7.4-1mamba
- automatic update by autodist
* Thu Oct 17 2013 Automatic Build System <autodist@mambasoft.it> 1.7.1-1mamba
- automatic version update by autodist
* Sat Aug 31 2013 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
- automatic version update by autodist
* Wed Jan 23 2013 Automatic Build System <autodist@mambasoft.it> 1.6.3-1mamba
- automatic version update by autodist
* Sun Dec 02 2012 Automatic Build System <autodist@mambasoft.it> 1.6.2-1mamba
- automatic version update by autodist
* Sat Sep 08 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.17-2mamba
- move man page directfbrc.5 from libdirectfb to directfb-tools (also fixes conflict with libdirectfb5)
* Mon Sep 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.17-1mamba
- update to 1.4.17
* Fri Jul 22 2011 Automatic Build System <autodist@mambasoft.it> 1.4.13-1mamba
- automatic update to 3.0.3.0 by autodist
* Mon Nov 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.11-1mamba
- update to 1.4.11
* Fri Aug 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.5-1mamba
- update to 1.4.5
* Wed Feb 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-1mamba
- update to 1.2.5
* Sat Jul 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-1mamba
- update to 1.1.1
* Fri Dec 16 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.9.24-1qilnx
- update to version 0.9.24 by autospec
* Mon Sep 05 2005 Massimo Pintore <massimo.pintore@qilinux.it> 0.9.22-1qilnx
- package created by autospec