automatic version update by autodist [release 1.8.0-1mamba;Thu Apr 16 2020]

This commit is contained in:
Automatic Build System 2024-01-06 04:06:22 +01:00
parent 08598b9afb
commit 55799b51af
4 changed files with 173 additions and 94 deletions

View File

@ -0,0 +1,19 @@
diff -ru DevIL/DevIL/src-IL/src/il_jp2.cpp DevILb/DevIL/src-IL/src/il_jp2.cpp
--- DevIL/DevIL/src-IL/src/il_jp2.cpp 2017-01-02 01:03:56.000000000 +0100
+++ DevILb/DevIL/src-IL/src/il_jp2.cpp 2021-03-20 09:25:11.500686387 +0100
@@ -314,13 +314,13 @@
-static int iJp2_file_read(jas_stream_obj_t *obj, char *buf, int cnt)
+static int iJp2_file_read(jas_stream_obj_t *obj, char *buf, unsigned int cnt)
{
obj;
return iread(buf, 1, cnt);
}
-static int iJp2_file_write(jas_stream_obj_t *obj, char *buf, int cnt)
+static int iJp2_file_write(jas_stream_obj_t *obj, const char *buf, unsigned int cnt)
{
obj;
return iwrite(buf, 1, cnt);

View File

@ -0,0 +1,47 @@
From 1763633e5f7a8b86c293bd9a2f030961e77b0067 Mon Sep 17 00:00:00 2001
From: Juergen Buchmueller <pullmoll@t-online.de>
Date: Mon, 2 Jan 2017 16:48:55 +0100
Subject: [PATCH] Add solib version number to CMakeLists.txt
---
DevIL/src-IL/CMakeLists.txt | 1 +
DevIL/src-ILU/CMakeLists.txt | 1 +
DevIL/src-ILUT/CMakeLists.txt | 1 +
3 files changed, 3 insertions(+)
diff --git a/DevIL/src-IL/CMakeLists.txt b/DevIL/src-IL/CMakeLists.txt
index 02e4f033..095f43e7 100644
--- a/DevIL/src-IL/CMakeLists.txt
+++ b/DevIL/src-IL/CMakeLists.txt
@@ -58,6 +58,7 @@ source_group("Text Files" FILES ${DevIL_TXT} )
if(BUILD_SHARED_LIBS)
add_library(IL SHARED ${DevIL_SRCS} ${DevIL_INC} ${DevIL_RSRC} ${DevIL_TXT})
+ set_target_properties(IL PROPERTIES SOVERSION 1)
else(BUILD_SHARED_LIBS)
add_library(IL ${DevIL_SRCS} ${DevIL_INC} ${DevIL_RSRC} ${DevIL_TXT})
endif(BUILD_SHARED_LIBS)
diff --git a/DevIL/src-ILU/CMakeLists.txt b/DevIL/src-ILU/CMakeLists.txt
index 17a3afe7..44b9531b 100644
--- a/DevIL/src-ILU/CMakeLists.txt
+++ b/DevIL/src-ILU/CMakeLists.txt
@@ -44,6 +44,7 @@ source_group("Resource Files" FILES ${ILU_RSRC} )
# Remove SHARED to create a static library
add_library(ILU SHARED ${ILU_SRCS} ${ILU_INC} ${ILU_RSRC})
+set_target_properties(ILU PROPERTIES SOVERSION 1)
## ILU requires IL
diff --git a/DevIL/src-ILUT/CMakeLists.txt b/DevIL/src-ILUT/CMakeLists.txt
index 21470cbc..296f9955 100644
--- a/DevIL/src-ILUT/CMakeLists.txt
+++ b/DevIL/src-ILUT/CMakeLists.txt
@@ -44,6 +44,7 @@ source_group("Resource Files" FILES ${ILUT_RSRC} )
# Remove SHARED to create a static library
add_library(ILUT SHARED ${ILUT_SRCS} ${ILUT_INC} ${ILUT_RSRC})
+set_target_properties(ILUT PROPERTIES SOVERSION 1)
## add link sub library info
target_link_libraries(ILUT

View File

@ -0,0 +1,78 @@
diff -Nru DevIL-1.8.0.orig/DevIL/src-IL/CMakeLists.txt DevIL-1.8.0/DevIL/src-IL/CMakeLists.txt
--- DevIL-1.8.0.orig/DevIL/src-IL/CMakeLists.txt 2020-04-16 13:36:56.474000000 +0200
+++ DevIL-1.8.0/DevIL/src-IL/CMakeLists.txt 2020-04-16 13:40:53.687000000 +0200
@@ -249,8 +249,8 @@
# Installation
install (TARGETS IL
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib64
+ LIBRARY DESTINATION lib64
RUNTIME DESTINATION bin
)
install (FILES ../include/IL/il.h DESTINATION include/IL)
diff -Nru DevIL-1.8.0.orig/DevIL/src-IL/pkgconfig/IL.pc.cmake.in DevIL-1.8.0/DevIL/src-IL/pkgconfig/IL.pc.cmake.in
--- DevIL-1.8.0.orig/DevIL/src-IL/pkgconfig/IL.pc.cmake.in 2020-04-13 04:41:31.000000000 +0200
+++ DevIL-1.8.0/DevIL/src-IL/pkgconfig/IL.pc.cmake.in 2020-04-16 13:41:54.670000000 +0200
@@ -1,7 +1,7 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}
includedir=${prefix}/include
-libdir=${exec_prefix}/lib
+libdir=${exec_prefix}/lib64
Name: IL
Description: Developer's Image Library - IL part (just image load/save)
diff -Nru DevIL-1.8.0.orig/DevIL/src-ILU/CMakeLists.txt DevIL-1.8.0/DevIL/src-ILU/CMakeLists.txt
--- DevIL-1.8.0.orig/DevIL/src-ILU/CMakeLists.txt 2020-04-16 13:36:56.475000000 +0200
+++ DevIL-1.8.0/DevIL/src-ILU/CMakeLists.txt 2020-04-16 13:41:04.452000000 +0200
@@ -75,8 +75,8 @@
# Installation
install (TARGETS ILU
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib64
+ LIBRARY DESTINATION lib64
RUNTIME DESTINATION bin
)
install (FILES ../include/IL/ilu.h DESTINATION include/IL)
diff -Nru DevIL-1.8.0.orig/DevIL/src-ILU/pkgconfig/ILU.pc.cmake.in DevIL-1.8.0/DevIL/src-ILU/pkgconfig/ILU.pc.cmake.in
--- DevIL-1.8.0.orig/DevIL/src-ILU/pkgconfig/ILU.pc.cmake.in 2020-04-13 04:41:31.000000000 +0200
+++ DevIL-1.8.0/DevIL/src-ILU/pkgconfig/ILU.pc.cmake.in 2020-04-16 13:41:42.636000000 +0200
@@ -1,7 +1,7 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}
includedir=${prefix}/include
-libdir=${exec_prefix}/lib
+libdir=${exec_prefix}/lib64
Name: ILU
Description: Developer's Image Library - ILU part (image library utilities)
diff -Nru DevIL-1.8.0.orig/DevIL/src-ILUT/CMakeLists.txt DevIL-1.8.0/DevIL/src-ILUT/CMakeLists.txt
--- DevIL-1.8.0.orig/DevIL/src-ILUT/CMakeLists.txt 2020-04-16 13:36:56.475000000 +0200
+++ DevIL-1.8.0/DevIL/src-ILUT/CMakeLists.txt 2020-04-16 13:41:21.735000000 +0200
@@ -73,8 +73,8 @@
# Installation
install (TARGETS ILUT
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib64
+ LIBRARY DESTINATION lib64
RUNTIME DESTINATION bin
)
install (FILES ../include/IL/ilut.h DESTINATION include/IL)
diff -Nru DevIL-1.8.0.orig/DevIL/src-ILUT/pkgconfig/ILUT.pc.cmake.in DevIL-1.8.0/DevIL/src-ILUT/pkgconfig/ILUT.pc.cmake.in
--- DevIL-1.8.0.orig/DevIL/src-ILUT/pkgconfig/ILUT.pc.cmake.in 2020-04-13 04:41:31.000000000 +0200
+++ DevIL-1.8.0/DevIL/src-ILUT/pkgconfig/ILUT.pc.cmake.in 2020-04-16 13:41:33.302000000 +0200
@@ -1,7 +1,7 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}
includedir=${prefix}/include
-libdir=${exec_prefix}/lib
+libdir=${exec_prefix}/lib64
Name: ILUT
Description: Developer's Image Library - ILUT part (connection to higher level libraries)

View File

@ -1,60 +1,34 @@
Name: libdevil Name: libdevil
Version: 1.7.8 Version: 1.8.0
Release: 4mamba Release: 1mamba
Summary: A full featured cross-platform image library Summary: A full featured cross-platform image library
Group: System/Libraries Group: System/Libraries
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://openil.sourceforge.net URL: http://openil.sourceforge.net
Source: http://downloads.sourceforge.net/project/openil/DevIL/%{version}/DevIL-%{version}.tar.gz Source: https://github.com/DentonW/DevIL.git/v%{version}/DevIL-%{version}.tar.bz2
Patch0: DevIL-1.6.8-header1.patch Patch0: DevIL-1.6.8-header1.patch
Patch1: DevIL-1.6.8-header2.patch Patch1: DevIL-1.6.8-header2.patch
Patch2: DevIL-1.6.8-ilut.patch Patch2: DevIL-1.6.8-ilut.patch
Patch3: ilu.h.patch Patch3: ilu.h.patch
Patch4: il.h.patch Patch4: il.h.patch
Patch5: %{name}-1.7.8-png14.patch Patch5: %{name}-1.7.8-png14.patch
Patch6: libdevil-1.8.0-soversion.patch
Patch7: libdevil-1.8.0-x86_64-libdir.patch
Patch8: libdevil-1.8.0-FS70085.patch
License: LGPL License: LGPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: liballegro4-devel BuildRequires: ldconfig
BuildRequires: libdirectfb-devel
BuildRequires: libfreeglut-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
BuildRequires: libICE-devel
BuildRequires: libilmbase-devel
BuildRequires: libjasper-devel BuildRequires: libjasper-devel
BuildRequires: libjbig-devel
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: liblcms-devel BuildRequires: liblcms2-devel
BuildRequires: liblzma-devel
BuildRequires: libmng-devel
BuildRequires: libopenexr-devel
BuildRequires: libpng12-devel
BuildRequires: libpng-devel BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libSDL-devel
BuildRequires: libSM-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libtiff-devel BuildRequires: libtiff-devel
BuildRequires: libts-devel
BuildRequires: libuuid-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXi-devel
BuildRequires: libXmu-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libXt-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libz-devel BuildRequires: libz-devel
BuildRequires: pkg-config
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
Requires(post):%{__install_info} Requires(post):%{__install_info}
@ -85,101 +59,62 @@ Requires: %{name}-devel = %{version}
%description static %description static
DevIL is an Open Source image library whose distribution is done under the terms of the GNU LGPL license. DevIL is an Open Source image library whose distribution is done under the terms of the GNU LGPL license.
DevIL offers you a simple way to implement loading, manipulating, filtering, converting, displaying, saving from/to several different image formats in your own project. DevIL offers you a simple way to implement loading, manipulating, filtering, converting, displaying, saving from/to several different image formats in your own project.
%{name} static library. %{name} static library.
#% debug_package
%prep %prep
%setup -q -n devil-%{version} %setup -q -n DevIL-%{version}
#%patch0 -p1 %patch6 -p1
#%patch1 -p1 %ifarch aarch64 x86_64
#%patch2 -p1 %patch7 -p1
#%patch3 -p1 %endif
#%patch4 -p1 %patch8 -p1
%patch5 -p1
%build %build
%configure \ cd DevIL
--with-pic \ %cmake -d build
--with-gnu-ld \
--enable-shared \
--with-x \
--enable-static \
--enable-ILU=yes \
--enable-ILUT=yes \
LDFLAGS="$LDFLAGS -lpng"
%make %make
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall cd DevIL
%makeinstall -C build
%{__mkdir_p} %{buildroot}%{_libdir}/pkgconfig %ifarch x86_64 aarch64
cat > %{buildroot}%{_libdir}/pkgconfig/devil.pc << EOF mv %{buildroot}%{_prefix}/lib/pkgconfig %{buildroot}%{_libdir}
prefix=%{_prefix} %endif
exec_prefix=%{_prefix}
libdir=%{_libdir}
includedir=%{_includedir}/IL
Name: Developers Image Library
Description: An image library.
Requires:
Version: 1.7.8
Libs: -L%{_libdir} -Wl,--export-dynamic -lalleg-4.4.0 -lalleg_unsharable -lIL -lILU -lILUT
Cflags: -I%{_includedir}/IL
EOF
%clean %clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post %post -p /sbin/ldconfig
/sbin/ldconfig
:
%postun %postun -p /sbin/ldconfig
/sbin/ldconfig
:
%post devel
%install_info DevIL_manual.info
:
%preun devel
%uninstall_info DevIL_manual.info
:
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/ilur
%{_libdir}/libIL.so.* %{_libdir}/libIL.so.*
%{_libdir}/libILU.so.* %{_libdir}/libILU.so.*
%{_libdir}/libILUT.so.* %{_libdir}/libILUT.so.*
%doc AUTHORS COPYING %doc LICENSE
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%dir %{_includedir}/IL %dir %{_includedir}/IL
%{_includedir}/IL/*.h %{_includedir}/IL/*.h
%{_includedir}/IL/*.hpp
%{_libdir}/libIL.la
%{_libdir}/libIL.so %{_libdir}/libIL.so
%{_libdir}/libILU.la
%{_libdir}/libILU.so %{_libdir}/libILU.so
%{_libdir}/libILUT.la
%{_libdir}/libILUT.so %{_libdir}/libILUT.so
%{_libdir}/pkgconfig/IL.pc %{_libdir}/pkgconfig/IL.pc
%{_libdir}/pkgconfig/ILU.pc %{_libdir}/pkgconfig/ILU.pc
%{_libdir}/pkgconfig/ILUT.pc %{_libdir}/pkgconfig/ILUT.pc
%{_libdir}/pkgconfig/devil.pc
%{_infodir}/DevIL_manual.info.gz
%doc CREDITS ChangeLog NEWS README README.unix
%doc TODO
%files static
%defattr(-,root,root)
%{_libdir}/*.a
%changelog %changelog
* Thu Apr 16 2020 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
- automatic version update by autodist
* Thu Oct 18 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-4mamba * Thu Oct 18 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-4mamba
- moved info file to -devel package and other small specfile fixes - moved info file to -devel package and other small specfile fixes