moved info file to -devel package and other small specfile fixes [release 1.7.8-4mamba;Thu Oct 18 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 04:06:21 +01:00
parent da275ada2e
commit 08598b9afb
8 changed files with 402 additions and 0 deletions

11
DevIL-1.6.8-header1.patch Normal file
View File

@ -0,0 +1,11 @@
--- DevIL-1.6.8/include/IL/ilu_region.h 2004-07-08 21:13:03.000000000 +0200
+++ DevIL-1.6.8/include/IL/ilu_region.h-gil 2008-08-15 04:17:21.000000000 +0200
@@ -13,7 +13,7 @@
#ifndef ILU_REGION_H
#define ILU_REGION_H
-#include "ilu_internal.h"
+#include <IL/il.h>
typedef struct Edge

11
DevIL-1.6.8-header2.patch Normal file
View File

@ -0,0 +1,11 @@
--- DevIL-1.6.8/src-ILU/src/ilu_region.c 2003-04-06 13:44:30.000000000 +0200
+++ DevIL-1.6.8/src-ILU/src/ilu_region.c-gil 2008-08-15 04:07:59.000000000 +0200
@@ -12,7 +12,7 @@
#include "ilu_region.h"
-
+#include "ilu_internal.h"
ILpointi *RegionPointsi = NULL;
ILpointf *RegionPointsf = NULL;

11
DevIL-1.6.8-ilut.patch Normal file
View File

@ -0,0 +1,11 @@
--- DevIL-1.6.8/include/IL/ilut.h 2006-07-04 16:43:23.000000000 +0200
+++ DevIL-1.6.8/include/IL/ilut.h-gil 2008-08-15 04:47:58.000000000 +0200
@@ -234,7 +234,7 @@
extern "C" {
#endif
- ILAPI BITMAP* ILAPIENTRY ilutAllegLoadImage(Lstring FileName);
+ ILAPI BITMAP* ILAPIENTRY ilutAllegLoadImage(ILstring FileName);
ILAPI BITMAP* ILAPIENTRY ilutConvertToAlleg(PALETTE Pal);
#endif//ILUT_USE_ALLEGRO

View File

@ -1,2 +1,7 @@
# libdevil # libdevil
Developer's Image Library (DevIL) is a programmer's library to develop applications with very powerful image loading capabilities, yet is easy for a developer to learn and use. Ultimate control of images is left to the developer, so unnecessary conversions, etc. are not performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert, manipulate, filter and display a wide variety of image formats.
Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
DevIL currently supports the following APIs for display: OpenGL, Windows GDI, SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual Basic, Power Basic and Dev-C++.

74
il.h.patch Normal file
View File

@ -0,0 +1,74 @@
--- DevIL-1.6.8/include/IL/il.h.orig 2007-08-12 01:37:20.000000000 -0400
+++ DevIL-1.6.8/include/IL/il.h 2007-08-12 01:37:37.000000000 -0400
@@ -445,15 +445,15 @@
ILAPI ILvoid ILAPIENTRY ilBindImage(ILuint Image);
ILAPI ILboolean ILAPIENTRY ilBlit(ILuint Source, ILint DestX, ILint DestY, ILint DestZ, ILuint SrcX, ILuint SrcY, ILuint SrcZ, ILuint Width, ILuint Height, ILuint Depth);
ILAPI ILvoid ILAPIENTRY ilClearColour(ILclampf Red, ILclampf Green, ILclampf Blue, ILclampf Alpha);
-ILAPI ILboolean ILAPIENTRY ilClearImage(ILvoid);
-ILAPI ILuint ILAPIENTRY ilCloneCurImage(ILvoid);
+ILAPI ILboolean ILAPIENTRY ilClearImage();
+ILAPI ILuint ILAPIENTRY ilCloneCurImage();
ILAPI ILboolean ILAPIENTRY ilCompressFunc(ILenum Mode);
ILAPI ILboolean ILAPIENTRY ilConvertImage(ILenum DestFormat, ILenum DestType);
ILAPI ILboolean ILAPIENTRY ilConvertPal(ILenum DestFormat);
ILAPI ILboolean ILAPIENTRY ilCopyImage(ILuint Src);
ILAPI ILuint ILAPIENTRY ilCopyPixels(ILuint XOff, ILuint YOff, ILuint ZOff, ILuint Width, ILuint Height, ILuint Depth, ILenum Format, ILenum Type, ILvoid *Data);
ILAPI ILuint ILAPIENTRY ilCreateSubImage(ILenum Type, ILuint Num);
-ILAPI ILboolean ILAPIENTRY ilDefaultImage(ILvoid);
+ILAPI ILboolean ILAPIENTRY ilDefaultImage();
ILAPI ILvoid ILAPIENTRY ilDeleteImage(const ILuint Num);
ILAPI ILvoid ILAPIENTRY ilDeleteImages(ILsizei Num, const ILuint *Images);
ILAPI ILboolean ILAPIENTRY ilDisable(ILenum Mode);
@@ -464,16 +464,16 @@
ILAPI ILubyte* ILAPIENTRY ilGetAlpha(ILenum Type);
ILAPI ILboolean ILAPIENTRY ilGetBoolean(ILenum Mode);
ILAPI ILvoid ILAPIENTRY ilGetBooleanv(ILenum Mode, ILboolean *Param);
-ILAPI ILubyte* ILAPIENTRY ilGetData(ILvoid);
+ILAPI ILubyte* ILAPIENTRY ilGetData();
ILAPI ILuint ILAPIENTRY ilGetDXTCData(ILvoid *Buffer, ILuint BufferSize, ILenum DXTCFormat);
-ILAPI ILenum ILAPIENTRY ilGetError(ILvoid);
+ILAPI ILenum ILAPIENTRY ilGetError();
ILAPI ILint ILAPIENTRY ilGetInteger(ILenum Mode);
ILAPI ILvoid ILAPIENTRY ilGetIntegerv(ILenum Mode, ILint *Param);
-ILAPI ILuint ILAPIENTRY ilGetLumpPos(ILvoid);
-ILAPI ILubyte* ILAPIENTRY ilGetPalette(ILvoid);
+ILAPI ILuint ILAPIENTRY ilGetLumpPos();
+ILAPI ILubyte* ILAPIENTRY ilGetPalette();
ILAPI ILstring ILAPIENTRY ilGetString(ILenum StringName);
ILAPI ILvoid ILAPIENTRY ilHint(ILenum Target, ILenum Mode);
-ILAPI ILvoid ILAPIENTRY ilInit(ILvoid);
+ILAPI ILvoid ILAPIENTRY ilInit();
ILAPI ILboolean ILAPIENTRY ilIsDisabled(ILenum Mode);
ILAPI ILboolean ILAPIENTRY ilIsEnabled(ILenum Mode);
ILAPI ILboolean ILAPIENTRY ilIsImage(ILuint Image);
@@ -489,7 +489,7 @@
ILAPI ILvoid ILAPIENTRY ilModAlpha( ILdouble AlphaValue );
ILAPI ILboolean ILAPIENTRY ilOriginFunc(ILenum Mode);
ILAPI ILboolean ILAPIENTRY ilOverlayImage(ILuint Source, ILint XCoord, ILint YCoord, ILint ZCoord);
-ILAPI ILvoid ILAPIENTRY ilPopAttrib(ILvoid);
+ILAPI ILvoid ILAPIENTRY ilPopAttrib();
ILAPI ILvoid ILAPIENTRY ilPushAttrib(ILuint Bits);
ILAPI ILvoid ILAPIENTRY ilRegisterFormat(ILenum Format);
ILAPI ILboolean ILAPIENTRY ilRegisterLoad(const ILstring Ext, IL_LOADPROC Load);
@@ -501,9 +501,9 @@
ILAPI ILvoid ILAPIENTRY ilRegisterType(ILenum Type);
ILAPI ILboolean ILAPIENTRY ilRemoveLoad(const ILstring Ext);
ILAPI ILboolean ILAPIENTRY ilRemoveSave(const ILstring Ext);
-ILAPI ILvoid ILAPIENTRY ilResetMemory(ILvoid);
-ILAPI ILvoid ILAPIENTRY ilResetRead(ILvoid);
-ILAPI ILvoid ILAPIENTRY ilResetWrite(ILvoid);
+ILAPI ILvoid ILAPIENTRY ilResetMemory();
+ILAPI ILvoid ILAPIENTRY ilResetRead();
+ILAPI ILvoid ILAPIENTRY ilResetWrite();
ILAPI ILboolean ILAPIENTRY ilSave(ILenum Type, ILstring FileName);
ILAPI ILuint ILAPIENTRY ilSaveF(ILenum Type, ILHANDLE File);
ILAPI ILboolean ILAPIENTRY ilSaveImage(const ILstring FileName);
@@ -518,7 +518,7 @@
ILAPI ILvoid ILAPIENTRY ilSetRead(fOpenRProc, fCloseRProc, fEofProc, fGetcProc, fReadProc, fSeekRProc, fTellRProc);
ILAPI ILvoid ILAPIENTRY ilSetString(ILenum Mode, const char *String);
ILAPI ILvoid ILAPIENTRY ilSetWrite(fOpenWProc, fCloseWProc, fPutcProc, fSeekWProc, fTellWProc, fWriteProc);
-ILAPI ILvoid ILAPIENTRY ilShutDown(ILvoid);
+ILAPI ILvoid ILAPIENTRY ilShutDown();
ILAPI ILboolean ILAPIENTRY ilTexImage(ILuint Width, ILuint Height, ILuint Depth, ILubyte numChannels, ILenum Format, ILenum Type, ILvoid *Data);
ILAPI ILenum ILAPIENTRY ilTypeFromExt(const ILstring FileName);
ILAPI ILboolean ILAPIENTRY ilTypeFunc(ILenum Mode);

63
ilu.h.patch Normal file
View File

@ -0,0 +1,63 @@
--- DevIL-1.6.8/include/IL/ilu.h.orig 2007-08-12 01:40:11.000000000 -0400
+++ DevIL-1.6.8/include/IL/ilu.h 2007-08-12 01:40:12.000000000 -0400
@@ -122,37 +122,37 @@
// ImageLib Utility Functions
-ILAPI ILboolean ILAPIENTRY iluAlienify(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluAlienify();
ILAPI ILboolean ILAPIENTRY iluBlurAvg(ILuint Iter);
ILAPI ILboolean ILAPIENTRY iluBlurGaussian(ILuint Iter);
-ILAPI ILboolean ILAPIENTRY iluBuildMipmaps(ILvoid);
-ILAPI ILuint ILAPIENTRY iluColoursUsed(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluBuildMipmaps();
+ILAPI ILuint ILAPIENTRY iluColoursUsed();
ILAPI ILboolean ILAPIENTRY iluCompareImage(ILuint Comp);
ILAPI ILboolean ILAPIENTRY iluContrast(ILfloat Contrast);
ILAPI ILboolean ILAPIENTRY iluCrop(ILuint XOff, ILuint YOff, ILuint ZOff, ILuint Width, ILuint Height, ILuint Depth);
ILAPI ILvoid ILAPIENTRY iluDeleteImage(ILuint Id);
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectE(ILvoid);
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectP(ILvoid);
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectS(ILvoid);
-ILAPI ILboolean ILAPIENTRY iluEmboss(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectE();
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectP();
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectS();
+ILAPI ILboolean ILAPIENTRY iluEmboss();
ILAPI ILboolean ILAPIENTRY iluEnlargeCanvas(ILuint Width, ILuint Height, ILuint Depth);
ILAPI ILboolean ILAPIENTRY iluEnlargeImage(ILfloat XDim, ILfloat YDim, ILfloat ZDim);
-ILAPI ILboolean ILAPIENTRY iluEqualize(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluEqualize();
ILAPI ILstring ILAPIENTRY iluErrorString(ILenum Error);
ILAPI ILboolean ILAPIENTRY iluConvolution(ILint *matrix, ILint scale, ILint bias);
-ILAPI ILboolean ILAPIENTRY iluFlipImage(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluFlipImage();
ILAPI ILboolean ILAPIENTRY iluGammaCorrect(ILfloat Gamma);
-ILAPI ILuint ILAPIENTRY iluGenImage(ILvoid);
+ILAPI ILuint ILAPIENTRY iluGenImage();
ILAPI ILvoid ILAPIENTRY iluGetImageInfo(ILinfo *Info);
ILAPI ILint ILAPIENTRY iluGetInteger(ILenum Mode);
ILAPI ILvoid ILAPIENTRY iluGetIntegerv(ILenum Mode, ILint *Param);
ILAPI ILstring ILAPIENTRY iluGetString(ILenum StringName);
ILAPI ILvoid ILAPIENTRY iluImageParameter(ILenum PName, ILenum Param);
-ILAPI ILvoid ILAPIENTRY iluInit(ILvoid);
-ILAPI ILboolean ILAPIENTRY iluInvertAlpha(ILvoid);
+ILAPI ILvoid ILAPIENTRY iluInit();
+ILAPI ILboolean ILAPIENTRY iluInvertAlpha();
ILAPI ILuint ILAPIENTRY iluLoadImage(const ILstring FileName);
-ILAPI ILboolean ILAPIENTRY iluMirror(ILvoid);
-ILAPI ILboolean ILAPIENTRY iluNegative(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluMirror();
+ILAPI ILboolean ILAPIENTRY iluNegative();
ILAPI ILboolean ILAPIENTRY iluNoisify(ILclampf Tolerance);
ILAPI ILboolean ILAPIENTRY iluPixelize(ILuint PixSize);
ILAPI ILvoid ILAPIENTRY iluRegionfv(ILpointf *Points, ILuint n);
@@ -166,7 +166,7 @@
ILAPI ILboolean ILAPIENTRY iluScaleAlpha(ILfloat scale);
ILAPI ILboolean ILAPIENTRY iluScaleColours(ILfloat r, ILfloat g, ILfloat b);
ILAPI ILboolean ILAPIENTRY iluSharpen(ILfloat Factor, ILuint Iter);
-ILAPI ILboolean ILAPIENTRY iluSwapColours(ILvoid);
+ILAPI ILboolean ILAPIENTRY iluSwapColours();
ILAPI ILboolean ILAPIENTRY iluWave(ILfloat Angle);
#define iluColorsUsed iluColoursUsed

View File

@ -0,0 +1,24 @@
diff -Nru devil-1.7.8.orig//src-IL/src/il_icon.c devil-1.7.8/src-IL/src/il_icon.c
--- devil-1.7.8.orig//src-IL/src/il_icon.c 2009-03-08 08:10:09.000000000 +0100
+++ devil-1.7.8/src-IL/src/il_icon.c 2010-11-12 19:05:06.323475526 +0100
@@ -525,7 +525,7 @@
// Expand low-bit-depth grayscale images to 8 bits
if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
- png_set_gray_1_2_4_to_8(ico_png_ptr);
+ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
}
// Expand RGB images with transparency to full alpha channels
diff -Nru devil-1.7.8.orig//src-IL/src/il_png.c devil-1.7.8/src-IL/src/il_png.c
--- devil-1.7.8.orig//src-IL/src/il_png.c 2009-03-08 08:10:09.000000000 +0100
+++ devil-1.7.8/src-IL/src/il_png.c 2010-11-12 19:04:51.957483550 +0100
@@ -278,7 +278,7 @@
// Expand low-bit-depth grayscale images to 8 bits
if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
- png_set_gray_1_2_4_to_8(png_ptr);
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
}
// Expand RGB images with transparency to full alpha channels

203
libdevil.spec Normal file
View File

@ -0,0 +1,203 @@
Name: libdevil
Version: 1.7.8
Release: 4mamba
Summary: A full featured cross-platform image library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://openil.sourceforge.net
Source: http://downloads.sourceforge.net/project/openil/DevIL/%{version}/DevIL-%{version}.tar.gz
Patch0: DevIL-1.6.8-header1.patch
Patch1: DevIL-1.6.8-header2.patch
Patch2: DevIL-1.6.8-ilut.patch
Patch3: ilu.h.patch
Patch4: il.h.patch
Patch5: %{name}-1.7.8-png14.patch
License: LGPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: liballegro4-devel
BuildRequires: libdirectfb-devel
BuildRequires: libfreeglut-devel
BuildRequires: libgcc
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
BuildRequires: libICE-devel
BuildRequires: libilmbase-devel
BuildRequires: libjasper-devel
BuildRequires: libjbig-devel
BuildRequires: libjpeg-devel
BuildRequires: liblcms-devel
BuildRequires: liblzma-devel
BuildRequires: libmng-devel
BuildRequires: libopenexr-devel
BuildRequires: libpng12-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libSDL-devel
BuildRequires: libSM-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtiff-devel
BuildRequires: libts-devel
BuildRequires: libuuid-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXi-devel
BuildRequires: libXmu-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libXt-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libz-devel
BuildRequires: pkg-config
## AUTOBUILDREQ-END
Requires(post):%{__install_info}
%description
Developer's Image Library (DevIL) is a programmer's library to develop applications with very powerful image loading capabilities, yet is easy for a developer to learn and use. Ultimate control of images is left to the developer, so unnecessary conversions, etc. are not performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert, manipulate, filter and display a wide variety of image formats.
Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
DevIL currently supports the following APIs for display: OpenGL, Windows GDI, SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual Basic, Power Basic and Dev-C++.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Developer's Image Library (DevIL) is a programmer's library to develop applications with very powerful image loading capabilities, yet is easy for a developer to learn and use. Ultimate control of images is left to the developer, so unnecessary conversions, etc. are not performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert, manipulate, filter and display a wide variety of image formats.
Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
DevIL currently supports the following APIs for display: OpenGL, Windows GDI, SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual Basic, Power Basic and Dev-C++.
This package contains static libraries and header files need for development.
%package static
Summary: %{name} static library
Group: Development/Libraries
Requires: %{name}-devel = %{version}
%description static
DevIL is an Open Source image library whose distribution is done under the terms of the GNU LGPL license.
DevIL offers you a simple way to implement loading, manipulating, filtering, converting, displaying, saving from/to several different image formats in your own project.
%{name} static library.
%prep
%setup -q -n devil-%{version}
#%patch0 -p1
#%patch1 -p1
#%patch2 -p1
#%patch3 -p1
#%patch4 -p1
%patch5 -p1
%build
%configure \
--with-pic \
--with-gnu-ld \
--enable-shared \
--with-x \
--enable-static \
--enable-ILU=yes \
--enable-ILUT=yes \
LDFLAGS="$LDFLAGS -lpng"
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%{__mkdir_p} %{buildroot}%{_libdir}/pkgconfig
cat > %{buildroot}%{_libdir}/pkgconfig/devil.pc << EOF
prefix=%{_prefix}
exec_prefix=%{_prefix}
libdir=%{_libdir}
includedir=%{_includedir}/IL
Name: Developers Image Library
Description: An image library.
Requires:
Version: 1.7.8
Libs: -L%{_libdir} -Wl,--export-dynamic -lalleg-4.4.0 -lalleg_unsharable -lIL -lILU -lILUT
Cflags: -I%{_includedir}/IL
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
/sbin/ldconfig
:
%postun
/sbin/ldconfig
:
%post devel
%install_info DevIL_manual.info
:
%preun devel
%uninstall_info DevIL_manual.info
:
%files
%defattr(-,root,root)
%{_bindir}/ilur
%{_libdir}/libIL.so.*
%{_libdir}/libILU.so.*
%{_libdir}/libILUT.so.*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/IL
%{_includedir}/IL/*.h
%{_includedir}/IL/*.hpp
%{_libdir}/libIL.la
%{_libdir}/libIL.so
%{_libdir}/libILU.la
%{_libdir}/libILU.so
%{_libdir}/libILUT.la
%{_libdir}/libILUT.so
%{_libdir}/pkgconfig/IL.pc
%{_libdir}/pkgconfig/ILU.pc
%{_libdir}/pkgconfig/ILUT.pc
%{_libdir}/pkgconfig/devil.pc
%{_infodir}/DevIL_manual.info.gz
%doc CREDITS ChangeLog NEWS README README.unix
%doc TODO
%files static
%defattr(-,root,root)
%{_libdir}/*.a
%changelog
* Thu Oct 18 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-4mamba
- moved info file to -devel package and other small specfile fixes
* Fri Nov 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-3mamba
- fix info page installation
- remove dependency on libpng 1.2 (added patch)
* Thu Nov 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-2mamba
- rebuilt with libpng 1.4
* Wed Aug 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.8-1mamba
- update to 1.7.8
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 1.6.8-3mamba
- automatic rebuild by autodist
* Mon Aug 18 2008 gil <puntogil@libero.it> 1.6.8-2mamba
- added: requires liballegro; devil.pc; devel static
* Mon Dec 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> rc2-1mamba
- package created by autospec