197 lines
6.7 KiB
RPMSpec
197 lines
6.7 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
Name: libdbusmenu
|
|
Version: 16.04.0
|
|
Release: 1mamba
|
|
Summary: DBus Menu Library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
|
URL: https://launchpad.net/dbusmenu
|
|
Source: http://launchpad.net/dbusmenu/%{majver}/%{version}/+download/libdbusmenu-%{version}.tar.gz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: gtk-doc
|
|
BuildRequires: libatk-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libdbus-devel
|
|
BuildRequires: libdbus-glib-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgtk-devel
|
|
BuildRequires: libjson-glib-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libxml2-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: gobject-introspection-devel
|
|
BuildRequires: vala-tools
|
|
BuildRequires: valgrind-devel
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
This package contains static libraries and header files need for development.
|
|
|
|
%package jsonloader
|
|
Group: System/Libraries
|
|
Summary: DBus Menu Library
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description jsonloader
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
|
|
%package jsonloader-devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}-jsonloader
|
|
Requires: %{name}-jsonloader = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description jsonloader-devel
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
This package contains static libraries and header files need for development.
|
|
|
|
%package gtk
|
|
Group: System/Libraries
|
|
Summary: DBus Menu Library
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description gtk
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
|
|
%package gtk-devel
|
|
Group: Development/Libraries
|
|
Summary: Static libraries and headers for %{name}-jsonloader
|
|
Requires: %{name}-gtk = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description gtk-devel
|
|
A small little library that was created by pulling out some comon code out of indicator-applet.
|
|
It passes a menu structure across DBus so that a program can create a menu simply without worrying about how it is displayed on the other side of the bus.
|
|
This package contains static libraries and header files need for development.
|
|
|
|
%package apidocs
|
|
Summary: %{name} API documentation
|
|
Group: Documentation
|
|
Requires: gtk-doc
|
|
|
|
%description apidocs
|
|
%{name} API documentation.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%configure --enable-introspection
|
|
%make -j1
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
rm -fr %{buildroot}/usr/share/doc/libdbusmenu
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%post jsonloader -p /sbin/ldconfig
|
|
%postun jsonloader -p /sbin/ldconfig
|
|
|
|
%post gtk -p /sbin/ldconfig
|
|
%postun gtk -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libdbusmenu-glib.so.*
|
|
%{_libdir}/girepository-1.0/Dbusmenu-0.4.typelib
|
|
%{_datadir}/gir-1.0/Dbusmenu-0.4.gir
|
|
%{_datadir}/vala/vapi/Dbusmenu-0.4.vapi
|
|
%doc COPYING README
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_includedir}/libdbusmenu-*/libdbusmenu-glib
|
|
%{_libdir}/libdbusmenu-glib.a
|
|
%{_libdir}/libdbusmenu-glib.la
|
|
%{_libdir}/libdbusmenu-glib.so
|
|
%{_libdir}/pkgconfig/dbusmenu-glib-0.4.pc
|
|
#
|
|
%{_libexecdir}/dbusmenu-bench
|
|
%{_libexecdir}/dbusmenu-dumper
|
|
%{_libexecdir}/dbusmenu-testapp
|
|
|
|
%files jsonloader
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libdbusmenu-jsonloader.so.*
|
|
%{_datadir}/libdbusmenu/json/test-gtk-label.json
|
|
|
|
%files jsonloader-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/libdbusmenu-glib-0.4/libdbusmenu-jsonloader
|
|
%{_includedir}/libdbusmenu-glib-0.4/libdbusmenu-jsonloader/*
|
|
%{_libdir}/libdbusmenu-jsonloader.a
|
|
%{_libdir}/libdbusmenu-jsonloader.la
|
|
%{_libdir}/libdbusmenu-jsonloader.so
|
|
%{_libdir}/pkgconfig/dbusmenu-jsonloader-0.4.pc
|
|
|
|
%files gtk
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libdbusmenu-gtk3.so.*
|
|
%{_libdir}/girepository-1.0/DbusmenuGtk3-0.4.typelib
|
|
|
|
%files gtk-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/libdbusmenu-gtk3-0.4
|
|
%dir %{_includedir}/libdbusmenu-gtk3-0.4/libdbusmenu-gtk
|
|
%{_includedir}/libdbusmenu-gtk3-0.4/libdbusmenu-gtk/*.h
|
|
%{_libdir}/libdbusmenu-gtk3.a
|
|
%{_libdir}/libdbusmenu-gtk3.la
|
|
%{_libdir}/libdbusmenu-gtk3.so
|
|
%{_libdir}/pkgconfig/dbusmenu-gtk3-0.4.pc
|
|
%{_datadir}/gir-1.0/DbusmenuGtk3-0.4.gir
|
|
%{_datadir}/vala/vapi/DbusmenuGtk3-0.4.vapi
|
|
|
|
%files apidocs
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/gtk-doc/html/libdbusmenu-glib
|
|
%{_datadir}/gtk-doc/html/libdbusmenu-glib/*
|
|
%dir %{_datadir}/gtk-doc/html/libdbusmenu-gtk
|
|
%{_datadir}/gtk-doc/html/libdbusmenu-gtk/*
|
|
|
|
%changelog
|
|
* Wed Mar 02 2016 Automatic Build System <autodist@mambasoft.it> 16.04.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 12.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
|
|
- update to 0.6.1
|
|
|
|
* Tue Mar 27 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
|
- update to 0.5.1
|
|
|
|
* Sat Aug 28 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.3.12-1mamba
|
|
- update to 0.3.12
|
|
|
|
* Thu Aug 19 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.3.11-1mamba
|
|
- package created by autospec
|