automatic version update by autodist [release 0.102-1mamba;Mon Feb 17 2014]
This commit is contained in:
parent
a90804b9ac
commit
9f052875be
@ -1,2 +1,6 @@
|
|||||||
# libdbus-glib
|
# libdbus-glib
|
||||||
|
|
||||||
|
D-BUS is a message bus, used for sending messages between applications.
|
||||||
|
Conceptually, it fits somewhere in between raw sockets and CORBA in terms of complexity.
|
||||||
|
This package contains the GLIB binding libraries for D-BUS.
|
||||||
|
|
||||||
|
@ -0,0 +1,40 @@
|
|||||||
|
From 3e0828f57c3925ea9b63d22ab82d991a0fea0536 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon McVittie <simon.mcvittie@collabora.co.uk>
|
||||||
|
Date: Thu, 02 Jun 2011 12:49:51 +0000
|
||||||
|
Subject: Fix regression in marshalling objects as object paths
|
||||||
|
|
||||||
|
This regressed while fixing fd.o #36811. NetworkManager apparently uses
|
||||||
|
this idiom.
|
||||||
|
|
||||||
|
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=37852
|
||||||
|
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628890
|
||||||
|
Tested-by: Michael Biebl <biebl@debian.org>
|
||||||
|
Reviewed-by: Colin Walters <walters@verbum.org>
|
||||||
|
---
|
||||||
|
diff --git a/dbus/dbus-gobject.c b/dbus/dbus-gobject.c
|
||||||
|
index 3b0bd17..7ee0b4f 100644
|
||||||
|
--- a/dbus/dbus-gobject.c
|
||||||
|
+++ b/dbus/dbus-gobject.c
|
||||||
|
@@ -3049,16 +3049,16 @@ out:
|
||||||
|
const char *
|
||||||
|
_dbus_gobject_get_path (GObject *obj)
|
||||||
|
{
|
||||||
|
- GSList *registrations;
|
||||||
|
+ ObjectExport *oe;
|
||||||
|
ObjectRegistration *o;
|
||||||
|
|
||||||
|
- registrations = g_object_get_data (obj, "dbus_glib_object_registrations");
|
||||||
|
+ oe = g_object_get_data (obj, "dbus_glib_object_registrations");
|
||||||
|
|
||||||
|
- if (registrations == NULL)
|
||||||
|
+ if (oe == NULL || oe->registrations == NULL)
|
||||||
|
return NULL;
|
||||||
|
|
||||||
|
/* First one to have been registered wins */
|
||||||
|
- o = registrations->data;
|
||||||
|
+ o = oe->registrations->data;
|
||||||
|
|
||||||
|
return o->object_path;
|
||||||
|
}
|
||||||
|
--
|
||||||
|
cgit v0.8.3-6-g21f6
|
184
libdbus-glib.spec
Normal file
184
libdbus-glib.spec
Normal file
@ -0,0 +1,184 @@
|
|||||||
|
Name: libdbus-glib
|
||||||
|
Version: 0.102
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GLIB bindings for %{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://dbus.freedesktop.org
|
||||||
|
Source: http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.94-fix_regression_in_marshalling_objects_as_object_paths.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: gtk-doc
|
||||||
|
Obsoletes: dbus-glib
|
||||||
|
Provides: dbus-glib = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: dbus1-glib
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
D-BUS is a message bus, used for sending messages between applications.
|
||||||
|
Conceptually, it fits somewhere in between raw sockets and CORBA in terms of complexity.
|
||||||
|
This package contains the GLIB binding libraries for D-BUS.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: dbus1-glib-devel
|
||||||
|
Provides: dbus1-glib-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: dbus-glib-devel
|
||||||
|
Provides: dbus-glib-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
D-BUS is a message bus, used for sending messages between applications.
|
||||||
|
Conceptually, it fits somewhere in between raw sockets and CORBA in terms of complexity.
|
||||||
|
This package contains the development files for GLIB binding libraries for
|
||||||
|
D-BUS.
|
||||||
|
|
||||||
|
%package tools
|
||||||
|
Group: System/Tools
|
||||||
|
Summary: Utility applications for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description tools
|
||||||
|
This package contains utility applications for %{name}.
|
||||||
|
|
||||||
|
%package apidocs
|
||||||
|
Group: Documentation
|
||||||
|
Summary: %{name} API documentation
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: gtk-doc
|
||||||
|
|
||||||
|
%description apidocs
|
||||||
|
This package includes the %{name} API documentation.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n dbus-glib-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --enable-gtk-doc
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libdbus-glib-1.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libdbus-glib-1.so
|
||||||
|
%{_libdir}/libdbus-glib-1.la
|
||||||
|
%{_libdir}/libdbus-glib-1.a
|
||||||
|
%{_includedir}/dbus-1.0/dbus/dbus-glib-bindings.h
|
||||||
|
%{_includedir}/dbus-1.0/dbus/dbus-gtype-specialized.h
|
||||||
|
#%{_includedir}/dbus-1.0/dbus/dbus-glib-error-enum.h
|
||||||
|
%{_includedir}/dbus-1.0/dbus/dbus-glib-lowlevel.h
|
||||||
|
%{_includedir}/dbus-1.0/dbus/dbus-glib.h
|
||||||
|
%{_includedir}/dbus-1.0/dbus/dbus-gvalue-parse-variant.h
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
%doc ChangeLog NEWS README
|
||||||
|
|
||||||
|
%files tools
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/bash_completion.d/dbus-bash-completion.sh
|
||||||
|
%{_bindir}/dbus-binding-tool
|
||||||
|
%{_libexecdir}/dbus-bash-completion-helper
|
||||||
|
%{_mandir}/man1/dbus-binding-tool.1.gz
|
||||||
|
|
||||||
|
%files apidocs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gtk-doc/html/dbus-glib
|
||||||
|
%{_datadir}/gtk-doc/html/dbus-glib/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Feb 17 2014 Automatic Build System <autodist@mambasoft.it> 0.102-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Feb 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.2-3mamba
|
||||||
|
- dbus-binding-tool moved to new -tool subpackage
|
||||||
|
|
||||||
|
* Tue Feb 11 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.2-2mamba
|
||||||
|
- documentation moved to apidocs subpackage
|
||||||
|
|
||||||
|
* Mon Feb 25 2013 Automatic Build System <autodist@mambasoft.it> 0.100.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.100-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jul 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.94-2mamba
|
||||||
|
- applied patch to fix a regression problem seen with NetworkManager 0.8.4
|
||||||
|
|
||||||
|
* Sat Jul 23 2011 Automatic Build System <autodist@mambasoft.it> 0.94-1mamba
|
||||||
|
- automatic update to 3.0.3.0 by autodist
|
||||||
|
|
||||||
|
* Mon Dec 06 2010 Automatic Build System <autodist@mambasoft.it> 0.92-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.88-2mamba
|
||||||
|
- removed unised build requirements and added --enable-gtk-doc
|
||||||
|
|
||||||
|
* Sat Aug 21 2010 Automatic Build System <autodist@mambasoft.it> 0.88-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 26 2010 Automatic Build System <autodist@mambasoft.it> 0.86-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Apr 27 2010 Automatic Build System <autodist@mambasoft.it> 0.86-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Jan 29 2010 Automatic Build System <autodist@mambasoft.it> 0.84-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Jul 22 2009 Automatic Build System <autodist@mambasoft.it> 0.82-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.80-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jan 08 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.78-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Jun 13 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.76-1mamba
|
||||||
|
- update to 0.76
|
||||||
|
|
||||||
|
* Thu May 22 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.74-2mamba
|
||||||
|
- fix use of automatic build requirements
|
||||||
|
|
||||||
|
* Sun May 11 2008 gil <puntogil@libero.it> 0.74-1mamba
|
||||||
|
- update to 0.74
|
||||||
|
- find new Build requires: glibc-devel libexpat-devel
|
||||||
|
|
||||||
|
* Sat Apr 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.73-1mamba
|
||||||
|
- update to version 0.73 by autospec
|
||||||
|
|
||||||
|
* Fri Nov 10 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.72-2qilnx
|
||||||
|
- libdbus-glib: obsolete dbus-glib
|
||||||
|
|
||||||
|
* Thu Nov 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.72-1qilnx
|
||||||
|
- update to version 0.72 by autospec
|
||||||
|
- dbus-binding-tool moved to devel package
|
||||||
|
|
||||||
|
* Wed Oct 25 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.71-2qilnx
|
||||||
|
- rebuilt for QiLinux
|
||||||
|
|
||||||
|
* Tue Oct 24 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.71-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user