rebuilt with debug package and tools subpackage, added patches [release 0.9.0-2mamba;Wed Dec 02 2020]
This commit is contained in:
parent
502de2adbb
commit
9c235b53c0
12
libdbus-c++-0.9.0-linkfix.patch
Normal file
12
libdbus-c++-0.9.0-linkfix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up libdbus-c++-0.9.0/src/Makefile.am.linkfix libdbus-c++-0.9.0/src/Makefile.am
|
||||
--- libdbus-c++-0.9.0/src/Makefile.am.linkfix 2013-12-17 16:07:22.326715886 +0100
|
||||
+++ libdbus-c++-0.9.0/src/Makefile.am 2013-12-17 16:07:34.474542044 +0100
|
||||
@@ -29,7 +29,7 @@ libdbus_c___1_la_CXXFLAGS = \
|
||||
-Wno-unused-parameter
|
||||
|
||||
libdbus_c___1_la_LIBADD = \
|
||||
- $(dbus_LIBS)
|
||||
+ $(dbus_LIBS) $(xml_LIBS)
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
$(dbus_CFLAGS) \
|
14
libdbus-c++-0.9.0-macro-collision.patch
Normal file
14
libdbus-c++-0.9.0-macro-collision.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -rupN libdbus-c++-0.9.0/examples/glib/dbus-browser.h libdbus-c++-0.9.0-new/examples/glib/dbus-browser.h
|
||||
--- libdbus-c++-0.9.0/examples/glib/dbus-browser.h 2015-03-05 23:43:26.903517530 +0100
|
||||
+++ libdbus-c++-0.9.0-new/examples/glib/dbus-browser.h 2011-11-28 16:03:19.000000000 +0100
|
||||
@@ -1,9 +1,9 @@
|
||||
#ifndef __DEMO_DBUS_BROWSER_H
|
||||
#define __DEMO_DBUS_BROWSER_H
|
||||
|
||||
+#include <gtkmm.h>
|
||||
#include <dbus-c++/dbus.h>
|
||||
#include <dbus-c++/glib-integration.h>
|
||||
-#include <gtkmm.h>
|
||||
|
||||
#include "dbus-glue.h"
|
||||
|
45
libdbus-c++-0.9.0-threading.patch
Normal file
45
libdbus-c++-0.9.0-threading.patch
Normal file
@ -0,0 +1,45 @@
|
||||
--- libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h.threading 2017-02-15 13:40:53.796004263 +0000
|
||||
+++ libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h 2017-02-15 13:40:46.907000493 +0000
|
||||
@@ -188,6 +188,7 @@
|
||||
/* classes for multithreading support
|
||||
*/
|
||||
|
||||
+#if 0
|
||||
class DXXAPI Mutex
|
||||
{
|
||||
public:
|
||||
@@ -243,9 +244,11 @@
|
||||
typedef bool (*CondVarWaitTimeoutFn)(CondVar *cv, Mutex *mx, int timeout);
|
||||
typedef void (*CondVarWakeOneFn)(CondVar *cv);
|
||||
typedef void (*CondVarWakeAllFn)(CondVar *cv);
|
||||
+#endif
|
||||
|
||||
void DXXAPI _init_threading();
|
||||
|
||||
+#if 0
|
||||
void DXXAPI _init_threading(
|
||||
MutexNewFn, MutexFreeFn, MutexLockFn, MutexUnlockFn,
|
||||
CondVarNewFn, CondVarFreeFn, CondVarWaitFn, CondVarWaitTimeoutFn, CondVarWakeOneFn, CondVarWakeAllFn
|
||||
@@ -312,6 +315,7 @@
|
||||
cv->wake_all();
|
||||
}
|
||||
};
|
||||
+#endif
|
||||
|
||||
} /* namespace DBus */
|
||||
|
||||
--- libdbus-c++-0.9.0/src/dispatcher.cpp.threading 2017-02-15 13:48:22.627249868 +0000
|
||||
+++ libdbus-c++-0.9.0/src/dispatcher.cpp 2017-02-15 13:48:29.164253445 +0000
|
||||
@@ -253,6 +253,7 @@
|
||||
#endif//DBUS_HAS_THREADS_INIT_DEFAULT
|
||||
}
|
||||
|
||||
+#if 0
|
||||
void DBus::_init_threading(
|
||||
MutexNewFn m1,
|
||||
MutexFreeFn m2,
|
||||
@@ -318,3 +319,4 @@
|
||||
#endif//DBUS_HAS_RECURSIVE_MUTEX
|
||||
dbus_threads_init(&functions);
|
||||
}
|
||||
+#endif
|
9
libdbus-c++-0.9.0-writechar.patch
Normal file
9
libdbus-c++-0.9.0-writechar.patch
Normal file
@ -0,0 +1,9 @@
|
||||
--- libdbus-c++-0.9.0/src/pipe.cpp.writechar 2017-02-16 11:07:13.591950169 +0000
|
||||
+++ libdbus-c++-0.9.0/src/pipe.cpp 2017-02-16 11:04:17.158796092 +0000
|
||||
@@ -83,5 +83,5 @@
|
||||
void Pipe::signal()
|
||||
{
|
||||
// TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work...
|
||||
- ::write(_fd_write, '\0', 1);
|
||||
+ ::write(_fd_write, "", 1);
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
Name: libdbus-c++
|
||||
Version: 0.9.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: C++ Interface for DBus
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -9,9 +9,14 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://sourceforge.net/apps/mediawiki/dbus-cplusplus/index.php?title=Main_Page
|
||||
Source: http://downloads.sourceforge.net/project/dbus-cplusplus/dbus-c%2B%2B/%{version}/libdbus-c%2B%2B-%{version}.tar.gz
|
||||
Patch0: libdbus-c++-0.9.0-gcc-4.7.patch
|
||||
Patch1: libdbus-c++-0.9.0-writechar.patch
|
||||
Patch2: libdbus-c++-0.9.0-threading.patch
|
||||
Patch3: libdbus-c++-0.9.0-macro-collision.patch
|
||||
Patch4: libdbus-c++-0.9.0-linkfix.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libecore-devel
|
||||
BuildRequires: libeina-devel
|
||||
@ -19,7 +24,6 @@ BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: pkg-config
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgtkmm-devel
|
||||
BuildRequires: libtool
|
||||
@ -32,11 +36,20 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
C++ Interface for DBus.
|
||||
This package contains libraries and header files needed for development.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
%package tools
|
||||
Group: Development/Tools
|
||||
Summary: Tools provided with %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description tools
|
||||
C++ Interface for DBus.
|
||||
This package contains the tools provided with %{name}.
|
||||
|
||||
%package static
|
||||
Group: Development/Libraries
|
||||
@ -45,20 +58,30 @@ Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description static
|
||||
C++ Interface for DBus.
|
||||
This package contains static libraries needed for development.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
#./autogen.sh
|
||||
|
||||
%build
|
||||
#./autogen.sh
|
||||
export CPPFLAGS='%{optflags}'
|
||||
CXXFLAGS='--std=gnu++11 %{optflags}'
|
||||
export LDFLAGS='-lexpat -lpthread'
|
||||
|
||||
%configure \
|
||||
--enable-glib
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -73,8 +96,6 @@ make install DESTDIR=%{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/dbusxx-introspect
|
||||
%{_bindir}/dbusxx-xml2cpp
|
||||
%{_libdir}/libdbus-c++-*.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
@ -87,11 +108,19 @@ make install DESTDIR=%{buildroot}
|
||||
%{_libdir}/pkgconfig/dbus-c++-*.pc
|
||||
%doc README TODO
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/dbusxx-introspect
|
||||
%{_bindir}/dbusxx-xml2cpp
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libdbus-c++-*.*a
|
||||
|
||||
%changelog
|
||||
* Wed Dec 02 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-2mamba
|
||||
- rebuilt with debug package and tools subpackage, added patches
|
||||
|
||||
* Mon Sep 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-1mamba
|
||||
- update to 0.9.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user