update to 0.9.0 [release 0.9.0-1mamba;Mon Sep 03 2012]
This commit is contained in:
parent
710e197b07
commit
502de2adbb
@ -1,2 +1,4 @@
|
|||||||
# libdbus-cPlusPlus
|
# libdbus-c++
|
||||||
|
|
||||||
|
libdbus-c++ attempts to provide a C++ API for D-BUS. The library has a glib/gtk and an Ecore mainloop integration. It also offers an optional own main loop.
|
||||||
|
|
||||||
|
11
libdbus-c++-0.9.0-gcc-4.7.patch
Normal file
11
libdbus-c++-0.9.0-gcc-4.7.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -Nru libdbus-c++-0.9.0.orig/include/dbus-c++/eventloop-integration.h libdbus-c++-0.9.0/include/dbus-c++/eventloop-integration.h
|
||||||
|
--- libdbus-c++-0.9.0.orig/include/dbus-c++/eventloop-integration.h 2011-11-28 16:03:19.000000000 +0100
|
||||||
|
+++ libdbus-c++-0.9.0/include/dbus-c++/eventloop-integration.h 2012-09-03 16:48:22.334507821 +0200
|
||||||
|
@@ -26,6 +26,7 @@
|
||||||
|
#define __DBUSXX_EVENTLOOP_INTEGRATION_H
|
||||||
|
|
||||||
|
#include <errno.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include "api.h"
|
||||||
|
#include "dispatcher.h"
|
||||||
|
#include "util.h"
|
102
libdbus-c++.spec
Normal file
102
libdbus-c++.spec
Normal file
@ -0,0 +1,102 @@
|
|||||||
|
Name: libdbus-c++
|
||||||
|
Version: 0.9.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: C++ Interface for DBus
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://sourceforge.net/apps/mediawiki/dbus-cplusplus/index.php?title=Main_Page
|
||||||
|
Source: http://downloads.sourceforge.net/project/dbus-cplusplus/dbus-c%2B%2B/%{version}/libdbus-c%2B%2B-%{version}.tar.gz
|
||||||
|
Patch0: libdbus-c++-0.9.0-gcc-4.7.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libecore-devel
|
||||||
|
BuildRequires: libeina-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: pkg-config
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libgtkmm-devel
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{name} attempts to provide a C++ API for D-BUS. The library has a glib/gtk and an Ecore mainloop integration. It also offers an optional own main loop.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
C++ Interface for DBus.
|
||||||
|
|
||||||
|
This package contains libraries and header files need for development.
|
||||||
|
|
||||||
|
%package static
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries for %{name}
|
||||||
|
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description static
|
||||||
|
C++ Interface for DBus.
|
||||||
|
|
||||||
|
This package contains static libraries need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
#./autogen.sh
|
||||||
|
export CPPFLAGS='%{optflags}'
|
||||||
|
export LDFLAGS='-lexpat -lpthread'
|
||||||
|
%configure \
|
||||||
|
--enable-glib
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/dbusxx-introspect
|
||||||
|
%{_bindir}/dbusxx-xml2cpp
|
||||||
|
%{_libdir}/libdbus-c++-*.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/dbus-c++-*
|
||||||
|
%dir %{_includedir}/dbus-c++-*/dbus-c++
|
||||||
|
%{_includedir}/dbus-c++-*/dbus-c++/*.h
|
||||||
|
%{_libdir}/libdbus-c++-*.so
|
||||||
|
%{_libdir}/pkgconfig/dbus-c++-*.pc
|
||||||
|
%doc README TODO
|
||||||
|
|
||||||
|
%files static
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libdbus-c++-*.*a
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-1mamba
|
||||||
|
- update to 0.9.0
|
||||||
|
|
||||||
|
* Sat Dec 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.0-2mamba
|
||||||
|
- imported from milestone1-contib to devel
|
||||||
|
|
||||||
|
* Sat Oct 02 2010 gil <puntogil@libero.it> 0.5.0-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user