automatic version update by autodist [release 19.1.1-1mamba;Sat Oct 12 2024]

This commit is contained in:
Automatic Build System 2024-10-13 01:12:12 +02:00
parent 05b1a74841
commit 8ad71ff6fe
2 changed files with 27 additions and 7 deletions

View File

@ -0,0 +1,17 @@
diff -ruN build.orig/libcxx/include/CMakeLists.txt build/libcxx/include/CMakeLists.txt
--- build.orig/libcxx/include/CMakeLists.txt 2024-08-05 10:40:33.000000000 +0200
+++ build/libcxx/include/CMakeLists.txt 2024-09-13 15:02:44.249710564 +0200
@@ -1074,11 +1074,13 @@
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
COMPONENT cxx-headers)
+ if (FALSE)
# Install the generated IWYU file to the generic include dir.
install(FILES "${LIBCXX_GENERATED_INCLUDE_DIR}/libcxx.imp"
DESTINATION "${LIBCXX_INSTALL_INCLUDE_DIR}"
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
COMPONENT cxx-headers)
+ endif()
if (NOT CMAKE_CONFIGURATION_TYPES)
add_custom_target(install-cxx-headers

View File

@ -1,5 +1,5 @@
Name: libcxx
Version: 18.1.8
Version: 19.1.1
Release: 1mamba
Summary: An implementation of the C++ standard library, targeting C++11, C++14 and above
Group: System/Libraries
@ -14,6 +14,7 @@ Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/libunwind-%{version}.src.tar.xz
# From Fedora
Source5: libcxx-17.0.5-CmakeLists.txt
Patch0: libcxx-19.1.1-do-not-install-libcxx.imp.patch
License: MIT, BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -68,6 +69,8 @@ mv libunwind-%{version}.src libunwind
cp %{SOURCE5} CMakeLists.txt
%patch 0 -p1 -b .do-not-install-libcxx.imp
%build
#:<< _EOF
mkdir -p build
@ -102,12 +105,6 @@ DESTDIR=%{buildroot} ninja install-cxx install-cxxabi
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post -n libcxxabi -p /sbin/ldconfig
%postun -n libcxxabi -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libc++.so.*
@ -123,6 +120,9 @@ DESTDIR=%{buildroot} ninja install-cxx install-cxxabi
%{_libdir}/libc++.a
%{_libdir}/libc++experimental.a
%{_libdir}/libc++.so
%{_libdir}/libc++.modules.json
%dir %{_datadir}/libc++/v1
%{_datadir}/libc++/v1/*
%files -n libcxxabi
%defattr(-,root,root)
@ -137,6 +137,9 @@ DESTDIR=%{buildroot} ninja install-cxx install-cxxabi
%{_libdir}/libc++abi.a
%changelog
* Sat Oct 12 2024 Automatic Build System <autodist@openmamba.org> 19.1.1-1mamba
- automatic version update by autodist
* Sat Jun 22 2024 Automatic Build System <autodist@openmamba.org> 18.1.8-1mamba
- automatic version update by autodist