package created by autospec [release 1.4.6-1mamba;Fri Aug 10 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 04:03:42 +01:00
parent fd67b47dae
commit 96242443fc
3 changed files with 129 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libcult # libcult
libcult is a collection of c++ libraries that were designed to form a cohesive union of clean, simple and readable c++ code that uses the most powerful mechanisms available on the GNU development platform.

View File

@ -0,0 +1,57 @@
From 2ef8e0426baad35a3438f9497005c3e3391e23f0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
Date: Fri, 1 Jun 2012 10:12:33 +0200
Subject: [PATCH 2/2] fix compilation with gcc-4.7
---
cult/mm/evptr.hxx | 4 ++--
cult/mm/shptr.hxx | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/cult/mm/evptr.hxx b/cult/mm/evptr.hxx
index 18f232c..ed0bd93 100644
--- a/cult/mm/evptr.hxx
+++ b/cult/mm/evptr.hxx
@@ -70,7 +70,7 @@ namespace Cult
Evptr&
operator= (Evptr const& ep)
{
- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
return *this;
}
@@ -79,7 +79,7 @@ namespace Cult
Evptr&
operator= (Evptr<Y> const& ep)
{
- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
return *this;
}
diff --git a/cult/mm/shptr.hxx b/cult/mm/shptr.hxx
index a5e1257..6630b1c 100644
--- a/cult/mm/shptr.hxx
+++ b/cult/mm/shptr.hxx
@@ -45,7 +45,7 @@ namespace Cult
Shptr&
operator= (Shptr const& ap)
{
- assign (ap);
+ this->assign (ap);
return *this;
}
@@ -53,7 +53,7 @@ namespace Cult
Shptr&
operator= (Shptr<Y> const& ap)
{
- assign (ap);
+ this->assign (ap);
return *this;
}
--
1.7.8.5

70
libcult.spec Normal file
View File

@ -0,0 +1,70 @@
Name: libcult
Version: 1.4.6
Release: 1mamba
Summary: A collection of c++ libraries that uses the mechanisms available on the GNU development platform
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://kolpackov.net/projects/libcult/
Source: ftp://kolpackov.net/pub/projects/libcult/1.4/libcult-%{version}.tar.bz2
Patch0: %{name}-1.4.6-gcc-4.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: build
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
libcult is a collection of c++ libraries that were designed to form a cohesive union of clean, simple and readable c++ code that uses the most powerful mechanisms available on the GNU development platform.
%package devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q
%patch0 -p1
%build
%make << _EOF
_EOF
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -D -m0755 cult/libcult.so %{buildroot}%{_libdir}/libcult.so
install -d -m0755 %{buildroot}%{_includedir}
cp -a cult %{buildroot}%{_includedir}/
find %{buildroot}%{_includedir} -name *.o -exec rm -f {} \;
find %{buildroot}%{_includedir} -name *.o.d -exec rm -f {} \;
find %{buildroot}%{_includedir} -name *.so -exec rm -f {} \;
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libcult.so
%doc LICENSE
%files devel
%defattr(-,root,root)
%dir %{_includedir}/cult
%{_includedir}/cult/*
%doc NEWS README
%changelog
* Fri Aug 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.6-1mamba
- package created by autospec