update to 3.10.0.20130731git [release 3.10.0.20130731git-1mamba;Wed Jul 31 2013]
This commit is contained in:
parent
6f64f8d2e9
commit
4ef7ba272e
@ -1,2 +1,4 @@
|
|||||||
# libcrystalhd
|
# libcrystalhd
|
||||||
|
|
||||||
|
The libcrystalhd library provides userspace access to Broadcom Crystal HD video decoder devices. The device supports hardware decoding of MPEG-2, h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation bcm970012 hardware, and up to 1080p at 60fps for the second-generation bcm970015 hardware.
|
||||||
|
|
||||||
|
14
crystal_hd-LICENSE
Normal file
14
crystal_hd-LICENSE
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Legal Disclaimer
|
||||||
|
The Crystal HD video decoder open source software is provided under the GNU Lesser General Public License, version 2.1, as published by the Free Software Foundation ("LGPL"). This software is distributed in the hope that it will be useful, but WITHOUT ANY SUPPORT OR WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the LGPL for more details. A copy of the LGPL is available at http://www.broadcom.com/licenses/LGPLv2.1.php or by writing to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||||
|
|
||||||
|
The BCM70015 and BCM70012 device firmware (binary files bcm70015fw.bin and bcm70012fw.bin) is distributed under the following terms:
|
||||||
|
|
||||||
|
Copyright 2007-2010 Broadcom Corporation.
|
||||||
|
|
||||||
|
Redistribution and use in binary forms of this software, without modification, are permitted provided that the following conditions are met:
|
||||||
|
|
||||||
|
* Redistributions must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
|
||||||
|
|
||||||
|
* Neither the name of Broadcom nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
|
||||||
|
|
||||||
|
THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL BROADCOM BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
73
libcrystalhd-3.6.9.20100703-add_DtsTxFreeSize.patch
Normal file
73
libcrystalhd-3.6.9.20100703-add_DtsTxFreeSize.patch
Normal file
@ -0,0 +1,73 @@
|
|||||||
|
From 2e7535e9504254854765f97fe74b23d0ecd40d4b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Taylor Ralph <taylor.ralph@gmail.com>
|
||||||
|
Date: Thu, 23 Sep 2010 15:50:19 -0400
|
||||||
|
Subject: [PATCH] [lib] add function to get tx buf free size
|
||||||
|
|
||||||
|
Jarod changed things from int32_t to unint32_t to match freeSize's
|
||||||
|
type, and added function pseudo-documentation block. And any bugs.
|
||||||
|
|
||||||
|
Signed-off-by: Jarod Wilson <jarod@redhat.com>
|
||||||
|
---
|
||||||
|
linux_lib/libcrystalhd/libcrystalhd_if.cpp | 10 ++++++++++
|
||||||
|
linux_lib/libcrystalhd/libcrystalhd_if.h | 24 ++++++++++++++++++++++++
|
||||||
|
2 files changed, 34 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/linux_lib/libcrystalhd/libcrystalhd_if.cpp b/linux_lib/libcrystalhd/libcrystalhd_if.cpp
|
||||||
|
index b00f89b..0723c8e 100644
|
||||||
|
--- a/linux_lib/libcrystalhd/libcrystalhd_if.cpp
|
||||||
|
+++ b/linux_lib/libcrystalhd/libcrystalhd_if.cpp
|
||||||
|
@@ -1794,6 +1794,16 @@ DtsSendData( HANDLE hDevice ,
|
||||||
|
return txBufPush(&Ctx->circBuf, pUserData, ulSizeInBytes);
|
||||||
|
}
|
||||||
|
|
||||||
|
+DRVIFLIB_API uint32_t
|
||||||
|
+DtsTxFreeSize( HANDLE hDevice )
|
||||||
|
+{
|
||||||
|
+ DTS_LIB_CONTEXT *Ctx = NULL;
|
||||||
|
+
|
||||||
|
+ DTS_GET_CTX(hDevice,Ctx);
|
||||||
|
+
|
||||||
|
+ return Ctx->circBuf.freeSize;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
DRVIFLIB_API BC_STATUS
|
||||||
|
DtsSendSPESPkt(HANDLE hDevice ,
|
||||||
|
uint64_t timeStamp,
|
||||||
|
diff --git a/linux_lib/libcrystalhd/libcrystalhd_if.h b/linux_lib/libcrystalhd/libcrystalhd_if.h
|
||||||
|
index d01e0d6..8807842 100644
|
||||||
|
--- a/linux_lib/libcrystalhd/libcrystalhd_if.h
|
||||||
|
+++ b/linux_lib/libcrystalhd/libcrystalhd_if.h
|
||||||
|
@@ -1508,6 +1508,30 @@ DtsCrystalHDVersion(
|
||||||
|
PBC_INFO_CRYSTAL bCrystalInfo
|
||||||
|
);
|
||||||
|
|
||||||
|
+/*****************************************************************************
|
||||||
|
+
|
||||||
|
+Function name:
|
||||||
|
+
|
||||||
|
+ DtsTxFreeSize
|
||||||
|
+
|
||||||
|
+Description:
|
||||||
|
+
|
||||||
|
+ This API returns the amount of free space in the tx circular buffer
|
||||||
|
+Parameters:
|
||||||
|
+
|
||||||
|
+ hDevice Handle to device. This is obtained via a prior call to
|
||||||
|
+ DtsDeviceOpen.
|
||||||
|
+
|
||||||
|
+Return:
|
||||||
|
+
|
||||||
|
+ uint32_t value of number of free bytes in the tx circular buffer
|
||||||
|
+
|
||||||
|
+*****************************************************************************/
|
||||||
|
+DRVIFLIB_API uint32_t
|
||||||
|
+DtsTxFreeSize(
|
||||||
|
+ HANDLE hDevice
|
||||||
|
+);
|
||||||
|
+
|
||||||
|
#ifdef __cplusplus
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
--
|
||||||
|
1.7.2.5
|
||||||
|
|
69
libcrystalhd-3.6.9.20100703-gstreamer-0.10.patch
Normal file
69
libcrystalhd-3.6.9.20100703-gstreamer-0.10.patch
Normal file
@ -0,0 +1,69 @@
|
|||||||
|
--- src/gstbcmdec.c 2010-12-06 22:36:34.000000000 +0100
|
||||||
|
+++ src/gstbcmdec.c 2011-05-04 18:00:13.558917747 +0200
|
||||||
|
@@ -362,9 +362,8 @@
|
||||||
|
|
||||||
|
static GstCaps *gst_bcmdec_getcaps (GstPad * pad)
|
||||||
|
{
|
||||||
|
- GstBcmDec *bcmdec;
|
||||||
|
GstCaps *caps;
|
||||||
|
- bcmdec = GST_BCMDEC(gst_pad_get_parent(pad));
|
||||||
|
+ GST_BCMDEC(gst_pad_get_parent(pad));
|
||||||
|
|
||||||
|
caps = gst_caps_copy (gst_pad_get_pad_template_caps (pad));
|
||||||
|
|
||||||
|
@@ -624,7 +623,6 @@
|
||||||
|
{
|
||||||
|
GstBcmDec *bcmdec;
|
||||||
|
// BC_STATUS sts = BC_STS_SUCCESS;
|
||||||
|
- guint32 buf_sz = 0;
|
||||||
|
guint32 offset = 0;
|
||||||
|
GstClockTime tCurrent = 0;
|
||||||
|
guint8 *pbuffer;
|
||||||
|
@@ -655,7 +653,6 @@
|
||||||
|
}
|
||||||
|
tCurrent = GST_BUFFER_TIMESTAMP(buf);
|
||||||
|
}
|
||||||
|
- buf_sz = GST_BUFFER_SIZE(buf);
|
||||||
|
|
||||||
|
if (bcmdec->play_pending) {
|
||||||
|
bcmdec->play_pending = FALSE;
|
||||||
|
@@ -697,7 +694,6 @@
|
||||||
|
static gboolean bcmdec_negotiate_format(GstBcmDec *bcmdec)
|
||||||
|
{
|
||||||
|
GstCaps *caps;
|
||||||
|
- guint32 fourcc;
|
||||||
|
gboolean result;
|
||||||
|
guint num = (guint)(bcmdec->output_params.framerate * 1000);
|
||||||
|
guint den = 1000;
|
||||||
|
@@ -706,10 +702,8 @@
|
||||||
|
GstVideoFormat vidFmt;
|
||||||
|
|
||||||
|
#ifdef YV12__
|
||||||
|
- fourcc = GST_STR_FOURCC("YV12");
|
||||||
|
vidFmt = GST_VIDEO_FORMAT_YV12;
|
||||||
|
#else
|
||||||
|
- fourcc = GST_STR_FOURCC("YUY2");
|
||||||
|
vidFmt = GST_VIDEO_FORMAT_YUY2;
|
||||||
|
#endif
|
||||||
|
GST_DEBUG_OBJECT(bcmdec, "framerate = %f", bcmdec->output_params.framerate);
|
||||||
|
@@ -858,8 +852,6 @@
|
||||||
|
GstStateChangeReturn result = GST_STATE_CHANGE_SUCCESS;
|
||||||
|
GstBcmDec *bcmdec = GST_BCMDEC(element);
|
||||||
|
BC_STATUS sts = BC_STS_SUCCESS;
|
||||||
|
- GstClockTime clock_time;
|
||||||
|
- GstClockTime base_clock_time;
|
||||||
|
int ret = 0;
|
||||||
|
|
||||||
|
switch (transition) {
|
||||||
|
@@ -904,9 +896,9 @@
|
||||||
|
bcmdec->gst_clock = gst_element_get_clock(element);
|
||||||
|
if (bcmdec->gst_clock) {
|
||||||
|
//printf("clock available %p\n",bcmdec->gst_clock);
|
||||||
|
- base_clock_time = gst_element_get_base_time(element);
|
||||||
|
+ //base_clock_time = gst_element_get_base_time(element);
|
||||||
|
//printf("base clock time %lld\n",base_clock_time);
|
||||||
|
- clock_time = gst_clock_get_time(bcmdec->gst_clock);
|
||||||
|
+ //clock_time = gst_clock_get_time(bcmdec->gst_clock);
|
||||||
|
//printf(" clock time %lld\n",clock_time);
|
||||||
|
}
|
||||||
|
break;
|
44108
libcrystalhd-updates.patch
Normal file
44108
libcrystalhd-updates.patch
Normal file
File diff suppressed because it is too large
Load Diff
139
libcrystalhd.spec
Normal file
139
libcrystalhd.spec
Normal file
@ -0,0 +1,139 @@
|
|||||||
|
%define pkgver %(echo %version | cut -d. -f4)
|
||||||
|
%define pkgverrev 07032010
|
||||||
|
Name: libcrystalhd
|
||||||
|
Version: 3.10.0.20130731git
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Broadcom Crystal HD device interface library
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.broadcom.com/support/crystal_hd/
|
||||||
|
Source: git://linuxtv.org/jarod/crystalhd.git/master/crystalhd-%{version}.tar.bz2
|
||||||
|
#Source0: http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_%{pkgver}.zip
|
||||||
|
# from openSUSE generated from http://git.wilsonet.com/crystalhd.git/
|
||||||
|
Source1: crystal_hd-LICENSE
|
||||||
|
Patch0: %{name}-updates.patch
|
||||||
|
Patch1: %{name}-3.6.9.20100703-add_DtsTxFreeSize.patch
|
||||||
|
Patch2: libcrystalhd-3.6.9.20100703-gstreamer-0.10.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgst-plugins-base010-devel
|
||||||
|
BuildRequires: libgstreamer010-devel
|
||||||
|
BuildRequires: liblzma-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The libcrystalhd library provides userspace access to Broadcom Crystal HD video decoder devices. The device supports hardware decoding of MPEG-2, h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation bcm970012 hardware, and up to 1080p at 60fps for the second-generation bcm970015 hardware.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Broadcom Crystal HD device interface library.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n crystalhd-firmware
|
||||||
|
Group: System/Kernel and Hardware
|
||||||
|
Summary: Firmware for the Broadcom Crystal HD video decoder
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n crystalhd-firmware
|
||||||
|
Broadcom Crystal HD device interface library.
|
||||||
|
|
||||||
|
This package contains firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015) video decoders.
|
||||||
|
|
||||||
|
%package -n gstreamer-plugin-crystalhd
|
||||||
|
Group: System/Multimedia
|
||||||
|
Summary: Gstreamer crystalhd decoder plugin
|
||||||
|
BuildRequires: libgst-plugins-base-devel
|
||||||
|
BuildRequires: libgstreamer-devel
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n gstreamer-plugin-crystalhd
|
||||||
|
Broadcom Crystal HD device interface library.
|
||||||
|
|
||||||
|
This package contains Gstreamer crystalhd decoder plugin.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n crystalhd-%{version}
|
||||||
|
#cd %{pkgverrev}
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
cp %{SOURCE1} LICENSE
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make -C linux_lib/libcrystalhd
|
||||||
|
cd filters/gst/gst-plugin/
|
||||||
|
./autogen.sh
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall LIBDIR=%{_libdir} DESTDIR=%{buildroot} -C linux_lib/libcrystalhd
|
||||||
|
%makeinstall DESTDIR=%{buildroot} -C filters/gst/gst-plugin
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
|
||||||
|
mkdir -p %{buildroot}/lib/firmware
|
||||||
|
install -pm 755 firmware/fwbin/70012/bcm70012fw.bin %{buildroot}/lib/firmware/
|
||||||
|
install -pm 755 firmware/fwbin/70012/bcmFilePlayFw.bin %{buildroot}/lib/firmware/
|
||||||
|
install -pm 755 firmware/fwbin/70015/bcm70015fw.bin %{buildroot}/lib/firmware/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libcrystalhd.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/libcrystalhd
|
||||||
|
%{_includedir}/libcrystalhd/*.h
|
||||||
|
%{_libdir}/libcrystalhd.so
|
||||||
|
|
||||||
|
%files -n crystalhd-firmware
|
||||||
|
%defattr(-,root,root)
|
||||||
|
/lib/firmware/bcmFilePlayFw.bin
|
||||||
|
/lib/firmware/bcm70012fw.bin
|
||||||
|
/lib/firmware/bcm70015fw.bin
|
||||||
|
%doc LICENSE
|
||||||
|
|
||||||
|
%files -n gstreamer-plugin-crystalhd
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/gstreamer-*.*/libgstbcmdec.so
|
||||||
|
%doc filters/gst/gst-plugin/COPYING
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jul 31 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10.0.20130731git-1mamba
|
||||||
|
- update to 3.10.0.20130731git
|
||||||
|
|
||||||
|
* Mon Oct 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.9.20100703-2mamba
|
||||||
|
- fixed built with gcc 4.7
|
||||||
|
|
||||||
|
* Fri Mar 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.9.20100703-1mamba
|
||||||
|
- update to 3.6.9.20100307
|
||||||
|
- added patch from http://expresskeys.ruivo.org/cgi-bin/gitweb.cgi?p=crystalhd.git to fix build with ffmpeg 0.8.10
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5.1-2mamba
|
||||||
|
- rebuilt in devel
|
||||||
|
|
||||||
|
* Mon Mar 07 2011 gil <puntogil@libero.it> 3.5.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user