automatic version update by autodist [release 0.6.8-1mamba;Fri Oct 26 2012]
This commit is contained in:
parent
8551a19881
commit
74cdd05414
@ -1,2 +1,4 @@
|
||||
# libcroco
|
||||
|
||||
The Libcroco project is an effort to build a generic Cascading Style Sheet (CSS) parsing and manipulation toolkit that can be used by GNOME applications in need of CSS support.
|
||||
|
||||
|
41
libcroco-0.6.1-multilib.patch
Normal file
41
libcroco-0.6.1-multilib.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- libcroco-0.6.1/croco-config.in.multilib 2006-03-05 16:57:01.000000000 -0500
|
||||
+++ libcroco-0.6.1/croco-config.in 2006-05-23 13:54:34.000000000 -0400
|
||||
@@ -1,10 +1,11 @@
|
||||
#! /bin/sh
|
||||
|
||||
-prefix=@prefix@
|
||||
-exec_prefix=@exec_prefix@
|
||||
+name=libcroco-0.6
|
||||
+prefix=`pkg-config --variable prefix $name`
|
||||
+exec_prefix=`pkg-config --variable exec_prefix $name`
|
||||
exec_prefix_set=no
|
||||
-includedir=@includedir@
|
||||
-libdir=@libdir@
|
||||
+includedir=`pkg-config --variable includedir $name`
|
||||
+libdir=`pkg-config --variable libdir $name`
|
||||
|
||||
usage()
|
||||
{
|
||||
@@ -59,7 +60,7 @@
|
||||
;;
|
||||
|
||||
--version)
|
||||
- echo @VERSION@
|
||||
+ pkg-config --modversion $name
|
||||
exit 0
|
||||
;;
|
||||
|
||||
@@ -68,11 +69,11 @@
|
||||
;;
|
||||
|
||||
--cflags)
|
||||
- echo @CROCO_CFLAGS@ @GLIB2_CFLAGS@ @LIBXML2_CFLAGS@
|
||||
+ pkg-config --cflags $name
|
||||
;;
|
||||
|
||||
--libs)
|
||||
- echo @CROCO_LIBS@ @GLIB2_LIBS@ @LIBXML2_LIBS@
|
||||
+ pkg-config --libs $name
|
||||
;;
|
||||
|
||||
*)
|
97
libcroco.spec
Normal file
97
libcroco.spec
Normal file
@ -0,0 +1,97 @@
|
||||
%define majversion %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: libcroco
|
||||
Version: 0.6.8
|
||||
Release: 1mamba
|
||||
Summary: A generic Cascading Style Sheet (CSS) parsing and manipulation toolkit
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.freespiders.org/projects/libcroco/
|
||||
Source: ftp://ftp.gnome.org/pub/GNOME/sources/libcroco/%{majversion}/libcroco-%{version}.tar.xz
|
||||
Patch: %{name}-0.6.1-multilib.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: libpango-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Libcroco project is an effort to build a generic Cascading Style Sheet (CSS) parsing and manipulation toolkit that can be used by GNOME applications in need of CSS support.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The Libcroco project is an effort to build a generic Cascading Style Sheet (CSS) parsing and manipulation toolkit that can be used by GNOME applications in need of CSS support.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .multilib
|
||||
|
||||
%build
|
||||
%configure --enable-seleng=yes --enable-layeng=yes
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/csslint-%{majversion}
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/croco-%{majversion}-config
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/libcroco-%{majversion}.pc
|
||||
%{_includedir}/libcroco-%{majversion}
|
||||
%dir %{_datadir}/gtk-doc/html/libcroco
|
||||
%{_datadir}/gtk-doc/html/libcroco/*
|
||||
|
||||
%changelog
|
||||
* Fri Oct 26 2012 Automatic Build System <autodist@mambasoft.it> 0.6.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 16 2012 Automatic Build System <autodist@mambasoft.it> 0.6.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Sep 16 2012 Automatic Build System <autodist@mambasoft.it> 0.6.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 02 2012 Automatic Build System <autodist@mambasoft.it> 0.6.5-1mamba
|
||||
- update to 0.6.5
|
||||
|
||||
* Mon Nov 28 2011 Automatic Build System <autodist@mambasoft.it> 0.6.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Feb 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Aug 26 2008 Aleph0 <aleph0@openmamba.org> 0.6.1-2mamba
|
||||
- specfile updated
|
||||
|
||||
* Thu Dec 21 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.6.1-1qilnx
|
||||
- update to version 0.6.1 by autospec
|
||||
|
||||
* Tue Dec 30 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user