automatic version update by autodist [release 1.16.4-1mamba;Sat Jan 25 2014]
This commit is contained in:
parent
ff1367a96f
commit
66bd9b9727
@ -1,2 +1,4 @@
|
||||
# libclutter
|
||||
|
||||
Clutter is an open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces. The most obvious example of potential usage is in media center type applications.
|
||||
|
||||
|
51
Use-a-native-format-for-atlas-textures.patch
Normal file
51
Use-a-native-format-for-atlas-textures.patch
Normal file
@ -0,0 +1,51 @@
|
||||
From 01524a55da752146ece2e6bf345fb0a01f2ed656 Mon Sep 17 00:00:00 2001
|
||||
From: Owen Taylor <otaylor@fresnel.(none)>
|
||||
Date: Thu, 29 Apr 2010 19:47:56 -0400
|
||||
Subject: [PATCH] Use a native format for atlas textures
|
||||
|
||||
Since we create frame buffer objects for atlas textures, we should use
|
||||
a format that can be used as a rendering target. For this reason, use
|
||||
an internal format of ARGB instead of RGBA when creating the texture.
|
||||
|
||||
(We don't actually render to it, but the Radeon Mesa drivers aren't
|
||||
sophisticated enough to deal with a FBO that can be read from but
|
||||
can't be rendered to. On other hardware, this is probably pretty much
|
||||
neutral for efficiency.)
|
||||
|
||||
http://bugzilla.openedhand.com/show_bug.cgi?id=2100
|
||||
---
|
||||
clutter/cogl/cogl/cogl-atlas-texture.c | 11 ++++++++++-
|
||||
1 files changed, 10 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/clutter/cogl/cogl/cogl-atlas-texture.c b/clutter/cogl/cogl/cogl-atlas-texture.c
|
||||
index b9219e4..3fafb58 100644
|
||||
--- a/clutter/cogl/cogl/cogl-atlas-texture.c
|
||||
+++ b/clutter/cogl/cogl/cogl-atlas-texture.c
|
||||
@@ -70,6 +70,15 @@
|
||||
#define GL_FRAMEBUFFER_COMPLETE 0x8CD5
|
||||
#endif
|
||||
|
||||
+/* Best guess at native frame buffer formats; using these makes the
|
||||
+ * Mesa framebuffer support happier on Radeon cards that can't
|
||||
+ * render to arbitrarily ordered pixels */
|
||||
+#if G_BYTE_ORDER == G_LITTLE_ENDIAN
|
||||
+#define NATIVE_PIXEL_FORMAT COGL_PIXEL_FORMAT_BGRA_8888_PRE
|
||||
+#else
|
||||
+#define NATIVE_PIXEL_FORMAT COGL_PIXEL_FORMAT_ARGB_8888_PRE
|
||||
+#endif
|
||||
+
|
||||
static void _cogl_atlas_texture_free (CoglAtlasTexture *sub_tex);
|
||||
|
||||
COGL_HANDLE_DEFINE (AtlasTexture, atlas_texture);
|
||||
@@ -868,7 +877,7 @@ _cogl_atlas_texture_reserve_space (CoglAtlasTexture *new_sub_tex,
|
||||
_cogl_texture_2d_new_with_size (_cogl_atlas_get_width (new_atlas),
|
||||
_cogl_atlas_get_height (new_atlas),
|
||||
COGL_TEXTURE_NONE,
|
||||
- COGL_PIXEL_FORMAT_RGBA_8888)) ==
|
||||
+ NATIVE_PIXEL_FORMAT)) ==
|
||||
COGL_INVALID_HANDLE)
|
||||
{
|
||||
COGL_NOTE (ATLAS, "Could not create a CoglTexture2D");
|
||||
--
|
||||
1.7.0.1
|
||||
|
242
libclutter.spec
Normal file
242
libclutter.spec
Normal file
@ -0,0 +1,242 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
Name: libclutter
|
||||
Version: 1.16.4
|
||||
Release: 1mamba
|
||||
Summary: Open Source software library for creating fast, compelling, portable, and dynamic graphical user interfaces
|
||||
Group: Development/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||
URL: http://www.clutter-project.org/
|
||||
Source: ftp://ftp.gnome.org/pub/gnome/sources/clutter/%{majver}/clutter-%{version}.tar.xz
|
||||
# http://bugzilla.openedhand.com/show_bug.cgi?id=2100
|
||||
Patch0: Use-a-native-format-for-atlas-textures.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libjson-glib-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng12-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: libcogl-devel
|
||||
Provides: clutter
|
||||
Obsoletes: clutter
|
||||
Requires: gobject-introspection
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Clutter is an open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces. The most obvious example of potential usage is in media center type applications.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: clutter-devel
|
||||
Obsoletes: clutter-devel
|
||||
|
||||
%description devel
|
||||
Clutter is an open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: clutter-doc
|
||||
Obsoletes: clutter-doc
|
||||
|
||||
%description doc
|
||||
Clutter is an open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces.
|
||||
|
||||
This package contains documentation for %{name}.
|
||||
|
||||
%package static
|
||||
Summary: Static libraries for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: clutter-static
|
||||
Obsoletes: clutter-static
|
||||
|
||||
%description static
|
||||
Clutter is an open source software library for creating fast, compelling, portable, and dynamic graphical user interfaces.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -n clutter-%{version}
|
||||
#%patch0 -p1 -b .atlas-textures
|
||||
|
||||
%build
|
||||
# --disable-gtk-doc --disable-conformance
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc ; fi;
|
||||
%configure $CONFIGFLAGS \
|
||||
--enable-xinput
|
||||
if ! test -f ChangeLog; then
|
||||
echo "Created from snapshot" > ChangeLog
|
||||
fi
|
||||
)
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang clutter-1.0
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -f clutter-1.0.lang
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libclutter-1.0.so.*
|
||||
%{_libdir}/libclutter-glx-*.so.*
|
||||
%{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
|
||||
%{_libdir}/girepository-?.?/Cally-?.?.typelib
|
||||
%{_libdir}/girepository-?.?/Clutter-?.?.typelib
|
||||
%{_libdir}/girepository-?.?/ClutterX11-?.?.typelib
|
||||
#%{_libdir}/girepository-?.?/Cogl-?.?.typelib
|
||||
%doc COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/clutter-1.0
|
||||
%dir %{_includedir}/clutter-1.0/clutter
|
||||
%dir %{_includedir}/clutter-1.0/clutter/deprecated
|
||||
%{_includedir}/clutter-1.0/clutter/deprecated/*.h
|
||||
%dir %{_includedir}/clutter-1.0/clutter/gdk
|
||||
%{_includedir}/clutter-1.0/clutter/gdk/clutter-gdk.h
|
||||
%dir %{_includedir}/clutter-1.0/cally
|
||||
%{_includedir}/clutter-1.0/cally/*.h
|
||||
%dir %{_includedir}/clutter-1.0/clutter
|
||||
%{_includedir}/clutter-1.0/clutter/*.h
|
||||
%dir %{_includedir}/clutter-1.0/clutter/glx
|
||||
%{_includedir}/clutter-1.0/clutter/glx/*.h
|
||||
%dir %{_includedir}/clutter-1.0/clutter/x11
|
||||
%{_includedir}/clutter-1.0/clutter/x11/*.h
|
||||
%{_libdir}/libclutter-1.0.la
|
||||
%{_libdir}/libclutter-1.0.so
|
||||
%{_libdir}/pkgconfig/clutter-gdk-1.0.pc
|
||||
#%{_includedir}/clutter-?.?/cogl/*.h
|
||||
%{_libdir}/libclutter-glx-?.?.so
|
||||
%{_libdir}/pkgconfig/cally-?.?.pc
|
||||
%{_libdir}/pkgconfig/clutter-?.?.pc
|
||||
%{_libdir}/pkgconfig/clutter-glx-?.?.pc
|
||||
%{_libdir}/pkgconfig/clutter-x11-?.?.pc
|
||||
%{_libdir}/pkgconfig/clutter-cogl-?.?.pc
|
||||
#%{_libdir}/pkgconfig/cogl-gl-?.?.pc
|
||||
%{_datadir}/gir-1.0/ClutterGdk-1.0.gir
|
||||
%{_datadir}/gir-?.?/Cally-?.?.gir
|
||||
%{_datadir}/gir-?.?/Clutter-?.?.gir
|
||||
%{_datadir}/gir-?.?/ClutterX11-?.?.gir
|
||||
#%{_datadir}/gir-?.?/Cogl-?.?.gir
|
||||
%doc README ChangeLog* NEWS
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/gtk-doc/html/cally
|
||||
%{_datadir}/gtk-doc/html/clutter
|
||||
#%{_datadir}/gtk-doc/html/cogl
|
||||
|
||||
%changelog
|
||||
* Sat Jan 25 2014 Automatic Build System <autodist@mambasoft.it> 1.16.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 19 2013 Automatic Build System <autodist@mambasoft.it> 1.16.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Nov 03 2013 Automatic Build System <autodist@mambasoft.it> 1.16.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 15 2013 Automatic Build System <autodist@mambasoft.it> 1.14.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 17 2013 Automatic Build System <autodist@mambasoft.it> 1.14.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Apr 07 2013 Automatic Build System <autodist@mambasoft.it> 1.14.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 17 2013 Automatic Build System <autodist@mambasoft.it> 1.13.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 18 2012 Automatic Build System <autodist@mambasoft.it> 1.13.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 17 2012 Automatic Build System <autodist@mambasoft.it> 1.12.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 26 2012 Automatic Build System <autodist@mambasoft.it> 1.12.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.8-2mamba
|
||||
- moved typelib file from -devel to main package
|
||||
|
||||
* Fri Jul 06 2012 Automatic Build System <autodist@mambasoft.it> 1.10.8-1mamba
|
||||
- update to 1.10.8
|
||||
|
||||
* Mon Jan 30 2012 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Oct 21 2011 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 01 2011 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
|
||||
- update to 1.8.0
|
||||
|
||||
* Tue Jun 14 2011 Automatic Build System <autodist@mambasoft.it> 1.6.16-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue May 03 2011 Automatic Build System <autodist@mambasoft.it> 1.6.14-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Mar 13 2011 Automatic Build System <autodist@mambasoft.it> 1.6.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jan 31 2011 Automatic Build System <autodist@mambasoft.it> 1.5.12-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Dec 01 2010 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Nov 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-1mamba
|
||||
- update to 1.4.0
|
||||
- renamed from clutter to libclutter
|
||||
|
||||
* Sun Sep 19 2010 gil <puntogil@libero.it> 1.2.12-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user