rebuilt with aarch64 build fix, debug package and build requirements [release 0.40-2mamba;Tue Mar 16 2021]
This commit is contained in:
parent
4fc32f1399
commit
00f6df31a5
73
libchm-0.40-gcc-10.2.0.patch
Normal file
73
libchm-0.40-gcc-10.2.0.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From be20aa9e5992f371fa0f73be16bb1b145192a428 Mon Sep 17 00:00:00 2001
|
||||
From: Jed Wing <jed.wing@gmail.com>
|
||||
Date: Wed, 27 May 2009 18:25:42 -0700
|
||||
Subject: [PATCH 1/2] Patch to fix integer types problem by Goswin von
|
||||
Brederlow.
|
||||
|
||||
This came from Goswin von Brederlow <brederlo@informatik.uni-tuebingen.de> via
|
||||
Kartik Mistry, the maintainer of the Debian package of chmlib.
|
||||
---
|
||||
src/chm_lib.c | 30 +++++++++++++-----------------
|
||||
1 file changed, 13 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/src/chm_lib.c b/src/chm_lib.c
|
||||
index 6c6736c..ffd213c 100644
|
||||
--- a/src/chm_lib.c
|
||||
+++ b/src/chm_lib.c
|
||||
@@ -56,6 +56,7 @@
|
||||
|
||||
#include "lzx.h"
|
||||
|
||||
+#include <stdint.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#ifdef CHM_DEBUG
|
||||
@@ -149,22 +150,9 @@ typedef unsigned __int32 UInt32;
|
||||
typedef __int64 Int64;
|
||||
typedef unsigned __int64 UInt64;
|
||||
|
||||
-/* I386, 32-bit, non-Windows */
|
||||
-/* Sparc */
|
||||
-/* MIPS */
|
||||
-/* PPC */
|
||||
-#elif __i386__ || __sun || __sgi || __ppc__
|
||||
-typedef unsigned char UChar;
|
||||
-typedef short Int16;
|
||||
-typedef unsigned short UInt16;
|
||||
-typedef long Int32;
|
||||
-typedef unsigned long UInt32;
|
||||
-typedef long long Int64;
|
||||
-typedef unsigned long long UInt64;
|
||||
-
|
||||
/* x86-64 */
|
||||
/* Note that these may be appropriate for other 64-bit machines. */
|
||||
-#elif __x86_64__ || __ia64__
|
||||
+#elif defined(__LP64__)
|
||||
typedef unsigned char UChar;
|
||||
typedef short Int16;
|
||||
typedef unsigned short UInt16;
|
||||
@@ -173,10 +161,18 @@ typedef unsigned int UInt32;
|
||||
typedef long Int64;
|
||||
typedef unsigned long UInt64;
|
||||
|
||||
+/* I386, 32-bit, non-Windows */
|
||||
+/* Sparc */
|
||||
+/* MIPS */
|
||||
+/* PPC */
|
||||
#else
|
||||
-
|
||||
-/* yielding an error is preferable to yielding incorrect behavior */
|
||||
-#error "Please define the sized types for your platform in chm_lib.c"
|
||||
+typedef unsigned char UChar;
|
||||
+typedef short Int16;
|
||||
+typedef unsigned short UInt16;
|
||||
+typedef long Int32;
|
||||
+typedef unsigned long UInt32;
|
||||
+typedef long long Int64;
|
||||
+typedef unsigned long long UInt64;
|
||||
#endif
|
||||
|
||||
/* GCC */
|
||||
--
|
||||
1.8.3.1
|
||||
|
30
libchm.spec
30
libchm.spec
@ -1,6 +1,6 @@
|
||||
Name: libchm
|
||||
Version: 0.40
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: CHMLIB is a library for dealing with Microsoft ITSS/CHM format files
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -9,8 +9,11 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.jedrea.com/chmlib
|
||||
Source: http://www.jedrea.com/chmlib/chmlib-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.40-arm-guess.patch
|
||||
Patch1: libchm-0.40-gcc-10.2.0.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
License: LGPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
CHMLIB is a library for dealing with Microsoft ITSS/CHM format files.
|
||||
@ -21,14 +24,19 @@ Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}
|
||||
|
||||
%description devel
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n chmlib-%{version}
|
||||
%patch0 -p1
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
%patch1 -p1
|
||||
#% patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -43,17 +51,21 @@ This package contains static libraries and header files need for development.
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
%doc AUTHORS COPYING NEWS README
|
||||
%{_libdir}/libchm.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/libchm.a
|
||||
%{_libdir}/libchm.la
|
||||
%{_libdir}/libchm.so
|
||||
%doc NEWS README
|
||||
|
||||
%changelog
|
||||
* Tue Mar 16 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.40-2mamba
|
||||
- rebuilt with aarch64 build fix, debug package and build requirements
|
||||
|
||||
* Fri Jun 05 2009 Automatic Build System <autodist@mambasoft.it> 0.40-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user