automatic version update by autodist [release 3.340-1mamba;Mon Apr 15 2013]

This commit is contained in:
Automatic Build System 2024-01-06 03:59:09 +01:00
parent 0de6cfdc3e
commit 085ce12c20
4 changed files with 135 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# libcfitsio
CFITSIO is a library of C and Fortran subroutines for reading and writing data files in FITS (Flexible Image Transport System) data format. CFITSIO provides simple high-level routines for reading and writing FITS files that insulate the programmer from the internal complexities of the FITS format.
CFITSIO also provides many advanced features for manipulating and filtering the information in FITS files.

View File

@ -0,0 +1,9 @@
diff -Nru cfitsio.patch//cfitsio.pc.in cfitsio/cfitsio.pc.in
--- cfitsio.patch//cfitsio.pc.in 2011-03-02 22:56:18.000000000 +0100
+++ cfitsio/cfitsio.pc.in 2011-03-26 15:47:46.818755096 +0100
@@ -8,4 +8,4 @@
Version: 3.27
Libs: -L${libdir} -lcfitsio @LIBS@
Libs.private: -lm
-Cflags: -I${includedir}
+Cflags: -I${includedir}/cfitsio

View File

@ -0,0 +1,22 @@
diff -Nru cfitsio.orig/configure cfitsio/configure
--- cfitsio.orig/configure 2013-03-20 21:02:48.000000000 +0100
+++ cfitsio/configure 2013-04-15 16:02:10.868839677 +0200
@@ -3932,7 +3932,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -3953,7 +3954,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
if test "x$EXT" != xdarwin && test "x$EXT" != xcygwin && test "x$EXT" != xmingw32; then
if test "x$GCC" = xyes; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="$CC -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
fi

101
libcfitsio.spec Normal file
View File

@ -0,0 +1,101 @@
%define pkgver %(echo %version | tr -d .)
Name: libcfitsio
Epoch: 1
Version: 3.340
Release: 1mamba
Summary: A FITS File Subroutine Library
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Aleph0 <aleph0@openmamba.org>
URL: http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
Source: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio%{pkgver}.tar.gz
Patch0: %{name}-3.340-sharedlibs.patch
Patch1: %{name}-3.270-pkgconfig.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: pkg-config
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
CFITSIO is a library of C and Fortran subroutines for reading and writing data files in FITS (Flexible Image Transport System) data format. CFITSIO provides simple high-level routines for reading and writing FITS files that insulate the programmer from the internal complexities of the FITS format.
CFITSIO also provides many advanced features for manipulating and filtering the information in FITS files.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
CFITSIO is a library of C and Fortran subroutines for reading and writing data files in FITS (Flexible Image Transport System) data format. CFITSIO provides simple high-level routines for reading and writing FITS files that insulate the programmer from the internal complexities of the FITS format.
CFITSIO also provides many advanced features for manipulating and filtering the information in FITS files.
This package contains static libraries and header files need for development.
%prep
%setup -q -n cfitsio
%patch0 -p1
%patch1 -p1
%build
export CC=%{_host}-gcc
%configure \
--includedir=%{_includedir}/cfitsio
%make shared
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -d %{buildroot}%{_includedir}/cfitsio
%makeinstall
ln -s libcfitsio.so.0 %{buildroot}%{_libdir}/libcfitsio.so
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libcfitsio.so.*
%doc License.txt
%files devel
%defattr(-,root,root)
%{_includedir}/cfitsio/*.h
%{_libdir}/libcfitsio.a
#%{_libdir}/*.la
%{_libdir}/libcfitsio.so
%{_libdir}/pkgconfig/cfitsio.pc
%doc changes.txt README
%doc fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
%changelog
* Mon Apr 15 2013 Automatic Build System <autodist@mambasoft.it> 3.340-1mamba
- automatic version update by autodist
* Mon Sep 10 2012 Automatic Build System <autodist@mambasoft.it> 3.310-1mamba
- automatic version update by autodist
* Sun Sep 02 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.270-2mamba
- removed runtime requirement for gcc-fortran
* Sat Mar 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.270-1mamba
- update to 3.270
* Fri Mar 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.26-1mamba
- update to 3.26
* Sat Oct 18 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.100-2mamba
- removed forgotten -D -T setup options
* Mon Oct 13 2008 gil <puntogil@libero.it> 3.100-1mamba
- update to 3.100
* Fri Nov 23 2007 Aleph0 <aleph0@openmamba.org> 3.060-1mamba
- package created by autospec