update to 3.0.1 [release 3.0.1-1mamba;Wed Sep 23 2015]
This commit is contained in:
parent
934853a8c4
commit
f22915a83e
25
libcec-3.0.1-buildfix-upstream.patch
Normal file
25
libcec-3.0.1-buildfix-upstream.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 2f32a9debc1f148b5dfcfc463480f1432bb71725 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lars Op den Kamp <lars@opdenkamp.eu>
|
||||||
|
Date: Sat, 11 Jul 2015 00:53:17 +0200
|
||||||
|
Subject: [PATCH] fixed: don't generate an invalid env.h when not built with
|
||||||
|
the .git dir present. closes #112
|
||||||
|
|
||||||
|
---
|
||||||
|
support/git-rev.sh | 7 +++++--
|
||||||
|
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/support/git-rev.sh b/support/git-rev.sh
|
||||||
|
index 5dce3d0..4aadae6 100755
|
||||||
|
--- a/support/git-rev.sh
|
||||||
|
+++ b/support/git-rev.sh
|
||||||
|
@@ -1,5 +1,8 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
## cmake doesn't read the variable when it doesn't end with a newline, and I haven't figured out how to have it add a newline directly...
|
||||||
|
-echo -n "`git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h"`\n"
|
||||||
|
-
|
||||||
|
+if [ -d .git ]; then
|
||||||
|
+ echo "`git --no-pager log --abbrev=7 -n 1 --pretty=format:"%h"`"
|
||||||
|
+else
|
||||||
|
+ echo "<unknown>"
|
||||||
|
+fi
|
58
libcec.spec
58
libcec.spec
@ -10,8 +10,9 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libcec
|
Name: libcec
|
||||||
Version: 20130217git
|
Epoch: 1
|
||||||
Release: 4mamba
|
Version: 3.0.1
|
||||||
|
Release: 1mamba
|
||||||
Summary: USB CEC Adaptor communication Library
|
Summary: USB CEC Adaptor communication Library
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -19,14 +20,19 @@ Distribution: openmamba
|
|||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
URL: http://libcec.pulse-eight.com/
|
URL: http://libcec.pulse-eight.com/
|
||||||
## GITSOURCE git://github.com/Pulse-Eight/libcec.git
|
## GITSOURCE git://github.com/Pulse-Eight/libcec.git
|
||||||
Source: git://github.com/Pulse-Eight/libcec.git/master/libcec-%{version}.tar.bz2
|
Source: git://github.com/Pulse-Eight/libcec.git/libcec-%{version}/libcec-%{version}.tar.bz2
|
||||||
|
Patch0: libcec-3.0.1-buildfix-upstream.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libplatform-devel
|
||||||
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: systemd-devel
|
BuildRequires: libudev-devel
|
||||||
BuildRequires: udev-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
@ -61,37 +67,27 @@ Requires: pkg-config
|
|||||||
%description -n %{pckname}-devel
|
%description -n %{pckname}-devel
|
||||||
This package contains libraries and header files for developing applications that use %{pckname}.
|
This package contains libraries and header files for developing applications that use %{pckname}.
|
||||||
|
|
||||||
%ifnarch noarch
|
%debug_package
|
||||||
%global __debug_package 1
|
|
||||||
|
|
||||||
%package -n %{pckname}-debug
|
|
||||||
Summary: Debug information for package %{pckname}
|
|
||||||
Group: Development/Debug
|
|
||||||
AutoReqProv: 0
|
|
||||||
|
|
||||||
%description -n %{pckname}-debug
|
|
||||||
This package provides debug information for package %{pckname}.
|
|
||||||
Debug information is useful when developing applications that use this package or when debugging this package.
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#: << CBLOCK
|
#: << CBLOCK
|
||||||
./bootstrap
|
%cmake -d build \
|
||||||
%configure \
|
\
|
||||||
%if "%{?_with_raspberrypi}"
|
%if "%{?_with_raspberrypi}"
|
||||||
--with-rpi-include-path="/opt/vc/include" \
|
-DRPI_INCLUDE_DIR=/opt/vc/include \
|
||||||
--with-rpi-lib-path="/opt/vc/lib"
|
-DRPI_LIB_DIR=/opt/vc/lib
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -102,24 +98,26 @@ Debug information is useful when developing applications that use this package o
|
|||||||
%files -n %{pckname}
|
%files -n %{pckname}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/cec-client
|
%{_bindir}/cec-client
|
||||||
|
%{_bindir}/cec-client-3.0.1
|
||||||
|
%{_bindir}/cecc-client
|
||||||
|
%{_bindir}/cecc-client-3.0.1
|
||||||
|
%{_bindir}/pyCecClient.py
|
||||||
|
%{_prefix}/lib/python*/dist-packages/cec/__init__.py
|
||||||
|
%{_prefix}/lib/python*/dist-packages/cec/_cec.so
|
||||||
%{_libdir}/libcec.so.*
|
%{_libdir}/libcec.so.*
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%files -n %{pckname}-devel
|
%files -n %{pckname}-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/libcec
|
%{_includedir}/libcec
|
||||||
%{_libdir}/libcec.a
|
|
||||||
%{_libdir}/libcec.la
|
|
||||||
%{_libdir}/libcec.so
|
%{_libdir}/libcec.so
|
||||||
%{_libdir}/pkgconfig/libcec.pc
|
%{_libdir}/pkgconfig/libcec.pc
|
||||||
%doc ChangeLog README
|
%doc ChangeLog
|
||||||
|
|
||||||
%ifnarch noarch
|
|
||||||
%files -n %{pckname}-debug -f debugfiles.list
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 23 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.1-1mamba
|
||||||
|
- update to 3.0.1
|
||||||
|
|
||||||
* Sun Mar 03 2013 Davide Madrisan <davide.madrisan@gmail.com> 20130217git-4mamba
|
* Sun Mar 03 2013 Davide Madrisan <davide.madrisan@gmail.com> 20130217git-4mamba
|
||||||
- fix the summary of the devel package
|
- fix the summary of the devel package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user