rebuilt in devel [release 0.99.12p2-2mamba;Fri Jan 13 2012]
This commit is contained in:
parent
c1e88d7aa3
commit
3b7c1ac3ff
@ -1,2 +1,6 @@
|
||||
# libcdaudio
|
||||
|
||||
libcdaudio is a portable library for controlling audio CDs. It
|
||||
is also able to manage transfers of information with the
|
||||
CDDB (http://www.freedb.org/) and CDIndex systems.
|
||||
|
||||
|
12
libcdaudio-0.99-CAN-2005-0706.patch
Normal file
12
libcdaudio-0.99-CAN-2005-0706.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- libcdaudio-0.99.10/src/cddb.c.orig 2005-04-03 15:37:04.180240520 +0200
|
||||
+++ libcdaudio-0.99.10/src/cddb.c 2005-04-03 15:38:07.389631232 +0200
|
||||
@@ -1034,7 +1034,7 @@
|
||||
}
|
||||
|
||||
query->query_matches = 0;
|
||||
- while(!cddb_read_line(sock, inbuffer, 256)) {
|
||||
+ while(query->query_matches < MAX_INEXACT_MATCHES && !cddb_read_line(sock, inbuffer, 256)) {
|
||||
slashed = 0;
|
||||
if(strchr(inbuffer, '/') != NULL && parse_disc_artist) {
|
||||
index = 0;
|
||||
|
11
libcdaudio-0.99.12-buffovfl.patch
Normal file
11
libcdaudio-0.99.12-buffovfl.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/cddb.c~ 2005-09-13 13:19:44.000000000 +0200
|
||||
+++ src/cddb.c 2005-09-13 13:21:12.000000000 +0200
|
||||
@@ -1601,7 +1601,7 @@
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if((inbuffer = malloc(256)) == NULL) {
|
||||
+ if((inbuffer = malloc(512)) == NULL) {
|
||||
free(root_dir);
|
||||
free(file);
|
||||
return -1;
|
11
libcdaudio-0.99.12p2-libdir.patch
Normal file
11
libcdaudio-0.99.12p2-libdir.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- libcdaudio-0.99.12p2/libcdaudio-config.in~ 2003-02-10 21:46:14.000000000 +0100
|
||||
+++ libcdaudio-0.99.12p2/libcdaudio-config.in 2006-12-29 19:24:25.000000000 +0100
|
||||
@@ -49,7 +49,7 @@
|
||||
echo @LIB_LDADD@
|
||||
;;
|
||||
--libs)
|
||||
- libdir=-L${exec_prefix}/lib
|
||||
+ libdir=-L@libdir@
|
||||
echo $libdir -lcdaudio @LIBS@
|
||||
;;
|
||||
*)
|
79
libcdaudio.spec
Normal file
79
libcdaudio.spec
Normal file
@ -0,0 +1,79 @@
|
||||
Name: libcdaudio
|
||||
Version: 0.99.12p2
|
||||
Release: 2mamba
|
||||
Summary: Control operation of a CD-ROM when playing audio CDs
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: gil <puntogil@libero.it>
|
||||
URL: http://libcdaudio.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/project/libcdaudio/libcdaudio/%{version}/libcdaudio-%{version}.tar.gz
|
||||
Patch0: libcdaudio-0.99.12-buffovfl.patch
|
||||
Patch1: libcdaudio-0.99.12p2-libdir.patch
|
||||
Patch2: libcdaudio-0.99-CAN-2005-0706.patch
|
||||
License: GPL, LGPL
|
||||
BuildRequires: gcc-c++
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
libcdaudio is a portable library for controlling audio CDs. It
|
||||
is also able to manage transfers of information with the
|
||||
CDDB (http://www.freedb.org/) and CDIndex systems.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
libcdaudio - Control operation of a CD-ROM when playing audio CDs.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-dependency-tracking \
|
||||
--disable-static \
|
||||
--enable-threads
|
||||
make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
rm -rf %{buildroot}%{_libdir}/*.la
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libcdaudio.so.*
|
||||
%doc AUTHORS COPYING ChangeLog NEWS README TODO
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/libcdaudio-config
|
||||
%{_includedir}/cdaudio.h
|
||||
%{_libdir}/libcdaudio.so
|
||||
%{_libdir}/pkgconfig/libcdaudio.pc
|
||||
%{_datadir}/aclocal/libcdaudio.m4
|
||||
|
||||
%changelog
|
||||
* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.12p2-2mamba
|
||||
- rebuilt in devel
|
||||
|
||||
* Mon Mar 07 2011 gil <puntogil@libero.it> 0.99.12p2-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user