125 lines
4.0 KiB
RPMSpec
125 lines
4.0 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
%define apiver 1.16
|
|
Name: libcairomm
|
|
Version: 1.18.0
|
|
Release: 1mamba
|
|
Summary: A C++ wrapper for the cairo graphics library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cairographics.org/cairomm/
|
|
Source: http://www.cairographics.org/releases/cairomm-%{version}.tar.xz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libsigc++-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
cairomm is a C++ wrapper for the cairo graphics library. It offers all the power of cairo with an interface familiar to C++ developers, including use of the Standard Template Library where it makes sense.
|
|
|
|
%package devel
|
|
Summary: Devel package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
cairomm is a C++ wrapper for the cairo graphics library. It offers all the power of cairo with an interface familiar to C++ developers, including use of the Standard Template Library where it makes sense.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n cairomm-%{version}
|
|
|
|
%build
|
|
%meson \
|
|
-Dbuild-documentation=true
|
|
|
|
%meson_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%meson_install
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libcairomm-%{apiver}.so.*
|
|
%doc COPYING
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libcairomm-%{apiver}.so
|
|
%dir %{_libdir}/cairomm-%{apiver}
|
|
%dir %{_libdir}/cairomm-%{apiver}/include
|
|
%{_libdir}/cairomm-%{apiver}/include/cairommconfig.h
|
|
%dir %{_includedir}/cairomm-%{apiver}/cairomm
|
|
%{_includedir}/cairomm-%{apiver}/cairomm/*.h
|
|
%{_datadir}/devhelp/books/cairomm-%{apiver}/cairomm-%{apiver}.devhelp2
|
|
%{_libdir}/pkgconfig/*.pc
|
|
%{_datadir}/doc/cairomm-%{apiver}/reference/html/*
|
|
%{_docdir}/cairomm-%{apiver}/reference/cairomm-%{apiver}.tag
|
|
%doc ChangeLog NEWS README.md
|
|
|
|
%changelog
|
|
* Sun Oct 01 2023 Automatic Build System <autodist@mambasoft.it> 1.18.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 22 2022 Automatic Build System <autodist@mambasoft.it> 1.16.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 21 2021 Automatic Build System <autodist@mambasoft.it> 1.16.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 07 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.0-1mamba
|
|
- update to 1.16.0
|
|
|
|
* Sun Feb 05 2017 Automatic Build System <autodist@mambasoft.it> 1.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 29 2015 Automatic Build System <autodist@mambasoft.it> 1.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 14 2014 Automatic Build System <autodist@mambasoft.it> 1.11.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 1.10.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Feb 27 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.6-1mamba
|
|
- update to 1.8.6
|
|
|
|
* Fri Nov 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-3mamba
|
|
- rebuilt
|
|
|
|
* Mon Oct 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-2mamba
|
|
- rebuilt against libpng 1.4
|
|
|
|
* Mon Oct 26 2009 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Jul 12 2009 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed May 20 2009 Automatic Build System <autodist@mambasoft.it> 1.8.0-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Sat Feb 28 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Aug 19 2008 gil <puntogil@libero.it> 1.6.2-1mamba
|
|
- update to 1.6.2
|
|
|
|
* Thu Jun 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
|
|
- package created by autospec
|