280 lines
9.6 KiB
RPMSpec
280 lines
9.6 KiB
RPMSpec
%define pckver %(echo %version | tr . _)
|
|
%define pckmajver %(echo %version | cut -d. -f1-2 | tr . _)
|
|
Name: libboost155
|
|
Version: 1.55.0
|
|
Release: 3mamba
|
|
Summary: Free peer-reviewed portable C++ source libraries
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://boost.org/
|
|
Source: http://download.sourceforge.net/sourceforge/boost/boost_%{pckver}.tar.bz2
|
|
License: Boost Software License
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libbzip2-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libicu-devel
|
|
BuildRequires: libmpi-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python-devel >= 2.3.3
|
|
BuildRequires: boost-jam
|
|
BuildRequires: libicu-devel >= 54
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
|
|
|
%description
|
|
The Boost libraries provide free peer-reviewed portable C++ source libraries.
|
|
The emphasis is on libraries which work well with the C++ Standard Library.
|
|
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
|
|
|
|
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
|
|
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Devel package for libboost
|
|
Requires: %{name} = %{version}-%{release}
|
|
|
|
%description devel
|
|
The Boost libraries provide free peer-reviewed portable C++ source libraries.
|
|
The emphasis is on libraries which work well with the C++ Standard Library.
|
|
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
|
|
|
|
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
|
|
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
|
|
|
This is the devel package.
|
|
|
|
%package -n python-boost155
|
|
Group: System/Libraries
|
|
Summary: Boost.Python library
|
|
Requires: %{name} = %{version}-%{release}
|
|
|
|
%description -n python-boost155
|
|
The Boost libraries provides free peer-reviewed portable C++ source libraries.
|
|
The emphasis is on libraries which work well with the C++ Standard Library.
|
|
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
|
|
|
|
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
|
|
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
|
|
|
This package contains then Boost.python library
|
|
|
|
%package -n python-boost155-devel
|
|
Group: Development/Libraries
|
|
Summary: Devel package for %{name}-python
|
|
Requires: python-boost155 = %{version}-%{release}
|
|
Requires: %{name} = %{version}-%{release}
|
|
Requires: %{name}-devel = %{version}-%{release}
|
|
|
|
%description -n python-boost155-devel
|
|
The Boost library provide free peer-reviewed portable C++ source libraries.
|
|
The emphasis is on libraries which work well with the C++ Standard Library.
|
|
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
|
|
|
|
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
|
|
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
|
|
|
This is the devel package for the Boost.Python library.
|
|
|
|
%prep
|
|
%setup -q -n boost_%{pckver}
|
|
|
|
%build
|
|
./bootstrap.sh \
|
|
--with-icu \
|
|
--with-python-root=%{_prefix} \
|
|
--with-python-version=%{python_version} \
|
|
--with-libraries=all
|
|
|
|
# 1.4.5 needs to be build with internal bjam
|
|
# --with-bjam=%{_bindir}/bjam \
|
|
|
|
cat >> tools/build/v2/user-config.jam << _EOF
|
|
|
|
using mpi ;
|
|
|
|
_EOF
|
|
|
|
EXPAT_INCLUDE=%{_includedir} \
|
|
EXPAT_LIBPATH=%{_libdir} \
|
|
./bjam \
|
|
--prefix=%{_prefix} \
|
|
--layout=tagged -d2 \
|
|
runtime-link=shared \
|
|
link=shared,static \
|
|
toolset=gcc \
|
|
variant=release \
|
|
threading=single,multi \
|
|
debug-symbols=on \
|
|
stage \
|
|
%ifarch x86_64
|
|
cflags="-fPIC"
|
|
%endif
|
|
|
|
# %{?_smp_mflags} \
|
|
# -sPYTHON_VERSION=%{python_ver} \
|
|
# -sBUILD="release <threading>single/multiple" \
|
|
|
|
# --with-python-root=%{_prefix}
|
|
|
|
#% make \
|
|
# BJAM_CONFIG="release -sICU_PATH=/usr \
|
|
# threading=multi optimization=speed inlining=full \
|
|
# -sNO_COMPRESSION=0 -sZLIB_INCLUDE=/usr/include -sZLIB_LIBPATH=/usr/lib \
|
|
# -sBZIP2_INCLUDE=/usr/include -sBZIP2_LIBPATH=/usr/lib \
|
|
# --layout=system --builddir=obj --toolset=gcc"
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
EXPAT_INCLUDE=%{_includedir} \
|
|
EXPAT_LIBPATH=%{_libdir} \
|
|
./bjam \
|
|
--prefix=%{buildroot}%{_prefix} \
|
|
--libdir=%{buildroot}%{_libdir} \
|
|
--execprefix=%{buildroot}%{_libexecdir} \
|
|
--includedir=%{buildroot}%{_includedir} \
|
|
--layout=tagged -d2 \
|
|
runtime-link=shared \
|
|
link=shared,static \
|
|
toolset=gcc \
|
|
variant=release \
|
|
threading=single,multi \
|
|
debug-symbols=on \
|
|
install
|
|
|
|
# --includedir=%{buildroot}%{_includedir} \
|
|
|
|
# -sTOOLS=gcc \
|
|
# -sPYTHON_VERSION=%{python_ver} \
|
|
# -sBUILD="release <threading>single/multiple" \
|
|
|
|
|
|
# --with-python-root=%{_prefix} \
|
|
|
|
#for f in %{buildroot}%{_libdir}/libboost_*-mt.so; do
|
|
# mv $f ${f/-mt}.%{version}
|
|
# ln -s `basename ${f/-mt}.%{version}` ${f/-mt}
|
|
#done
|
|
|
|
#for f in %{buildroot}%{_libdir}/libboost_*-mt.a; do
|
|
# mv $f ${f/-mt}
|
|
#done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/*.so.*
|
|
%exclude %{_libdir}/libboost_python*.so.*
|
|
%doc LICENSE_1_0.txt
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/boost
|
|
%{_includedir}/boost/*
|
|
%{_libdir}/*.so
|
|
%{_libdir}/*.a
|
|
#%exclude %{_libdir}/libboost_python*.a
|
|
%exclude %{_libdir}/libboost_python*.so
|
|
|
|
%files -n python-boost155
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libboost_python*.so.*
|
|
|
|
%files -n python-boost155-devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libboost_python*.so
|
|
|
|
%changelog
|
|
* Tue Feb 03 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.55.0-3mamba
|
|
- legacy package
|
|
|
|
* Thu Oct 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.55.0-2mamba
|
|
- rebuilt with libicu 53
|
|
|
|
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.55.0-1mamba
|
|
- update to 1.55.0
|
|
|
|
* Sat Jul 13 2013 Automatic Build System <autodist@mambasoft.it> 1.54.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 30 2013 Automatic Build System <autodist@mambasoft.it> 1.53.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52.0-2mamba
|
|
- fix adding locales library (added --with-libraries=all to bootstrap.sh)
|
|
|
|
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52.0-1mamba
|
|
- update to 1.52.0
|
|
- add --with-locale required by blender 2.65
|
|
|
|
* Mon Jul 30 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.50.0-1mamba
|
|
- update to 1.50.0
|
|
|
|
* Fri Jun 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.45.0-2mamba
|
|
- added patch to fix thread support with gcc >= 4.7
|
|
|
|
* Tue Dec 14 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.45.0-1mamba
|
|
- update to 1.45.0
|
|
|
|
* Tue Jun 29 2010 Automatic Build System <autodist@mambasoft.it> 1.43.0-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Thu Jun 10 2010 Automatic Build System <autodist@mambasoft.it> 1.43.0-1mamba
|
|
- update to 1.43.0
|
|
|
|
* Thu Jun 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-3mamba
|
|
- added no_exception patch to serialization/throw_exception.hpp (see http://marc.info/?l=boost&m=123972460823115&w=2)
|
|
|
|
* Thu Jun 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-2mamba
|
|
- re-enable ICU support and threading variants
|
|
|
|
* Thu Jun 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-1mamba
|
|
- update to 1.39.0
|
|
|
|
* Tue Mar 31 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.38.0-1mamba
|
|
- update to 1.38.0
|
|
- python packages renamed to python-boost*
|
|
|
|
* Wed Feb 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.37.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Oct 28 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36.0-2mamba
|
|
- rebuilt against python 2.6
|
|
|
|
* Fri Sep 12 2008 gil <puntogil@libero.it> 1.36.0-1mamba
|
|
- update to 1.36.0
|
|
|
|
* Mon Jul 21 2008 gil <puntogil@libero.it> 1.35.0-1mamba
|
|
- update to 1.35.0
|
|
- edit patch0
|
|
|
|
* Sun Oct 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.34.1-1mamba
|
|
- update to 1.34.1
|
|
|
|
* Mon Jul 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.34.0-1mamba
|
|
- update to 1.34.0
|
|
|
|
* Fri Apr 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.33.1-1mamba
|
|
- update to 1.33.1
|
|
|
|
* Tue Feb 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.32.0-1qilnx
|
|
- update to version 1.32.0 by autospec
|
|
- package license modified
|
|
- added license file in the package documentation
|
|
- specfile updates
|
|
- fixes in the install section
|
|
- added missing header files
|
|
|
|
* Tue Jun 29 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.31.0-1qilnx
|
|
- first build
|