update to 1.55.0 [release 1.55.0-1mamba;Sat Nov 30 2013]

This commit is contained in:
Silvan Calarco 2024-01-06 03:52:22 +01:00
parent f6ecb16256
commit bf6f4f00d5
14 changed files with 619 additions and 0 deletions

View File

@ -1,2 +1,9 @@
# libboost
The Boost libraries provide free peer-reviewed portable C++ source libraries.
The emphasis is on libraries which work well with the C++ Standard Library.
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.

View File

@ -0,0 +1,11 @@
--- boost_1_35_0/tools/jam/src/build.jam 2007-12-01 21:17:52.000000000 +0100
+++ boost_1_35_0-gil/tools/jam/src/build.jam 2008-07-21 12:07:27.000000000 +0200
@@ -176,7 +176,7 @@
## GCC 2.x, 3.x, 4.x
toolset gcc gcc : "-o " : -D
: -pedantic -fno-strict-aliasing
- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
+ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
[ opt --debug : -g -O0 -fno-inline ]
-I$(--python-include) -I$(--extra-include) -Wno-long-long
: -L$(--python-lib[1]) -l$(--python-lib[2]) ;

View File

@ -0,0 +1,16 @@
--- boost_1_35_0/tools/jam/src/builtins.c 2007-10-27 11:55:58.000000000 +0200
+++ boost_1_35_0-gil/tools/jam/src/builtins.c 2008-07-21 12:09:39.000000000 +0200
@@ -63,6 +63,13 @@
void backtrace_line( FRAME *frame );
void print_source_line( PARSE* p );
+void init_set();
+void init_path();
+void init_regex();
+void init_property_set();
+void init_sequence();
+void init_order();
+
RULE* bind_builtin( char* name, LIST*(*f)(PARSE*, FRAME*), int flags, char** args )
{
argument_list* arg_list = 0;

View File

@ -0,0 +1,14 @@
--- boost_1_35_0/tools/jam/src/debug.c 2006-09-20 06:03:20.000000000 +0200
+++ boost_1_35_0-gil/tools/jam/src/debug.c 2008-07-21 12:19:18.000000000 +0200
@@ -112,9 +112,8 @@
profile_total.memory += p->memory;
}
printf("%10d %12.6f %12.6f %12.8f %10d %10d %s\n",
- p->num_entries,
- cumulative,net,q,
- p->memory, mem_each,
+ (int) p->num_entries, (int) p->cumulative, (int) p->net, q,
+ (int) p->memory, (int) mem_each,
p->name);
}

View File

@ -0,0 +1,13 @@
--- boost_1_35_0/tools/build/v2/tools/gcc.jam 2008-03-15 19:55:28.000000000 +0100
+++ boost_1_35_0-gil/tools/build/v2/tools/gcc.jam 2008-07-21 12:04:56.000000000 +0200
@@ -284,8 +284,8 @@
# Declare flags and action for compilation
flags gcc.compile OPTIONS <optimization>off : -O0 ;
-flags gcc.compile OPTIONS <optimization>speed : -O3 ;
-flags gcc.compile OPTIONS <optimization>space : -Os ;
+flags gcc.compile OPTIONS <optimization>speed : -O3 -fno-strict-aliasing ;
+flags gcc.compile OPTIONS <optimization>space : -Os -fno-strict-aliasing ;
flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
flags gcc.compile OPTIONS <inlining>on : -Wno-inline ;

View File

@ -0,0 +1,26 @@
--- boost_1_35_0/tools/jam/src/hcache.c 2006-09-07 05:57:02.000000000 +0200
+++ boost_1_35_0-gil/tools/jam/src/hcache.c 2008-07-21 11:53:01.000000000 +0200
@@ -162,7 +162,7 @@
{
if (!s)
s = "";
- fprintf(f, "%lu\t%s\n", strlen(s), s);
+ fprintf(f, "%lu\t%s\n", (unsigned long) strlen(s), s);
}
void
@@ -314,10 +314,10 @@
else if (c->age > maxage)
continue;
- sprintf(includes_count_str, "%lu", list_length(c->includes));
- sprintf(hdrscan_count_str, "%lu", list_length(c->hdrscan));
- sprintf(time_str, "%lu", c->time);
- sprintf(age_str, "%lu", c->age);
+ sprintf(includes_count_str, "%lu", (unsigned long) list_length(c->includes));
+ sprintf(hdrscan_count_str, "%lu", (unsigned long) list_length(c->hdrscan));
+ sprintf(time_str, "%lu", (unsigned long) c->time);
+ sprintf(age_str, "%lu", (unsigned long) c->age);
write_netstring(f, CACHE_RECORD_HEADER);
write_netstring(f, c->boundname);

View File

@ -0,0 +1,17 @@
--- boost_1_35_0/tools/jam/src/make1.c 2007-11-28 08:21:49.000000000 +0100
+++ boost_1_35_0-gil/tools/jam/src/make1.c 2008-07-21 12:26:16.000000000 +0200
@@ -60,12 +60,13 @@
# include "make.h"
# include "command.h"
# include "execcmd.h"
+# include "debug.h"
# include "compile.h"
# include "output.h"
# include <stdlib.h>
-#if defined(sun) || defined(__sun)
+#if defined(sun) || defined(__sun) || defined(unix) || defined(__unix)
#include <unistd.h> /* for unlink */
#endif

View File

@ -0,0 +1,10 @@
--- boost_1_35_0/tools/jam/src/native.c 2005-09-28 16:09:58.000000000 +0200
+++ boost_1_35_0-gil/tools/jam/src/native.c 2008-07-21 11:53:01.000000000 +0200
@@ -8,6 +8,7 @@
# define P0 (PARSE *)0
# define C0 (char *)0
+void lol_build( LOL* lol, char** elements );
void declare_native_rule(char* module, char* rule, char** args,
LIST*(*f)(PARSE*, FRAME*), int version)

View File

@ -0,0 +1,10 @@
--- boost_1_35_0/tools/jam/src/newstr.c 2006-09-10 19:04:21.000000000 +0200
+++ boost_1_35_0-gil/tools/jam/src/newstr.c 2008-07-21 11:53:01.000000000 +0200
@@ -8,6 +8,7 @@
# include "newstr.h"
# include "hash.h"
# include "compile.h"
+# include "debug.h"
# include <stddef.h>
# include <stdlib.h>

View File

@ -0,0 +1,15 @@
diff -ru boost_1_39_0.orig/boost/function/function_template.hpp boost_1_39_0/boost/function/function_template.hpp
--- boost_1_39_0.orig/boost/function/function_template.hpp 2008-10-16 15:21:50.000000000 +0200
+++ boost_1_39_0/boost/function/function_template.hpp 2009-06-04 14:10:36.000000000 +0200
@@ -950,10 +950,10 @@
f.vtable->manager(f.functor, this->functor,
boost::detail::function::move_functor_tag);
f.vtable = 0;
-#if !defined(BOOST_NO_EXCEPTIONS)
} else {
clear();
}
+#if !defined(BOOST_NO_EXCEPTIONS)
} catch (...) {
vtable = 0;
throw;

View File

@ -0,0 +1,21 @@
Index: throw_exception.hpp
===================================================================
--- boost/serialization/throw_exception.hpp (revision 52381)
+++ boost/serialization/throw_exception.hpp (working copy)
@@ -17,7 +17,7 @@
#include <boost/config.hpp>
-#ifdef BOOST_NO_EXCEPTIONS
+#ifndef BOOST_NO_EXCEPTIONS
# include <exception>
#endif
@@ -26,7 +26,7 @@
#ifdef BOOST_NO_EXCEPTIONS
-void throw_exception(std::exception const & e) {
+void inline throw_exception(std::exception const & e) {
::boost::throw_exception(e);
}

View File

@ -0,0 +1,146 @@
From 5c77ecf330364ef1d85146428f769b87402cac57 Mon Sep 17 00:00:00 2001
From: vladimir_prus <vladimir_prus@b8fc166d-592f-0410-95f2-cb63ce0dd405>
Date: Fri, 15 May 2009 05:23:56 +0000
Subject: [PATCH] Implement the 'tagged' layout.
git-svn-id: http://svn.boost.org/svn/boost/trunk@53015 b8fc166d-592f-0410-95f2-cb63ce0dd405
---
Jamroot | 104 ++++++++++++++++++++++++++++++++-------------------------------
1 files changed, 53 insertions(+), 51 deletions(-)
diff --git a/Jamroot b/Jamroot
index 919ab01..ca61af1 100644
--- a/Jamroot
+++ b/Jamroot
@@ -64,21 +64,26 @@
# versions of Boost or multiple compilers can
# be used on the same system.
#
-# versioned (default) - Names of boost
-# binaries include the Boost version
-# number and the name and version of the
-# compiler. Boost headers are installed
-# in a subdirectory of <HDRDIR> whose
-# name contains the Boost version
-# number.
-#
-# system - Binaries names do not include
-# the Boost version number or the name
-# and version number of the compiler.
-# Boost headers are installed directly
-# into <HDRDIR>. This option is
-# intended for system integrators who
-# are building distribution packages.
+# versioned (default) - Names of boost binaries
+# include the Boost version number, name and
+# version of the compiler and encoded build
+# properties. Boost headers are installed in a
+# subdirectory of <HDRDIR> whose name contains
+# the Boost version number.
+#
+# tagged -- Names of boost binaries include the
+# encoded build properties such as variant and
+# threading, but do not including compiler name
+# and version, or Boost version. This option is
+# useful if you build several variants of Boost,
+# using the same compiler.
+#
+# system - Binaries names do not include the
+# Boost version number or the name and version
+# number of the compiler. Boost headers are
+# installed directly into <HDRDIR>. This option
+# is intended for system integrators who are
+# building distribution packages.
#
# --buildid=ID Adds the specified ID to the name of built
# libraries. The default is to not add anything.
@@ -318,53 +323,50 @@ rule tag ( name : type ? : property-set )
{
if $(type) in STATIC_LIB SHARED_LIB IMPORT_LIB
{
+ local result ;
if $(layout) = versioned
{
- local result = [ common.format-name
+ result = [ common.format-name
<base> <toolset> <threading> <runtime> -$(BOOST_VERSION_TAG)
-$(BUILD_ID)
: $(name) : $(type) : $(property-set) ] ;
-
- # Optionally add version suffix. On NT, library with version suffix
- # will not be recognized by linkers. On CYGWIN, we get strage
- # duplicate symbol errors when library is generated with version
- # suffix. On OSX, version suffix is not needed -- the linker expects
- # the libFoo.1.2.3.dylib format. AIX linkers do not accept version
- # suffixes either. Pgi compilers can not accept library with version
- # suffix.
- if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
- ! ( [ $(property-set).get <toolset> ] in pgi ) )
- {
- result = $(result).$(BOOST_VERSION) ;
- }
-
- return $(result) ;
+ }
+ else if $(layout) = tagged
+ {
+ result = [ common.format-name
+ <base> <threading> <runtime>
+ -$(BUILD_ID)
+ : $(name) : $(type) : $(property-set) ] ;
}
- else
+ else if $(layout) = system
{
- local result = [ common.format-name
+ result = [ common.format-name
<base>
-$(BUILD_ID)
: $(name) : $(type) : $(property-set) ] ;
-
- # Optionally add version suffix. On NT, library with version suffix
- # will not be recognized by linkers. On CYGWIN, we get strage
- # duplicate symbol errors when library is generated with version
- # suffix. On OSX, version suffix is not needed -- the linker expects
- # the libFoo.1.2.3.dylib format. AIX linkers do not accept version
- # suffixes either. Pgi compilers can not accept library with version
- # suffix.
- if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
- ! ( [ $(property-set).get <toolset> ] in pgi ) )
- {
- result = $(result).$(BOOST_VERSION) ;
- }
-
- return $(result) ;
}
- }
+ else
+ {
+ ECHO "error: invalid layout '$(layout)'" ;
+ EXIT ;
+ }
+
+ # Optionally add version suffix. On NT, library with version suffix
+ # will not be recognized by linkers. On CYGWIN, we get strage
+ # duplicate symbol errors when library is generated with version
+ # suffix. On OSX, version suffix is not needed -- the linker expects
+ # the libFoo.1.2.3.dylib format. AIX linkers do not accept version
+ # suffixes either. Pgi compilers can not accept library with version
+ # suffix.
+ if $(type) = SHARED_LIB &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ! ( [ $(property-set).get <toolset> ] in pgi ) )
+ {
+ result = $(result).$(BOOST_VERSION) ;
+ }
+
+ return $(result) ;
+ }
}
--
1.6.1

View File

@ -0,0 +1,13 @@
diff -Nru boost_1_45_0.orig/boost/config/stdlib/libstdcpp3.hpp boost_1_45_0/boost/config/stdlib/libstdcpp3.hpp
--- boost_1_45_0.orig/boost/config/stdlib/libstdcpp3.hpp 2010-10-01 11:19:44.000000000 +0200
+++ boost_1_45_0/boost/config/stdlib/libstdcpp3.hpp 2012-06-29 17:11:28.337977172 +0200
@@ -31,7 +31,8 @@
#ifdef __GLIBCXX__ // gcc 3.4 and greater:
# if defined(_GLIBCXX_HAVE_GTHR_DEFAULT) \
- || defined(_GLIBCXX__PTHREADS)
+ || defined(_GLIBCXX__PTHREADS) \
+ || defined(_GLIBCXX_HAS_GTHREADS)
//
// If the std lib has thread support turned on, then turn it on in Boost
// as well. We do this because some gcc-3.4 std lib headers define _REENTANT

300
libboost.spec Normal file
View File

@ -0,0 +1,300 @@
%define pckver %(echo %version | tr . _)
%define pckmajver %(echo %version | cut -d. -f1-2 | tr . _)
Name: libboost
Version: 1.55.0
Release: 1mamba
Summary: Free peer-reviewed portable C++ source libraries
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://boost.org/
Source: http://download.sourceforge.net/sourceforge/boost/boost_%{pckver}.tar.bz2
Patch0: %{name}-1.35.0-gcc42.patch
Patch1: %{name}-1.35.0-build.patch
Patch2: %{name}-1.35.0-builtins.patch
Patch3: %{name}-1.35.0-debug.patch
Patch4: %{name}-1.35.0-hcache.patch
Patch5: %{name}-1.35.0-make1.patch
Patch6: %{name}-1.35.0-native.patch
Patch7: %{name}-1.35.0-newstr.patch
Patch8: %{name}-1.39.0-function_template_header.patch
Patch9: %{name}-1.39.0-tagged_layout.patch
Patch10: %{name}-1.39.0-no_exceptions.patch
Patch11: %{name}-1.45.0-gcc-4.7-threads.patch
License: Boost Software License
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbzip2-devel
BuildRequires: libgcc
BuildRequires: libicu-devel
BuildRequires: libmpi-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: python-devel >= 2.3.3
BuildRequires: boost-jam
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
%description
The Boost libraries provide free peer-reviewed portable C++ source libraries.
The emphasis is on libraries which work well with the C++ Standard Library.
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
%package devel
Group: Development/Libraries
Summary: Devel package for libboost
Requires: %{name} = %{version}-%{release}
%description devel
The Boost libraries provide free peer-reviewed portable C++ source libraries.
The emphasis is on libraries which work well with the C++ Standard Library.
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
This is the devel package.
%package -n python-boost
Group: System/Libraries
Summary: Boost.Python library
Provides: libboost-python
Obsoletes: libboost-python
Requires: %{name} = %{version}-%{release}
%description -n python-boost
The Boost libraries provides free peer-reviewed portable C++ source libraries.
The emphasis is on libraries which work well with the C++ Standard Library.
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
This package contains then Boost.python library
%package -n python-boost-devel
Group: Development/Libraries
Summary: Devel package for %{name}-python
Provides: libboost-python-devel
Obsoletes: libboost-python-devel
Requires: python-boost = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires: %{name}-devel = %{version}-%{release}
%description -n python-boost-devel
The Boost library provide free peer-reviewed portable C++ source libraries.
The emphasis is on libraries which work well with the C++ Standard Library.
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
This is the devel package for the Boost.Python library.
%prep
%setup -q -n boost_%{pckver}
#%patch0 -p1
#%patch1 -p1
#%patch2 -p1
#%patch3 -p1
#%patch4 -p1
#%patch5 -p1
#%patch6 -p1
#%patch7 -p1
#%patch8 -p1
#%patch9 -p1
#%patch10 -p0
#%patch11 -p1
%build
./bootstrap.sh \
--with-icu \
--with-python-root=%{_prefix} \
--with-python-version=%{python_version} \
--with-libraries=all
# 1.4.5 needs to be build with internal bjam
# --with-bjam=%{_bindir}/bjam \
cat >> tools/build/v2/user-config.jam << _EOF
using mpi ;
_EOF
EXPAT_INCLUDE=%{_includedir} \
EXPAT_LIBPATH=%{_libdir} \
./bjam \
--prefix=%{_prefix} \
--layout=tagged -d2 \
runtime-link=shared \
link=shared,static \
toolset=gcc \
variant=release \
threading=single,multi \
debug-symbols=on \
stage \
%ifarch x86_64
cflags="-fPIC"
%endif
# %{?_smp_mflags} \
# -sPYTHON_VERSION=%{python_ver} \
# -sBUILD="release <threading>single/multiple" \
# --with-python-root=%{_prefix}
#% make \
# BJAM_CONFIG="release -sICU_PATH=/usr \
# threading=multi optimization=speed inlining=full \
# -sNO_COMPRESSION=0 -sZLIB_INCLUDE=/usr/include -sZLIB_LIBPATH=/usr/lib \
# -sBZIP2_INCLUDE=/usr/include -sBZIP2_LIBPATH=/usr/lib \
# --layout=system --builddir=obj --toolset=gcc"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
EXPAT_INCLUDE=%{_includedir} \
EXPAT_LIBPATH=%{_libdir} \
./bjam \
--prefix=%{buildroot}%{_prefix} \
--libdir=%{buildroot}%{_libdir} \
--execprefix=%{buildroot}%{_libexecdir} \
--includedir=%{buildroot}%{_includedir} \
--layout=tagged -d2 \
runtime-link=shared \
link=shared,static \
toolset=gcc \
variant=release \
threading=single,multi \
debug-symbols=on \
install
# --includedir=%{buildroot}%{_includedir} \
# -sTOOLS=gcc \
# -sPYTHON_VERSION=%{python_ver} \
# -sBUILD="release <threading>single/multiple" \
# --with-python-root=%{_prefix} \
#for f in %{buildroot}%{_libdir}/libboost_*-mt.so; do
# mv $f ${f/-mt}.%{version}
# ln -s `basename ${f/-mt}.%{version}` ${f/-mt}
#done
#for f in %{buildroot}%{_libdir}/libboost_*-mt.a; do
# mv $f ${f/-mt}
#done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/*.so.*
%exclude %{_libdir}/libboost_python*.so.*
%doc LICENSE_1_0.txt
%files devel
%defattr(-,root,root)
%dir %{_includedir}/boost
%{_includedir}/boost/*
%{_libdir}/*.so
%{_libdir}/*.a
#%exclude %{_libdir}/libboost_python*.a
%exclude %{_libdir}/libboost_python*.so
%files -n python-boost
%defattr(-,root,root)
%{_libdir}/libboost_python*.so.*
%files -n python-boost-devel
%defattr(-,root,root)
%{_libdir}/libboost_python*.so
%changelog
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.55.0-1mamba
- update to 1.55.0
* Sat Jul 13 2013 Automatic Build System <autodist@mambasoft.it> 1.54.0-1mamba
- automatic version update by autodist
* Sat Mar 30 2013 Automatic Build System <autodist@mambasoft.it> 1.53.0-1mamba
- automatic version update by autodist
* Mon Dec 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52.0-2mamba
- fix adding locales library (added --with-libraries=all to bootstrap.sh)
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52.0-1mamba
- update to 1.52.0
- add --with-locale required by blender 2.65
* Mon Jul 30 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.50.0-1mamba
- update to 1.50.0
* Fri Jun 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.45.0-2mamba
- added patch to fix thread support with gcc >= 4.7
* Tue Dec 14 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.45.0-1mamba
- update to 1.45.0
* Tue Jun 29 2010 Automatic Build System <autodist@mambasoft.it> 1.43.0-2mamba
- automatic rebuild by autodist
* Thu Jun 10 2010 Automatic Build System <autodist@mambasoft.it> 1.43.0-1mamba
- update to 1.43.0
* Thu Jun 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-3mamba
- added no_exception patch to serialization/throw_exception.hpp (see http://marc.info/?l=boost&m=123972460823115&w=2)
* Thu Jun 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-2mamba
- re-enable ICU support and threading variants
* Thu Jun 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.39.0-1mamba
- update to 1.39.0
* Tue Mar 31 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.38.0-1mamba
- update to 1.38.0
- python packages renamed to python-boost*
* Wed Feb 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.37.0-1mamba
- automatic update by autodist
* Tue Oct 28 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36.0-2mamba
- rebuilt against python 2.6
* Fri Sep 12 2008 gil <puntogil@libero.it> 1.36.0-1mamba
- update to 1.36.0
* Mon Jul 21 2008 gil <puntogil@libero.it> 1.35.0-1mamba
- update to 1.35.0
- edit patch0
* Sun Oct 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.34.1-1mamba
- update to 1.34.1
* Mon Jul 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.34.0-1mamba
- update to 1.34.0
* Fri Apr 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.33.1-1mamba
- update to 1.33.1
* Tue Feb 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.32.0-1qilnx
- update to version 1.32.0 by autospec
- package license modified
- added license file in the package documentation
- specfile updates
- fixes in the install section
- added missing header files
* Tue Jun 29 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.31.0-1qilnx
- first build