remove and obsolete python-boost-py310 [release 1.85.0-2mamba;Sat Apr 20 2024]
This commit is contained in:
parent
44a9e6c89d
commit
79edf3b319
@ -1,15 +0,0 @@
|
||||
--- boost_1_57_0/boost/type_traits/detail/has_binary_operator.hpp.orig 2015-04-11 16:45:40.250578640 +0200
|
||||
+++ boost_1_57_0/boost/type_traits/detail/has_binary_operator.hpp 2015-04-11 16:45:58.911577918 +0200
|
||||
@@ -6,6 +6,7 @@
|
||||
//
|
||||
// See http://www.boost.org/libs/type_traits for most recent version including documentation.
|
||||
|
||||
+#ifndef Q_MOC_RUN
|
||||
#include <boost/config.hpp>
|
||||
#include <boost/type_traits/ice.hpp>
|
||||
#include <boost/type_traits/integral_constant.hpp>
|
||||
@@ -227,3 +228,4 @@
|
||||
#endif
|
||||
|
||||
#include <boost/type_traits/detail/bool_trait_undef.hpp>
|
||||
+#endif
|
@ -1,28 +0,0 @@
|
||||
From 3e405b6fd5db5615bbef241763de070118222ca7 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Seefeld <stefan@seefeld.name>
|
||||
Date: Thu, 9 Apr 2015 08:57:08 -0400
|
||||
Subject: [PATCH] Fix exec_file for Python 3 < 3.4.
|
||||
|
||||
---
|
||||
src/exec.cpp | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libs/python/src/exec.cpp b/libs/python/src/exec.cpp
|
||||
index 2910db7..12cdabc 100644
|
||||
--- a/libs/python/src/exec.cpp
|
||||
+++ b/libs/python/src/exec.cpp
|
||||
@@ -86,9 +86,12 @@ object BOOST_PYTHON_DECL exec_file(str filename, object global, object local)
|
||||
char *f = python::extract<char *>(filename);
|
||||
|
||||
// Let python open the file to avoid potential binary incompatibilities.
|
||||
-#if PY_VERSION_HEX >= 0x03000000
|
||||
- // See http://www.codeproject.com/Articles/820116/Embedding-Python-program-in-a-C-Cplusplus-code
|
||||
+#if PY_VERSION_HEX >= 0x03400000
|
||||
FILE *fs = _Py_fopen(f, "r");
|
||||
+#elif PY_VERSION_HEX >= 0x03000000
|
||||
+ PyObject *fo = Py_BuildValue("s", f);
|
||||
+ FILE *fs = _Py_fopen(fo, "r");
|
||||
+ Py_DECREF(fo);
|
||||
#else
|
||||
PyObject *pyfile = PyFile_FromString(f, const_cast<char*>("r"));
|
||||
if (!pyfile) throw std::invalid_argument(std::string(f) + " : no such file");
|
@ -1,48 +0,0 @@
|
||||
From 6064875bff2e52ba63f01911eb4deb79259c5e3b Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
|
||||
Date: Thu, 3 Jun 2021 23:10:37 +0100
|
||||
Subject: [PATCH] Fixes wrong type for mutex in regex v5
|
||||
|
||||
With the Boost.Regex to ehader-only library, the declaration
|
||||
of a mutex that should have been changed from boost::static_mutex
|
||||
to std::mutex was left behind. This was preventing regex from
|
||||
being built for older arm platforms [1]
|
||||
|
||||
[1]: https://github.com/openwrt/packages/issues/15725
|
||||
|
||||
Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
|
||||
---
|
||||
include/boost/regex/v5/mem_block_cache.hpp | 12 ++++--------
|
||||
1 file changed, 4 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/include/boost/regex/v5/mem_block_cache.hpp b/include/boost/regex/v5/mem_block_cache.hpp
|
||||
index 0af4eae18..eb3ec776c 100644
|
||||
--- a/include/boost/regex/v5/mem_block_cache.hpp
|
||||
+++ b/include/boost/regex/v5/mem_block_cache.hpp
|
||||
@@ -85,10 +85,10 @@ struct mem_block_node
|
||||
struct mem_block_cache
|
||||
{
|
||||
// this member has to be statically initialsed:
|
||||
- mem_block_node* next;
|
||||
- unsigned cached_blocks;
|
||||
+ mem_block_node* next { nullptr };
|
||||
+ unsigned cached_blocks { 0 };
|
||||
#ifdef BOOST_HAS_THREADS
|
||||
- boost::static_mutex mut;
|
||||
+ std::mutex mut;
|
||||
#endif
|
||||
|
||||
~mem_block_cache()
|
||||
@@ -133,11 +133,7 @@ struct mem_block_cache
|
||||
}
|
||||
static mem_block_cache& instance()
|
||||
{
|
||||
-#ifdef BOOST_HAS_THREADS
|
||||
- static mem_block_cache block_cache = { 0, 0, BOOST_STATIC_MUTEX_INIT, };
|
||||
-#else
|
||||
- static mem_block_cache block_cache = { 0, 0, };
|
||||
-#endif
|
||||
+ static mem_block_cache block_cache;
|
||||
return block_cache;
|
||||
}
|
||||
};
|
110
libboost.spec
110
libboost.spec
@ -1,8 +1,8 @@
|
||||
%define pckver %(echo %version | tr . _)
|
||||
%define pckmajver %(echo %version | cut -d. -f1-2 | tr . _)
|
||||
Name: libboost
|
||||
Version: 1.84.0
|
||||
Release: 1mamba
|
||||
Version: 1.85.0
|
||||
Release: 2mamba
|
||||
Summary: Free peer-reviewed portable C++ source libraries
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -10,9 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.boost.org/
|
||||
Source: https://boostorg.jfrog.io/artifactory/main/release/%{version}/source/boost_%{pckver}.tar.bz2
|
||||
Patch0: libboost-1.57.0-moc-libqt4-4.8.6.patch
|
||||
Patch1: libboost-1.58.0-python-3.3.patch
|
||||
Patch2: libboost-1.76.0-arm-upstream-fix-build.patch
|
||||
License: Boost Software License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -21,6 +18,9 @@ BuildRequires: libgcc
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmpi-devel
|
||||
%ifnarch aarch64
|
||||
BuildRequires: libquadmath-devel
|
||||
%endif
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
@ -59,6 +59,7 @@ This is the devel package.
|
||||
Group: System/Libraries
|
||||
Summary: Boost.Python library for Python 3
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: python-boost-py310 <= 1.85.0-1mamba
|
||||
|
||||
%description -n python-boost-py3
|
||||
The Boost libraries provides free peer-reviewed portable C++ source libraries.
|
||||
@ -68,30 +69,11 @@ A further goal is to establish "existing practice" and provide reference impleme
|
||||
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
||||
This package contains then Boost.python library for Python 3.
|
||||
|
||||
%package -n python-boost-py310
|
||||
Group: System/Libraries
|
||||
Summary: Boost.Python library for Python 3.10
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n python-boost-py310
|
||||
The Boost libraries provides free peer-reviewed portable C++ source libraries.
|
||||
The emphasis is on libraries which work well with the C++ Standard Library.
|
||||
The libraries are intended to be widely useful, and are in regular use by thousands of programmers across a broad spectrum of applications.
|
||||
A further goal is to establish "existing practice" and provide reference implementations so that Boost libraries are suitable for eventual standardization.
|
||||
Ten Boost libraries will be included in the C++ Standards Committee's upcoming C++ Standard Library Technical Report as a step toward becoming part of a future C++ Standard.
|
||||
This package contains then Boost.python library for Python 3.10.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n boost_%{pckver} -a0
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
mv boost_%{pckver} boost_python310
|
||||
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p2
|
||||
%setup -q -n boost_%{pckver} -D -T
|
||||
:<< _EOF
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -116,64 +98,16 @@ EXPAT_LIBPATH=%{_libdir} \
|
||||
variant=release \
|
||||
threading=multi \
|
||||
debug-symbols=on \
|
||||
stage \
|
||||
%ifarch x86_64
|
||||
cflags="-fPIC"
|
||||
cflags="-fPIC" \
|
||||
%endif
|
||||
|
||||
cd boost_python310
|
||||
# Rebuild boost with Python 3.10
|
||||
rm -f user-config.jam
|
||||
|
||||
./bootstrap.sh \
|
||||
--with-icu \
|
||||
--with-python-root=%{_prefix} \
|
||||
--with-python-version=%{python310_version} \
|
||||
--with-libraries=python
|
||||
|
||||
sed -i "s|using python.*|using python : %{python310_version} : %{_prefix} : %{python310_inc} ;|" project-config.jam
|
||||
echo "using mpi ;" >> project-config.jam
|
||||
|
||||
EXPAT_INCLUDE=%{_includedir} \
|
||||
EXPAT_LIBPATH=%{_libdir} \
|
||||
./b2 \
|
||||
-a \
|
||||
--prefix=%{_prefix} \
|
||||
--layout=system -d2 \
|
||||
python=%{python310_version} \
|
||||
runtime-link=shared \
|
||||
link=shared,static \
|
||||
toolset=gcc \
|
||||
variant=release \
|
||||
threading=multi \
|
||||
debug-symbols=on \
|
||||
stage \
|
||||
%ifarch x86_64
|
||||
cflags="-fPIC"
|
||||
%ifarch %{ix86}
|
||||
boost.stacktrace.from_exception=off \
|
||||
%endif
|
||||
stage
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
cd boost_python310
|
||||
EXPAT_INCLUDE=%{_includedir} \
|
||||
EXPAT_LIBPATH=%{_libdir} \
|
||||
./b2 \
|
||||
--prefix=%{buildroot}%{_prefix} \
|
||||
--libdir=%{buildroot}%{_libdir} \
|
||||
--execprefix=%{buildroot}%{_libexecdir} \
|
||||
--includedir=%{buildroot}%{_includedir} \
|
||||
--layout=system -d2 \
|
||||
python=%{python310_version} \
|
||||
runtime-link=shared \
|
||||
link=shared,static \
|
||||
toolset=gcc \
|
||||
variant=release \
|
||||
threading=multi \
|
||||
debug-symbols=on \
|
||||
install
|
||||
|
||||
cd ..
|
||||
|
||||
EXPAT_INCLUDE=%{_includedir} \
|
||||
EXPAT_LIBPATH=%{_libdir} \
|
||||
./b2 \
|
||||
@ -189,11 +123,16 @@ EXPAT_LIBPATH=%{_libdir} \
|
||||
variant=release \
|
||||
threading=multi \
|
||||
debug-symbols=on \
|
||||
%ifarch x86_64
|
||||
cflags="-fPIC" \
|
||||
%endif
|
||||
%ifarch %{ix86}
|
||||
boost.stacktrace.from_exception=off \
|
||||
%endif
|
||||
install
|
||||
|
||||
# https://github.com/boostorg/python/issues/203#issuecomment-391477685
|
||||
for _lib in python mpi_python numpy; do
|
||||
ln -srL %{buildroot}%{_libdir}/libboost_${_lib}{27,}.so
|
||||
ln -srL %{buildroot}%{_libdir}/libboost_${_lib}3{11,}.so
|
||||
done
|
||||
|
||||
@ -230,14 +169,13 @@ done
|
||||
%{_libdir}/libboost_mpi_python311.so.*
|
||||
%{_libdir}/libboost_numpy311.so.*
|
||||
|
||||
%files -n python-boost-py310
|
||||
%defattr(-,root,root)
|
||||
#%{_libdir}/boost-python3.10/mpi.so
|
||||
%{_libdir}/libboost_python310.so.*
|
||||
#%{_libdir}/libboost_mpi_python310.so.*
|
||||
%{_libdir}/libboost_numpy310.so.*
|
||||
|
||||
%changelog
|
||||
* Sat Apr 20 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.85.0-2mamba
|
||||
- remove and obsolete python-boost-py310
|
||||
|
||||
* Wed Apr 17 2024 Automatic Build System <autodist@openmamba.org> 1.85.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Dec 15 2023 Automatic Build System <autodist@mambasoft.it> 1.84.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user