175 lines
5.8 KiB
RPMSpec
175 lines
5.8 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f 1-2)
|
|
|
|
Name: libbonobo
|
|
Version: 2.32.1
|
|
Release: 2mamba
|
|
Summary: Bonobo is a component and compound document system for GNOME
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.gnome.org
|
|
# bugfixes: http://ftp.acc.umu.se/pub/GNOME/sources/%{pkgname}
|
|
Source: http://ftp.gnome.org/pub/GNOME/sources/libbonobo/%{majver}/libbonobo-%{version}.tar.bz2
|
|
License: GPL
|
|
BuildRequires: intltool
|
|
BuildRequires: perl-XML-Parser
|
|
BuildRequires: gettext-devel
|
|
BuildRequires: libpopt-devel
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: gtk-doc
|
|
BuildRequires: libdbus-devel
|
|
BuildRequires: libdbus-glib-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libselinux-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libz-devel
|
|
BuildRequires: ORBit2-devel
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Bonobo is a set of language and system independant CORBA interfaces for creating reusable components, controls and creating compound documents.
|
|
The Bonobo distribution includes a Gtk+ based implementation of the Bonobo interfaces, enabling developers to create reusable components and applications that can be used to form more complex documents.
|
|
|
|
%package devel
|
|
Summary: Devel package for libbonobo
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
Bonobo is a set of language and system independant CORBA interfaces for creating reusable components, controls and creating compound documents.
|
|
The Bonobo distribution includes a Gtk+ based implementation of the Bonobo interfaces, enabling developers to create reusable components and applications that can be used to form more complex documents.
|
|
This package contains static libraries and header files needed for development.
|
|
|
|
%package tools
|
|
Summary: Tools provided with libbonobo
|
|
Group: System/Tools
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description tools
|
|
Bonobo is a set of language and system independant CORBA interfaces for creating reusable components, controls and creating compound documents.
|
|
The Bonobo distribution includes a Gtk+ based implementation of the Bonobo interfaces, enabling developers to create reusable components and applications that can be used to form more complex documents.
|
|
This package contains the tools provided with libbonobo.
|
|
|
|
%package apidocs
|
|
Summary: %{pkgname} API documentation
|
|
Group: Documentation
|
|
Requires: gtk-doc
|
|
|
|
%description apidocs
|
|
%{pkgname} API documentation.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
|
sed -i "s#-DG_DISABLE_DEPRECATED##" activation-server/Makefile.in
|
|
|
|
%build
|
|
%configure --libexecdir=%{_sbindir}
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%find_lang libbonobo-2.0
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_libdir}/orbit-2.0/*
|
|
%{_libdir}/libbonobo-2.so.*
|
|
%{_libdir}/libbonobo-activation.so.*
|
|
%dir %{_libdir}/bonobo
|
|
%{_libdir}/bonobo/*
|
|
%dir %{_libdir}/bonobo-2.0
|
|
%{_libdir}/bonobo-2.0/*
|
|
|
|
%files tools -f libbonobo-2.0.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/*
|
|
%{_sbindir}/*
|
|
%dir %{_sysconfdir}/bonobo-activation
|
|
%{_sysconfdir}/bonobo-activation/*
|
|
%dir %{_datadir}/idl/bonobo-activation-2.0
|
|
%{_datadir}/idl/bonobo-activation-2.0/*
|
|
%dir %{_datadir}/idl/bonobo-2.0
|
|
%{_datadir}/idl/bonobo-2.0/*
|
|
%{_mandir}/man1/*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/libbonobo-2.0
|
|
%{_includedir}/libbonobo-2.0/*
|
|
%dir %{_includedir}/bonobo-activation-2.0
|
|
%{_includedir}/bonobo-activation-2.0/*
|
|
%{_libdir}/pkgconfig/*
|
|
%{_libdir}/libbonobo-2.a
|
|
%{_libdir}/libbonobo-2.la
|
|
%{_libdir}/libbonobo-2.so
|
|
%{_libdir}/libbonobo-activation.a
|
|
%{_libdir}/libbonobo-activation.la
|
|
%{_libdir}/libbonobo-activation.so
|
|
|
|
%files apidocs
|
|
%defattr(-,root,root)
|
|
%{_datadir}/gtk-doc/html/libbonobo/
|
|
%{_datadir}/gtk-doc/html/bonobo-activation/
|
|
|
|
%changelog
|
|
* Thu Dec 03 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-2mamba
|
|
- rebuilt with debug package, aarch64 build fix, -tools subpackage, disable gtkdoc
|
|
|
|
* Mon Apr 04 2011 Automatic Build System <autodist@mambasoft.it> 2.32.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Oct 02 2010 Automatic Build System <autodist@mambasoft.it> 2.32.0-1mamba
|
|
- automatic update to 2.32.0 by autodist
|
|
|
|
* Tue Jun 29 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.3-2mamba
|
|
- rebuilt to add pkgconfig provides
|
|
|
|
* Sat May 29 2010 Automatic Build System <autodist@mambasoft.it> 2.24.3-1mamba
|
|
- automatic update to 2.24.3 by autodist
|
|
|
|
* Tue Sep 29 2009 Automatic Build System <autodist@mambasoft.it> 2.24.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Mar 13 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Oct 03 2008 gil <puntogil@libero.it> 2.24.0-1mamba
|
|
- update to 2.24.0
|
|
|
|
* Fri Apr 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.22.0-1mamba
|
|
- update to 2.22.0
|
|
|
|
* Fri Jan 05 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.16.0-2qilnx
|
|
- new subpackage apidocs with API documentation
|
|
|
|
* Thu Jan 04 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.16.0-1qilnx
|
|
- update to version 2.16.0 by autospec
|
|
|
|
* Tue Aug 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-1qilnx
|
|
- update to version 2.10.0 by autospec
|
|
|
|
* Sun Jun 28 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.2-1qilnx
|
|
- new version build
|
|
|
|
* Tue Dec 30 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1qilnx
|
|
- new version rebuild
|
|
|
|
* Thu Jul 24 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.3.5-1qilnx
|
|
- first build for libbonobo
|