specfile cleanups
fixed build error: 'EOF' was not declared in this scope [release 1.4-3mamba;Sun Mar 21 2010]
This commit is contained in:
parent
282df44e2b
commit
aefb2d7a5a
@ -1,2 +1,6 @@
|
|||||||
# libbinio
|
# libbinio
|
||||||
|
|
||||||
|
The binary I/O stream class library presents a platform-independent way to access binary data streams in C++.
|
||||||
|
The library is hardware independent in the form that it transparently converts between the different forms of machine-internal binary data representation.
|
||||||
|
It further employs no special I/O protocol and can be used on arbitrary binary data sources.
|
||||||
|
|
||||||
|
10
libbinio-1.4-include.patch
Normal file
10
libbinio-1.4-include.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- libbinio-1.4/src/binwrap.cpp 2003-03-08 17:02:34.000000000 +0100
|
||||||
|
+++ libbinio-1.4/src/binwrap.cpp.fix 2010-03-21 22:25:44.000000000 +0100
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include "binwrap.h"
|
||||||
|
+#include <stdio.h>
|
||||||
|
|
||||||
|
#if BINIO_ENABLE_IOSTREAM
|
||||||
|
|
11
libbinio-1.4-info.patch
Normal file
11
libbinio-1.4-info.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libbinio-1.4/doc/libbinio.texi 2004-08-18 21:49:11.000000000 +0200
|
||||||
|
+++ libbinio-1.4/doc/libbinio.texi 2005-09-27 14:43:23.000000000 +0200
|
||||||
|
@@ -27,7 +27,7 @@
|
||||||
|
|
||||||
|
@dircategory Software Libraries
|
||||||
|
@direntry
|
||||||
|
-* libbinio: (libbinio) Binary I/O stream class library @value{VERSION}
|
||||||
|
+* libbinio: (libbinio). Binary I/O stream class library @value{VERSION}
|
||||||
|
@end direntry
|
||||||
|
|
||||||
|
@titlepage
|
91
libbinio.spec
Normal file
91
libbinio.spec
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
Name: libbinio
|
||||||
|
Version: 1.4
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: A platform-independent way to access binary data streams in C++
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Stefano Cotta Ramusino <stefano.cotta@qilinux.it>
|
||||||
|
URL: http://libbinio.sourceforge.net/
|
||||||
|
Source: http://switch.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-1.4-info.patch
|
||||||
|
Patch1: %{name}-1.4-include.patch
|
||||||
|
License: LGPL
|
||||||
|
PreReq: %{__install_info}
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The binary I/O stream class library presents a platform-independent way to access binary data streams in C++.
|
||||||
|
The library is hardware independent in the form that it transparently converts between the different forms of machine-internal binary data representation.
|
||||||
|
It further employs no special I/O protocol and can be used on arbitrary binary data sources.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The binary I/O stream class library presents a platform-independent way to access binary data streams in C++.
|
||||||
|
The library is hardware independent in the form that it transparently converts between the different forms of machine-internal binary data representation.
|
||||||
|
It further employs no special I/O protocol and can be used on arbitrary binary data sources.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
%install_info %{name}.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%uninstall_info %{name}.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/%{name}.so.*
|
||||||
|
%{_infodir}/%{name}.*
|
||||||
|
%doc AUTHORS COPYING ChangeLog NEWS README TODO
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/%{name}.a
|
||||||
|
%{_libdir}/%{name}.la
|
||||||
|
%{_libdir}/%{name}.so
|
||||||
|
%{_libdir}/pkgconfig/%{name}.pc
|
||||||
|
%{_includedir}/%{name}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Mar 21 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.4-3mamba
|
||||||
|
- specfile cleanups
|
||||||
|
- fixed build error: 'EOF' was not declared in this scope
|
||||||
|
|
||||||
|
* Wed Oct 15 2008 Tiziana Ferro <tiziana.ferro@email.it> 1.4-2mamba
|
||||||
|
- buildrequirements list added
|
||||||
|
- description formatted
|
||||||
|
|
||||||
|
* Fri Jan 20 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.4-1qilnx
|
||||||
|
- update to version 1.4 by autospec
|
||||||
|
- added info file patch
|
||||||
|
|
||||||
|
* Thu Aug 18 2005 Stefano Cotta Ramusino <whitone@gmail.com> 1.3-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user