update to 2.0.0.1 [release 2.0.0.1-1mamba;Wed Dec 04 2024]
This commit is contained in:
parent
a2bc15b13e
commit
be59db6733
@ -1,44 +0,0 @@
|
|||||||
Description: use BUFSIZ as buffer size
|
|
||||||
Author: Jakub Wilk <jwilk@debian.org>
|
|
||||||
Bug: http://sourceforge.net/tracker/?func=detail&atid=785907&aid=3591336&group_id=152942
|
|
||||||
Forwarded: no
|
|
||||||
Last-Update: 2012-11-30
|
|
||||||
|
|
||||||
--- a/include/b64/decode.h
|
|
||||||
+++ b/include/b64/decode.h
|
|
||||||
@@ -8,6 +8,7 @@
|
|
||||||
#ifndef BASE64_DECODE_H
|
|
||||||
#define BASE64_DECODE_H
|
|
||||||
|
|
||||||
+#include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
namespace base64
|
|
||||||
@@ -22,7 +23,7 @@
|
|
||||||
base64_decodestate _state;
|
|
||||||
int _buffersize;
|
|
||||||
|
|
||||||
- decoder(int buffersize_in = BUFFERSIZE)
|
|
||||||
+ decoder(int buffersize_in = BUFSIZ)
|
|
||||||
: _buffersize(buffersize_in)
|
|
||||||
{}
|
|
||||||
|
|
||||||
--- a/include/b64/encode.h
|
|
||||||
+++ b/include/b64/encode.h
|
|
||||||
@@ -8,6 +8,7 @@
|
|
||||||
#ifndef BASE64_ENCODE_H
|
|
||||||
#define BASE64_ENCODE_H
|
|
||||||
|
|
||||||
+#include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
namespace base64
|
|
||||||
@@ -22,7 +23,7 @@
|
|
||||||
base64_encodestate _state;
|
|
||||||
int _buffersize;
|
|
||||||
|
|
||||||
- encoder(int buffersize_in = BUFFERSIZE)
|
|
||||||
+ encoder(int buffersize_in = BUFSIZ)
|
|
||||||
: _buffersize(buffersize_in)
|
|
||||||
{}
|
|
||||||
|
|
16
libb64.spec
16
libb64.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libb64
|
Name: libb64
|
||||||
Version: 1.2
|
Version: 2.0.0.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A library of ANSI C routines for fast encoding/decoding data into and from a base64-encoded format
|
Summary: A library of ANSI C routines for fast encoding/decoding data into and from a base64-encoded format
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -7,8 +7,7 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://libb64.sourceforge.net/
|
URL: https://libb64.sourceforge.net/
|
||||||
Source: https://sourceforge.net/projects/libb64/files/libb64/libb64/libb64-%{version}.src.zip
|
Source: https://github.com/libb64/libb64.git/v%{version}/libb64-%{version}.tar.bz2
|
||||||
Patch0: libb64-1.2-bufsiz-as-buffer-size.patch
|
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -29,7 +28,6 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 0 -p1 -b .bufsiz-as-buffer-size
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd src
|
cd src
|
||||||
@ -49,21 +47,21 @@ cp -r include %{buildroot}%{_prefix}
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libb64.so.*
|
%{_libdir}/libb64.so.*
|
||||||
%doc AUTHORS LICENSE
|
%doc AUTHORS.md LICENSE.md
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/b64
|
%dir %{_includedir}/b64
|
||||||
%{_includedir}/b64/*
|
%{_includedir}/b64/*
|
||||||
%{_libdir}/libb64.so
|
%{_libdir}/libb64.so
|
||||||
%doc README
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0.1-1mamba
|
||||||
|
- update to 2.0.0.1
|
||||||
|
|
||||||
* Sun Aug 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
|
* Sun Aug 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
|
||||||
- package created using the webbuild interface
|
- package created using the webbuild interface
|
||||||
|
Loading…
Reference in New Issue
Block a user