package created using the webbuild interface [release 1.2-1mamba;Sun Aug 04 2024]
This commit is contained in:
parent
4673b03632
commit
a2bc15b13e
@ -1,2 +1,4 @@
|
||||
# libb64
|
||||
|
||||
libb64 is a library of ANSI C routines for fast encoding/decoding data into and from a base64-encoded format. C++ wrappers are included, as well as the source code for standalone encoding and decoding executables.
|
||||
|
||||
|
44
libb64-1.2-bufsiz-as-buffer-size.patch
Normal file
44
libb64-1.2-bufsiz-as-buffer-size.patch
Normal file
@ -0,0 +1,44 @@
|
||||
Description: use BUFSIZ as buffer size
|
||||
Author: Jakub Wilk <jwilk@debian.org>
|
||||
Bug: http://sourceforge.net/tracker/?func=detail&atid=785907&aid=3591336&group_id=152942
|
||||
Forwarded: no
|
||||
Last-Update: 2012-11-30
|
||||
|
||||
--- a/include/b64/decode.h
|
||||
+++ b/include/b64/decode.h
|
||||
@@ -8,6 +8,7 @@
|
||||
#ifndef BASE64_DECODE_H
|
||||
#define BASE64_DECODE_H
|
||||
|
||||
+#include <cstdio>
|
||||
#include <iostream>
|
||||
|
||||
namespace base64
|
||||
@@ -22,7 +23,7 @@
|
||||
base64_decodestate _state;
|
||||
int _buffersize;
|
||||
|
||||
- decoder(int buffersize_in = BUFFERSIZE)
|
||||
+ decoder(int buffersize_in = BUFSIZ)
|
||||
: _buffersize(buffersize_in)
|
||||
{}
|
||||
|
||||
--- a/include/b64/encode.h
|
||||
+++ b/include/b64/encode.h
|
||||
@@ -8,6 +8,7 @@
|
||||
#ifndef BASE64_ENCODE_H
|
||||
#define BASE64_ENCODE_H
|
||||
|
||||
+#include <cstdio>
|
||||
#include <iostream>
|
||||
|
||||
namespace base64
|
||||
@@ -22,7 +23,7 @@
|
||||
base64_encodestate _state;
|
||||
int _buffersize;
|
||||
|
||||
- encoder(int buffersize_in = BUFFERSIZE)
|
||||
+ encoder(int buffersize_in = BUFSIZ)
|
||||
: _buffersize(buffersize_in)
|
||||
{}
|
||||
|
69
libb64.spec
Normal file
69
libb64.spec
Normal file
@ -0,0 +1,69 @@
|
||||
Name: libb64
|
||||
Version: 1.2
|
||||
Release: 1mamba
|
||||
Summary: A library of ANSI C routines for fast encoding/decoding data into and from a base64-encoded format
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://libb64.sourceforge.net/
|
||||
Source: https://sourceforge.net/projects/libb64/files/libb64/libb64/libb64-%{version}.src.zip
|
||||
Patch0: libb64-1.2-bufsiz-as-buffer-size.patch
|
||||
License: Public Domain
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
libb64 is a library of ANSI C routines for fast encoding/decoding data into and from a base64-encoded format. C++ wrappers are included, as well as the source code for standalone encoding and decoding executables.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .bufsiz-as-buffer-size
|
||||
|
||||
%build
|
||||
cd src
|
||||
export CFLAGS="%{optflags} -fPIC"
|
||||
%make
|
||||
|
||||
export CFLAGS="${CFLAGS} -shared -Wl,-soname,libb64.so.0"
|
||||
gcc ${LDFLAGS} ${CFLAGS} *.o -o libb64.so.0
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
install -D -m0755 src/libb64.so.0 %{buildroot}%{_libdir}/libb64.so.0
|
||||
ln -sf libb64.so.0 %{buildroot}%{_libdir}/libb64.so
|
||||
|
||||
cp -r include %{buildroot}%{_prefix}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libb64.so.*
|
||||
%doc AUTHORS LICENSE
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/b64
|
||||
%{_includedir}/b64/*
|
||||
%{_libdir}/libb64.so
|
||||
%doc README
|
||||
|
||||
%changelog
|
||||
* Sun Aug 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user