automatic version update by autodist [release 0.4.2-1mamba;Thu Jun 13 2013]
This commit is contained in:
parent
fb4d5bc2bc
commit
27f62aa88b
@ -1,2 +1,5 @@
|
|||||||
# libattica
|
# libattica
|
||||||
|
|
||||||
|
Attica is a Qt library that implements the Open Collaboration Services API version 1.4.
|
||||||
|
It grants easy access to the services such as querying information about persons and contents.
|
||||||
|
|
||||||
|
30
libattica-0.2.0-qt_include_prefix.patch
Normal file
30
libattica-0.2.0-qt_include_prefix.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -Nru attica-0.2.0.orig//lib/cmake/libattica.pc.cmake attica-0.2.0/lib/cmake/libattica.pc.cmake
|
||||||
|
--- attica-0.2.0.orig//lib/cmake/libattica.pc.cmake 2010-10-15 17:33:39.000000000 +0200
|
||||||
|
+++ attica-0.2.0/lib/cmake/libattica.pc.cmake 2011-03-11 16:37:14.395893070 +0100
|
||||||
|
@@ -1,12 +1,12 @@
|
||||||
|
prefix=${CMAKE_INSTALL_PREFIX}
|
||||||
|
exec_prefix=${CMAKE_INSTALL_PREFIX}/bin
|
||||||
|
libdir=${LIB_DESTINATION}
|
||||||
|
-includedir=${CMAKE_INSTALL_PREFIX}/include
|
||||||
|
+includedir=${CMAKE_INSTALL_PREFIX}/include/qt4
|
||||||
|
|
||||||
|
Name: libattica
|
||||||
|
Description: Qt library to access Open Collaboration Services
|
||||||
|
#Requires:
|
||||||
|
Version: ${CMAKE_LIBATTICA_VERSION_MAJOR}.${CMAKE_LIBATTICA_VERSION_MINOR}.${CMAKE_LIBATTICA_VERSION_PATCH}
|
||||||
|
Libs: -L${LIB_DESTINATION} -lattica
|
||||||
|
-Cflags: -I${CMAKE_INSTALL_PREFIX}/include
|
||||||
|
+Cflags: -I${CMAKE_INSTALL_PREFIX}/include/qt4
|
||||||
|
|
||||||
|
diff -Nru attica-0.2.0.orig//lib/CMakeLists.txt attica-0.2.0/lib/CMakeLists.txt
|
||||||
|
--- attica-0.2.0.orig//lib/CMakeLists.txt 2010-10-15 17:33:39.000000000 +0200
|
||||||
|
+++ attica-0.2.0/lib/CMakeLists.txt 2011-03-11 16:36:43.186817819 +0100
|
||||||
|
@@ -118,7 +118,7 @@
|
||||||
|
providermanager.h
|
||||||
|
provider.h
|
||||||
|
${CMAKE_CURRENT_BINARY_DIR}/version.h
|
||||||
|
- DESTINATION include/attica COMPONENT Devel
|
||||||
|
+ DESTINATION include/qt4/attica COMPONENT Devel
|
||||||
|
)
|
||||||
|
|
||||||
|
# Install package config file
|
95
libattica.spec
Normal file
95
libattica.spec
Normal file
@ -0,0 +1,95 @@
|
|||||||
|
Name: libattica
|
||||||
|
Version: 0.4.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A Qt library to access Open Collaboration Service providers
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
|
URL: http://www.kde.org
|
||||||
|
Source: http://download.kde.org/stable/attica/attica-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-0.2.0-qt_include_prefix.patch
|
||||||
|
License: LGPL
|
||||||
|
BuildRequires: cmake
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Attica is a Qt library that implements the Open Collaboration Services API version 1.4.
|
||||||
|
It grants easy access to the services such as querying information about persons and contents.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Attica is a Qt library that implements the Open Collaboration Services API version 1.4.
|
||||||
|
It grants easy access to the services such as querying information about persons and contents.
|
||||||
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n attica-%{version}
|
||||||
|
%define _default_patch_fuzz 2
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake -d build \
|
||||||
|
-DQT4_BUILD=1
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libattica.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/qt4/attica
|
||||||
|
%{_includedir}/qt4/attica/*.h
|
||||||
|
%{_libdir}/libattica.so
|
||||||
|
%{_libdir}/pkgconfig/libattica.pc
|
||||||
|
%doc ChangeLog README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jun 13 2013 Automatic Build System <autodist@mambasoft.it> 0.4.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Aug 20 2012 Automatic Build System <autodist@mambasoft.it> 0.4.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.4.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Nov 21 2011 Automatic Build System <autodist@mambasoft.it> 0.2.9-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Mar 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.0-2mamba
|
||||||
|
- install headers under /usr/include/qt4 to fix kdebindings 4.6.1 build
|
||||||
|
|
||||||
|
* Fri Oct 29 2010 Automatic Build System <autodist@mambasoft.it> 0.2.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 05 2010 Automatic Build System <autodist@mambasoft.it> 0.1.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Jan 17 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.1.2-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user