libatlas/libatlas.spec

146 lines
4.5 KiB
RPMSpec

%define major %(echo %version | cut -d. -f 1)
%define lapackver 3.9.0
Name: libatlas
Version: 3.10.3
Release: 1mamba
Summary: ATLAS - Automatically Tuned Linear Algebra Software
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://math-atlas.sourceforge.net/
Source0: http://downloads.sourceforge.net/project/math-atlas/Stable/%{version}/atlas%{version}.tar.bz2
Source1: ATLAS-README
Source5: atlas-Makefile-x86
Source6: atlas-Makefile
Source7: https://github.com/Reference-LAPACK/lapack.git/v%{lapackver}/lapack-%{version}.tar.bz2
Patch0: libatlas-3.8.4-shared.patch
Patch1: libatlas-3.8.4-fix-melf-link-flags.patch
# ARM patch diffed from:
# http://www.vesperix.com/arm/atlas-arm/source/atlas-%{version}-arm.tar.gz
Patch2: atlas-3.8.4-arm.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: gcc-fortran
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
BuildRequires: libblas-devel >= 3.4.2-3mamba
BuildRequires: liblapack-devel >= 3.4.2-5mamba
BuildRequires: libxblas-devel
BuildRequires: libgomp-devel
%description
The ATLAS (Automatically Tuned Linear Algebra Software) project is an ongoing research effort focusing on applying empirical techniques in order to provide portable performance. At present, it provides C and Fortran77 interfaces to a portably efficient BLAS implementation, as well as a few routines from LAPACK.
%package devel
Group: Development/Libraries
Summary: Development libraries for ATLAS
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: chkconfig
%description devel
ATLAS - Automatically Tuned Linear Algebra Software.
This package contains the libraries and headers for development with ATLAS.
%package doc
Summary: Documentation for %{name}
Group: Documentation
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description doc
ATLAS - Automatically Tuned Linear Algebra Software.
This package contains the documentation for %{name}.
#% debug_package
%prep
#% setup -q -c -a0
%setup -q -c -D -T
:<< __EOF
mkdir -p ATLAS/build
cp %{SOURCE7} ATLAS/build
%build
#:<< _EOF
cd ATLAS/build
../configure \
%ifarch %{ix86}
-b 32 -A x86x87 -V -i \
%endif
%ifarch arm
-b 32 -A ARMa7 \
%endif
--prefix=%{_prefix} \
--shared \
--with-netlib-lapack-tarfile="lapack-%{version}.tar.bz2"
make build
cd lib
%ifarch %{ix86}
cp %{SOURCE5} Makefile
%else
cp %{SOURCE6} Makefile
%endif
make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
cd ATLAS/build
install -d -m0755 %{buildroot}%{_libdir}/atlas/
%make install DESTDIR=%{buildroot}%{_prefix} LIBINSTdir=%{buildroot}%{_libdir}/atlas/
cp -d lib/*.so %{buildroot}%{_libdir}/atlas/
install -m755 lib/liblapack.so.3.6.1 %{buildroot}%{_libdir}/atlas/liblapack.so.%{lapackver}
install -m755 lib/libptlapack.so.3.6.1 %{buildroot}%{_libdir}/atlas/libptlapack.so.%{lapackver}
ln -s liblapack.so.%{lapackver} %{buildroot}%{_libdir}/atlas/liblapack.so.3
ln -s liblapack.so.3 %{buildroot}%{_libdir}/atlas/liblapack.so
ln -s libblas.so %{buildroot}%{_libdir}/atlas/libblas.so.3
ln -s libcblas.so %{buildroot}%{_libdir}/atlas/libcblas.so.3
install -d -m0755 %{buildroot}%{_sysconfdir}/ld.so.conf.d
echo "%{_libdir}/atlas" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/atlas.conf
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_sysconfdir}/ld.so.conf.d/atlas.conf
%dir %{_libdir}/atlas
%{_libdir}/atlas/*.so*
#%doc ATLAS/*README
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%dir %{_includedir}/atlas
%{_includedir}/atlas/*.h
%{_libdir}/atlas/*.a
%files doc
%defattr(-,root,root)
%doc ATLAS/doc
%changelog
* Wed Feb 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10.3-1mamba
- update to 3.10.3
* Mon Aug 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.4-3mamba
- rebuilt with liblapack-3.4.2-5mamba implementing extended precision routines (xblas)
* Thu Aug 22 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.4-2mamba
- rebuild with liblapack-3.4.2-3mamba providing static library
* Wed Aug 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.4-1mamba
- update to 3.8.4
* Wed Jan 05 2011 gil <puntogil@libero.it> 3.8.3-2mamba
- rebuilt devel
* Sat May 09 2009 gil <puntogil@libero.it> 3.8.3-1mamba
- update to 3.8.3
* Sat Oct 04 2008 gil <puntogil@libero.it> 3.8.2-1mamba
- package created by autospec