automatic rebuild by autodist [release 0.3-2mamba;Fri Jul 12 2013]
This commit is contained in:
parent
694a772d5a
commit
c87efa023f
@ -1,2 +1,4 @@
|
|||||||
# libanimorph
|
# libanimorph
|
||||||
|
|
||||||
|
A C++ morphing engine used by makehuman.
|
||||||
|
|
||||||
|
52
libanimorph-0.3-gcc-4.7.patch
Normal file
52
libanimorph-0.3-gcc-4.7.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
diff -r -u animorph-0.3/include/animorph/BodySettings.h animorph-0.3-patch/include/animorph/BodySettings.h
|
||||||
|
--- animorph-0.3/include/animorph/BodySettings.h 2007-12-03 06:30:40.000000000 +0800
|
||||||
|
+++ animorph-0.3-patch/include/animorph/BodySettings.h 2008-07-27 01:04:53.000000000 +0800
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
#include <fstream>
|
||||||
|
#include <map>
|
||||||
|
#include <vector>
|
||||||
|
+#include <cstring>
|
||||||
|
#include "FileReader.h"
|
||||||
|
#include "FileWriter.h"
|
||||||
|
|
||||||
|
diff -r -u animorph-0.3/include/animorph/FaceGroup.h animorph-0.3-patch/include/animorph/FaceGroup.h
|
||||||
|
--- animorph-0.3/include/animorph/FaceGroup.h 2007-12-03 06:30:40.000000000 +0800
|
||||||
|
+++ animorph-0.3-patch/include/animorph/FaceGroup.h 2008-07-27 01:08:05.000000000 +0800
|
||||||
|
@@ -29,6 +29,7 @@
|
||||||
|
|
||||||
|
#include <map>
|
||||||
|
#include <ios>
|
||||||
|
+#include <cstring>
|
||||||
|
#include "Face.h"
|
||||||
|
#include "FaceVector.h"
|
||||||
|
#include "FileWriter.h"
|
||||||
|
diff -r -u animorph-0.3/include/animorph/Hotspot.h animorph-0.3-patch/include/animorph/Hotspot.h
|
||||||
|
--- animorph-0.3/include/animorph/Hotspot.h 2007-11-25 17:34:57.000000000 +0800
|
||||||
|
+++ animorph-0.3-patch/include/animorph/Hotspot.h 2008-07-27 01:07:17.000000000 +0800
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
#include <vector>
|
||||||
|
#include <iostream>
|
||||||
|
#include <fstream>
|
||||||
|
+#include <cstring>
|
||||||
|
#include "FileReader.h"
|
||||||
|
|
||||||
|
namespace Animorph {
|
||||||
|
diff -r -u animorph-0.3/include/animorph/util.h animorph-0.3-patch/include/animorph/util.h
|
||||||
|
--- animorph-0.3/include/animorph/util.h 2007-11-25 17:34:57.000000000 +0800
|
||||||
|
+++ animorph-0.3-patch/include/animorph/util.h 2008-07-27 01:05:25.000000000 +0800
|
||||||
|
@@ -37,6 +37,7 @@
|
||||||
|
#include <iomanip>
|
||||||
|
#include <vector>
|
||||||
|
#include <iostream>
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include "Vector3.h"
|
||||||
|
#include "Vertex.h"
|
||||||
|
#include "VertexVector.h"--- animorph-0.3.orig/src/OgreXMLExporter.cpp 2007-11-25 10:34:58.000000000 +0100
|
||||||
|
+++ animorph-0.3/src/OgreXMLExporter.cpp 2013-07-12 12:10:17.524423652 +0200
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
#include "../include/animorph/OgreXMLExporter.h"
|
||||||
|
#include "../include/animorph/xmlParser.h"
|
||||||
|
+#include <stdint.h>
|
||||||
|
using namespace std;
|
||||||
|
using namespace Animorph;
|
||||||
|
|
66
libanimorph.spec
Normal file
66
libanimorph.spec
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
Name: libanimorph
|
||||||
|
Version: 0.3
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A C++ morphing engine used by makehuman
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.dedalo-3d.com
|
||||||
|
Source: http://downloads.sourceforge.net/sourceforge/makehuman/animorph-%{version}.tar.gz
|
||||||
|
Patch1: libanimorph-0.3-gcc-4.7.patch
|
||||||
|
License: LGPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A C++ morphing engine used by makehuman.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A C++ morphing engine used by makehuman.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n animorph-%{version}
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
rm -rf %{buildroot}%{_prefix}/doc
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libanimorph.so.*
|
||||||
|
%doc AUTHORS COPYING TODO
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libanimorph.a
|
||||||
|
%{_libdir}/libanimorph.la
|
||||||
|
%{_libdir}/libanimorph.so
|
||||||
|
%{_includedir}/animorph/*.h
|
||||||
|
%dir %{_includedir}/animorph
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jul 12 2013 Automatic Build System <autodist@mambasoft.it> 0.3-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Oct 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user