automatic version update by autodist [release 1.1.8-1mamba;Sat Jan 12 2019]
This commit is contained in:
parent
58b70a3139
commit
cc5fe4f0d2
18
libalsa-1.1.7-audacity-2.3.0.patch
Normal file
18
libalsa-1.1.7-audacity-2.3.0.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -upr alsa-lib-1.1.7/src/pcm/interval_inline.h alsa-lib-1.1.7/src/pcm/interval_inline.h
|
||||||
|
--- alsa-lib-1.1.7/src/pcm/interval_inline.h 2018-10-16 10:08:35.000000000 +0200
|
||||||
|
+++ alsa-lib-1.1.7/src/pcm/interval_inline.h 2018-10-24 17:33:10.000000000 +0200
|
||||||
|
@@ -51,12 +51,14 @@ INTERVAL_INLINE int snd_interval_single(
|
||||||
|
{
|
||||||
|
assert(!snd_interval_empty(i));
|
||||||
|
return (i->min == i->max ||
|
||||||
|
- (i->min + 1 == i->max && i->openmax));
|
||||||
|
+ (i->min + 1 == i->max && (i->openmin || i->openmax)));
|
||||||
|
}
|
||||||
|
|
||||||
|
INTERVAL_INLINE int snd_interval_value(const snd_interval_t *i)
|
||||||
|
{
|
||||||
|
assert(snd_interval_single(i));
|
||||||
|
+ if (i->openmin && !i->openmax)
|
||||||
|
+ return i->max;
|
||||||
|
return i->min;
|
||||||
|
}
|
14
libalsa.spec
14
libalsa.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libalsa
|
Name: libalsa
|
||||||
Version: 1.1.7
|
Version: 1.1.8
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Library for the Advanced Linux Sound Architecture (ALSA)
|
Summary: Library for the Advanced Linux Sound Architecture (ALSA)
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
@ -14,6 +14,7 @@ Source3: libalsa-ucm-Midas_WM1811.tar.xz
|
|||||||
Patch0: %{name}-1.0.23-thread_safe_locale.patch
|
Patch0: %{name}-1.0.23-thread_safe_locale.patch
|
||||||
Patch1: %{name}-1.0.25-hctl_remove_a_useless_assert.patch
|
Patch1: %{name}-1.0.25-hctl_remove_a_useless_assert.patch
|
||||||
Patch2: libalsa-1.0.27-use-__inline__-for-exported-headers.patch
|
Patch2: libalsa-1.0.27-use-__inline__-for-exported-headers.patch
|
||||||
|
Patch3: libalsa-1.1.7-audacity-2.3.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -87,12 +88,14 @@ Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Library for the Advanced Linux Sound Architecture (ALSA).
|
Library for the Advanced Linux Sound Architecture (ALSA).
|
||||||
This package contains static libraries and header files needed for development.
|
This package contains static libraries and header files needed for development.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n alsa-lib-%{version}
|
%setup -q -n alsa-lib-%{version}
|
||||||
#% patch0 -p1
|
#% patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -184,6 +187,15 @@ cp -a lib32/%{_prefix}/lib %{buildroot}%{_prefix}/
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 12 2019 Automatic Build System <autodist@mambasoft.it> 1.1.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Nov 27 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-3mamba
|
||||||
|
- other upstream patch to try to fix audacity
|
||||||
|
|
||||||
|
* Mon Nov 26 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-2mamba
|
||||||
|
- patch to fix audacity crash (see https://bbs.archlinux.de/viewtopic.php?pid=366712#p366712)
|
||||||
|
|
||||||
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 1.1.7-1mamba
|
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 1.1.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user