automatic rebuild by autodist [release 1.2.1-4mamba;Fri Jul 12 2013]
This commit is contained in:
parent
8a2a7ca154
commit
1854cee65c
@ -1,2 +1,6 @@
|
||||
# libaiksaurus
|
||||
|
||||
AikSaurus is a GPL'd thesaurus library for C++.
|
||||
It returns many results, separated by part-of-speech information.
|
||||
The library itself has no particular GUI, and it can be used with any interface you'd like to create for it.
|
||||
|
||||
|
33
libaiksaurus-1.2.1-gcc43.patch
Normal file
33
libaiksaurus-1.2.1-gcc43.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -ru aiksaurus-1.2.1/base/aiksaurus.t.cpp aiksaurus-1.2.1.patched/base/aiksaurus.t.cpp
|
||||
--- aiksaurus-1.2.1/base/aiksaurus.t.cpp 2003-06-27 03:44:38.000000000 +0200
|
||||
+++ aiksaurus-1.2.1.patched/base/aiksaurus.t.cpp 2009-05-18 18:17:52.000000000 +0200
|
||||
@@ -22,6 +22,7 @@
|
||||
#include "Aiksaurus.h"
|
||||
#include "AsciiCompare.h"
|
||||
#include "config.h"
|
||||
+#include <cstdlib>
|
||||
#include <iostream>
|
||||
#include <string>
|
||||
using namespace std;
|
||||
diff -ru aiksaurus-1.2.1/gtk/src/Display.cpp aiksaurus-1.2.1.patched/gtk/src/Display.cpp
|
||||
--- aiksaurus-1.2.1/gtk/src/Display.cpp 2003-05-28 01:56:54.000000000 +0200
|
||||
+++ aiksaurus-1.2.1.patched/gtk/src/Display.cpp 2009-05-18 18:18:27.000000000 +0200
|
||||
@@ -18,6 +18,7 @@
|
||||
* 02111-1307, USA.
|
||||
*/
|
||||
|
||||
+#include <cstring>
|
||||
#include "Display.h"
|
||||
#include "Meaning.h"
|
||||
#include "DialogMediator.h"
|
||||
diff -ru aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp aiksaurus-1.2.1.patched/gtk/src/gtkAiksaur.t.cpp
|
||||
--- aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp 2002-01-12 03:02:12.000000000 +0100
|
||||
+++ aiksaurus-1.2.1.patched/gtk/src/gtkAiksaur.t.cpp 2009-05-18 18:19:00.000000000 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <gtk/gtk.h>
|
||||
#include <iostream>
|
||||
#include <string>
|
||||
+#include <cstdlib>
|
||||
using namespace std;
|
||||
|
||||
int main(int argc, char** argv)
|
99
libaiksaurus.spec
Normal file
99
libaiksaurus.spec
Normal file
@ -0,0 +1,99 @@
|
||||
Name: libaiksaurus
|
||||
Version: 1.2.1
|
||||
Release: 4mamba
|
||||
Summary: AikSaurus is a GPL'd thesaurus library for C++
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://sourceforge.net/projects/aiksaurus/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/aiksaurus/aiksaurus-%{version}.tar.gz
|
||||
Patch0: %{name}-1.2.1-gcc43.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
AikSaurus is a GPL'd thesaurus library for C++.
|
||||
It returns many results, separated by part-of-speech information.
|
||||
The library itself has no particular GUI, and it can be used with any interface you'd like to create for it.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
AikSaurus is a GPL'd thesaurus library for C++.
|
||||
It returns many results, separated by part-of-speech information.
|
||||
The library itself has no particular GUI, and it can be used with any interface you'd like to create for it.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n aiksaurus-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS COPYING ChangeLog README README.W32
|
||||
%{_bindir}/*
|
||||
%{_libdir}/*.so.*
|
||||
%{_datadir}/aiksaurus/*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/Aiksaurus/*
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Fri Jul 12 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-4mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon May 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-3mamba
|
||||
- specfile updated and rebuilt
|
||||
|
||||
* Fri Jul 07 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.2.1-2qilnx
|
||||
- specfile fixed and updated
|
||||
|
||||
* Tue Aug 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.2.1-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user