remove -static package and *.la *.a files [release 2.2.52-2mamba;Mon Jul 01 2013]
This commit is contained in:
parent
dc4845328e
commit
7b2e7fa3e0
@ -1,2 +1,6 @@
|
||||
# libacl
|
||||
|
||||
This package contains the libacl.so dynamic library which contains
|
||||
the POSIX 1003.1e draft standard 17 functions for manipulating access
|
||||
control lists.
|
||||
|
||||
|
38
libacl-2.2.47-build.patch
Normal file
38
libacl-2.2.47-build.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -Nru acl-2.2.47/include/builddefs.in acl-2.2.47/include-gil/builddefs.in
|
||||
--- acl-2.2.47/include/builddefs.in 2007-09-11 04:00:47.000000000 +0200
|
||||
+++ acl-2.2.47/include-gil/builddefs.in 2008-11-30 04:14:01.000000000 +0100
|
||||
@@ -27,14 +27,14 @@
|
||||
PKG_VERSION = @pkg_version@
|
||||
PKG_PLATFORM = @pkg_platform@
|
||||
PKG_DISTRIBUTION= @pkg_distribution@
|
||||
-PKG_BIN_DIR = @bindir@
|
||||
-PKG_SBIN_DIR = @sbindir@
|
||||
-PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
-PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
-PKG_INC_DIR = @includedir@
|
||||
-PKG_MAN_DIR = @mandir@
|
||||
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||
-PKG_LOCALE_DIR = @datadir@/locale
|
||||
+PKG_BIN_DIR = $(DESTDIR)@bindir@
|
||||
+PKG_SBIN_DIR = $(DESTDIR)@sbindir@
|
||||
+PKG_LIB_DIR = $(DESTDIR)@libdir@@libdirsuffix@
|
||||
+PKG_DEVLIB_DIR = $(DESTDIR)@libexecdir@@libdirsuffix@
|
||||
+PKG_INC_DIR = $(DESTDIR)@includedir@
|
||||
+PKG_MAN_DIR = $(DESTDIR)@mandir@
|
||||
+PKG_DOC_DIR = $(DESTDIR)@datadir@/doc/@pkg_name@
|
||||
+PKG_LOCALE_DIR = $(DESTDIR)@datadir@/locale
|
||||
|
||||
CC = @cc@
|
||||
AWK = @awk@
|
||||
diff -Nru acl-2.2.47/include/buildmacros acl-2.2.47/include-gil/buildmacros
|
||||
--- acl-2.2.47/include/buildmacros 2007-09-11 04:00:47.000000000 +0200
|
||||
+++ acl-2.2.47/include-gil/buildmacros 2008-11-30 04:15:11.000000000 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
27
libacl-2.2.47-exitcode.patch
Normal file
27
libacl-2.2.47-exitcode.patch
Normal file
@ -0,0 +1,27 @@
|
||||
--- acl-2.2.47/setfacl/setfacl.c 2008-02-07 04:39:57.000000000 +0100
|
||||
+++ acl-2.2.47/setfacl/setfacl.c-gil 2008-11-30 04:31:39.000000000 +0100
|
||||
@@ -137,7 +137,7 @@
|
||||
if (error < 0)
|
||||
goto fail;
|
||||
if (error == 0)
|
||||
- return 0;
|
||||
+ return status;
|
||||
|
||||
if (path_p == NULL) {
|
||||
if (filename) {
|
||||
@@ -151,6 +151,7 @@
|
||||
"aborting\n"),
|
||||
progname, backup_line);
|
||||
}
|
||||
+ status = 1;
|
||||
goto getout;
|
||||
}
|
||||
|
||||
@@ -169,6 +170,7 @@
|
||||
fprintf(stderr, _("%s: %s: %s in line %d\n"),
|
||||
progname, xquote(filename), strerror(errno),
|
||||
line);
|
||||
+ status = 1;
|
||||
goto getout;
|
||||
}
|
||||
|
11
libacl-2.2.47-multilib.patch
Normal file
11
libacl-2.2.47-multilib.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- acl-2.2.47/include/buildmacros 2008-11-30 05:06:54.000000000 +0100
|
||||
+++ acl-2.2.47/include/buildmacros-gil 2008-11-30 05:10:42.000000000 +0100
|
||||
@@ -74,8 +74,6 @@
|
||||
../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
|
||||
../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
|
||||
../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
|
||||
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
|
||||
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
|
||||
../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so
|
||||
else
|
||||
INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
|
154
libacl-2.2.47-params.patch
Normal file
154
libacl-2.2.47-params.patch
Normal file
@ -0,0 +1,154 @@
|
||||
--- acl-2.2.47_old/getfacl/getfacl.c 2008-02-07 04:39:57.000000000 +0100
|
||||
+++ acl-2.2.47/getfacl/getfacl.c 2008-07-31 12:23:10.000000000 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
#define POSIXLY_CORRECT_STR "POSIXLY_CORRECT"
|
||||
|
||||
#if !POSIXLY_CORRECT
|
||||
-# define CMD_LINE_OPTIONS "dRLP"
|
||||
+# define CMD_LINE_OPTIONS "aceEsRLPtpndvh"
|
||||
#endif
|
||||
#define POSIXLY_CMD_LINE_OPTIONS "d"
|
||||
|
||||
@@ -555,23 +555,23 @@ void help(void)
|
||||
#if !POSIXLY_CORRECT
|
||||
} else {
|
||||
printf(_(
|
||||
-" --access display the file access control list only\n"
|
||||
+" -a, --access display the file access control list only\n"
|
||||
" -d, --default display the default access control list only\n"
|
||||
-" --omit-header do not display the comment header\n"
|
||||
-" --all-effective print all effective rights\n"
|
||||
-" --no-effective print no effective rights\n"
|
||||
-" --skip-base skip files that only have the base entries\n"
|
||||
+" -c, --omit-header do not display the comment header\n"
|
||||
+" -e, --all-effective print all effective rights\n"
|
||||
+" -E, --no-effective print no effective rights\n"
|
||||
+" -s, --skip-base skip files that only have the base entries\n"
|
||||
" -R, --recursive recurse into subdirectories\n"
|
||||
" -L, --logical logical walk, follow symbolic links\n"
|
||||
" -P, --physical physical walk, do not follow symbolic links\n"
|
||||
-" --tabular use tabular output format\n"
|
||||
-" --numeric print numeric user/group identifiers\n"
|
||||
-" --absolute-names don't strip leading '/' in pathnames\n"));
|
||||
+" -t, --tabular use tabular output format\n"
|
||||
+" -n, --numeric print numeric user/group identifiers\n"
|
||||
+" -p, --absolute-names don't strip leading '/' in pathnames\n"));
|
||||
}
|
||||
#endif
|
||||
printf(_(
|
||||
-" --version print version and exit\n"
|
||||
-" --help this help text\n"));
|
||||
+" -v, --version print version and exit\n"
|
||||
+" -h, --help this help text\n"));
|
||||
}
|
||||
|
||||
int main(int argc, char *argv[])
|
||||
--- acl-2.2.47_old/man/man1/getfacl.1 2008-02-07 04:39:57.000000000 +0100
|
||||
+++ acl-2.2.47/man/man1/getfacl.1 2008-07-31 11:23:45.000000000 +0200
|
||||
@@ -12,10 +12,10 @@ getfacl \- get file access control lists
|
||||
.SH SYNOPSIS
|
||||
|
||||
.B getfacl
|
||||
-[\-dRLPvh] file ...
|
||||
+[\-aceEsRLPrpndvh] file ...
|
||||
|
||||
.B getfacl
|
||||
-[\-dRLPvh] \-
|
||||
+[\-aceEsRLPrpndvh] \-
|
||||
|
||||
.SH DESCRIPTION
|
||||
For each file, getfacl displays the file name, owner, the group,
|
||||
@@ -78,22 +78,22 @@ accessing the file mode.
|
||||
|
||||
.SS OPTIONS
|
||||
.TP 4
|
||||
-.I \-\-access
|
||||
+.I \-a, \-\-access
|
||||
Display the file access control list.
|
||||
.TP
|
||||
.I \-d, \-\-default
|
||||
Display the default access control list.
|
||||
.TP
|
||||
-.I \-\-omit-header
|
||||
+.I \-c, \-\-omit-header
|
||||
Do not display the comment header (the first three lines of each file's output).
|
||||
.TP
|
||||
-.I \-\-all-effective
|
||||
+.I \-e, \-\-all-effective
|
||||
Print all effective rights comments, even if identical to the rights defined by the ACL entry.
|
||||
.TP
|
||||
-.I \-\-no-effective
|
||||
+.I \-E, \-\-no-effective
|
||||
Do not print effective rights comments.
|
||||
.TP
|
||||
-.I \-\-skip-base
|
||||
+.I \-s, \-\-skip-base
|
||||
Skip files that only have the base ACL entries (owner, group, others).
|
||||
.TP
|
||||
.I \-R, \-\-recursive
|
||||
@@ -109,17 +109,20 @@ Physical walk, do not follow symbolic li
|
||||
link arguments.
|
||||
Only effective in combination with \-R.
|
||||
.TP
|
||||
-.I \-\-tabular
|
||||
+.I \-t, \-\-tabular
|
||||
Use an alternative tabular output format. The ACL and the default ACL are displayed side by side. Permissions that are ineffective due to the ACL mask entry are displayed capitalized. The entry tag names for the ACL_USER_OBJ and ACL_GROUP_OBJ entries are also displayed in capital letters, which helps in spotting those entries.
|
||||
.TP
|
||||
-.I \-\-absolute-names
|
||||
+.I \-p, \-\-absolute-names
|
||||
Do not strip leading slash characters (`/'). The default behavior is to
|
||||
strip leading slash characters.
|
||||
.TP
|
||||
-.I \-\-version
|
||||
+.I \-n, \-\-numeric
|
||||
+List numeric user and group IDs
|
||||
+.TP
|
||||
+.I \-v, \-\-version
|
||||
Print the version of getfacl and exit.
|
||||
.TP
|
||||
-.I \-\-help
|
||||
+.I \-h, \-\-help
|
||||
Print help explaining the command line options.
|
||||
.TP
|
||||
.I \-\-
|
||||
--- acl-2.2.47_old/man/man1/setfacl.1 2008-02-07 04:39:57.000000000 +0100
|
||||
+++ acl-2.2.47/man/man1/setfacl.1 2008-07-31 13:53:29.000000000 +0200
|
||||
@@ -115,10 +115,10 @@ This also skips symbolic link arguments.
|
||||
Only effective in combination with \-R.
|
||||
This option cannot be mixed with `\-\-restore'.
|
||||
.TP 4
|
||||
-.I \-\-version
|
||||
+.I \-v, \-\-version
|
||||
Print the version of setfacl and exit.
|
||||
.TP 4
|
||||
-.I \-\-help
|
||||
+.I \-h, \-\-help
|
||||
Print help explaining the command line options.
|
||||
.TP 4
|
||||
.I \-\-
|
||||
--- acl-2.2.47_old/setfacl/setfacl.c 2008-07-31 11:23:18.000000000 +0200
|
||||
+++ acl-2.2.47/setfacl/setfacl.c 2008-07-31 12:23:13.000000000 +0200
|
||||
@@ -42,10 +42,10 @@ extern int do_set(const char *path_p, co
|
||||
|
||||
/* '-' stands for `process non-option arguments in loop' */
|
||||
#if !POSIXLY_CORRECT
|
||||
-# define CMD_LINE_OPTIONS "-:bkndm:M:x:X:RLP"
|
||||
+# define CMD_LINE_OPTIONS "-:bkndvhm:M:x:X:RLP"
|
||||
# define CMD_LINE_SPEC "[-bkndRLP] { -m|-M|-x|-X ... } file ..."
|
||||
#endif
|
||||
-#define POSIXLY_CMD_LINE_OPTIONS "-:bkndm:M:x:X:"
|
||||
+#define POSIXLY_CMD_LINE_OPTIONS "-:bkndvhm:M:x:X:"
|
||||
#define POSIXLY_CMD_LINE_SPEC "[-bknd] {-m|-M|-x|-X ... } file ..."
|
||||
|
||||
struct option long_options[] = {
|
||||
@@ -265,8 +265,8 @@ void help(void)
|
||||
}
|
||||
#endif
|
||||
printf(_(
|
||||
-" --version print version and exit\n"
|
||||
-" --help this help text\n"));
|
||||
+" -v, --version print version and exit\n"
|
||||
+" -h, --help this help text\n"));
|
||||
}
|
||||
|
||||
|
24
libacl-2.2.47-path_max.patch
Normal file
24
libacl-2.2.47-path_max.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- acl-2.2.47/setfacl/parse.c 2007-09-11 04:00:49.000000000 +0200
|
||||
+++ acl-2.2.47/setfacl/parse.c-gil 2008-11-30 04:20:38.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -412,7 +413,12 @@
|
||||
gid_t *gid_p)
|
||||
{
|
||||
int c;
|
||||
- char linebuf[1024];
|
||||
+ /*
|
||||
+ Max PATH_MAX bytes even for UTF-8 path names and additional 9
|
||||
+ bytes for "# file: ".Not a good solution but for now it is the
|
||||
+ best I can do without too much impact on the code. [tw]
|
||||
+ */
|
||||
+ char linebuf[(4*PATH_MAX)+9];
|
||||
char *cp;
|
||||
char *p;
|
||||
int comments_read = 0;
|
11
libacl-2.2.47-segfault.patch
Normal file
11
libacl-2.2.47-segfault.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- acl-2.2.47/setfacl/setfacl.c 2008-02-07 04:39:57.000000000 +0100
|
||||
+++ acl-2.2.47/setfacl/setfacl.c-gil 2008-11-30 04:49:11.000000000 +0100
|
||||
@@ -599,6 +599,8 @@
|
||||
}
|
||||
}
|
||||
while (optind < argc) {
|
||||
+ if(!seq)
|
||||
+ goto synopsis;
|
||||
if (seq_empty(seq))
|
||||
goto synopsis;
|
||||
saw_files = 1;
|
145
libacl.spec
Normal file
145
libacl.spec
Normal file
@ -0,0 +1,145 @@
|
||||
### AUTOUPDATE-OFF: 1
|
||||
Name: libacl
|
||||
Version: 2.2.52
|
||||
Release: 2mamba
|
||||
Summary: Access control list utilities
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://oss.sgi.com/projects/xfs/source.html
|
||||
Source: http://download.savannah.gnu.org/releases/acl/acl-%{version}.src.tar.gz
|
||||
Patch0: libacl-2.2.47-build.patch
|
||||
Patch1: libacl-2.2.47-path_max.patch
|
||||
Patch2: libacl-2.2.47-params.patch
|
||||
Patch3: libacl-2.2.47-exitcode.patch
|
||||
Patch4: libacl-2.2.47-segfault.patch
|
||||
Patch5: libacl-2.2.47-multilib.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libattr-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: libtool
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gawk
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This package contains the libacl.so dynamic library which contains
|
||||
the POSIX 1003.1e draft standard 17 functions for manipulating access
|
||||
control lists.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-static
|
||||
Obsoletes: %{name}-static
|
||||
|
||||
%description devel
|
||||
This package contains libraries and header files needed to develop
|
||||
programs which make use of the access control list programming interface
|
||||
defined in POSIX 1003.1e draft standard 17.
|
||||
|
||||
%package tools
|
||||
Group: Development/Libraries
|
||||
Summary: Tools for %{name}
|
||||
License: GPL
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description tools
|
||||
This package contains the getfacl and setfacl utilities needed for
|
||||
manipulating access control lists.
|
||||
|
||||
%prep
|
||||
%setup -q -n acl-%{version}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
#%patch5 -p1
|
||||
#autoconf
|
||||
|
||||
%build
|
||||
touch .census
|
||||
# acl abuses libexecdir
|
||||
%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
|
||||
%if "%{_host}" != "%{_build}"
|
||||
make LIBTOOL="%{_prefix}/%{_host}/%{_bindir}/libtool --tag=CC" LIBATTR="%{_prefix}/%{_host}/lib/libattr.so"
|
||||
%else
|
||||
make
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install install-lib install-dev \
|
||||
PKG_BIN_DIR=%{buildroot}%{_bindir} \
|
||||
PKG_MAN_DIR=%{buildroot}%{_mandir} \
|
||||
PKG_DOC_DIR=%{buildroot}%{_docdir}/%{name} \
|
||||
PKG_LOCALE_DIR=%{buildroot}%{_datadir}/locale \
|
||||
PKG_INC_DIR=%{buildroot}%{_includedir} \
|
||||
PKG_DEVLIB_DIR=%{buildroot}%{_libdir} \
|
||||
PKG_LIB_DIR=%{buildroot}/%{_lib}
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/libacl.so
|
||||
%if "%{_host}" == "%{_build}"
|
||||
ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
|
||||
%endif
|
||||
chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
|
||||
rm -f %{buildroot}/%{_libdir}/libacl.a
|
||||
rm -f %{buildroot}/%{_libdir}/libacl.la
|
||||
rm -f %{buildroot}/%{_lib}/libacl.a
|
||||
rm -f %{buildroot}/%{_lib}/libacl.la
|
||||
|
||||
%find_lang acl
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
#%{_libdir}/*.so.*
|
||||
/%{_lib}/libacl.so.*
|
||||
%doc README
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/acl
|
||||
%{_includedir}/acl/*.h
|
||||
%{_includedir}/sys/acl.h
|
||||
%if "%{_host}" == "%{_build}"
|
||||
%{_libdir}/libacl.so
|
||||
%endif
|
||||
/%{_lib}/libacl.so
|
||||
%{_mandir}/man3/*.3.gz
|
||||
%dir %{_docdir}/libacl
|
||||
%{_docdir}/libacl/*
|
||||
|
||||
%files tools -f acl.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/chacl
|
||||
%{_bindir}/getfacl
|
||||
%{_bindir}/setfacl
|
||||
%{_mandir}/man1/chacl.1.gz
|
||||
%{_mandir}/man1/getfacl.1.gz
|
||||
%{_mandir}/man1/setfacl.1.gz
|
||||
%{_mandir}/man5/acl.5.gz
|
||||
|
||||
%changelog
|
||||
* Mon Jul 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.52-2mamba
|
||||
- remove -static package and *.la *.a files
|
||||
|
||||
* Mon May 20 2013 Automatic Build System <autodist@mambasoft.it> 2.2.52-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Dec 09 2012 Automatic Build System <autodist@mambasoft.it> 2.2.51-1mamba
|
||||
- update to 2.2.51
|
||||
|
||||
* Sun Nov 30 2008 gil <puntogil@libero.it> 2.2.47-1mamba
|
||||
- package created by autospec
|
Reference in New Issue
Block a user