automatic version update by autodist [release 1.16-1mamba;Sat Mar 01 2014]
This commit is contained in:
parent
93c9c59b63
commit
574782d486
@ -1,2 +1,4 @@
|
|||||||
# libaccounts-glib
|
# libaccounts-glib
|
||||||
|
|
||||||
|
Glib client library for the accounts and SSO (Single Sign-On) framework for Linux and POSIX based platforms.
|
||||||
|
|
||||||
|
11
libaccounts-glib-1.8-gcc-4.8.patch
Normal file
11
libaccounts-glib-1.8-gcc-4.8.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libaccounts-glib-1.8/libaccounts-glib/ag-service.c.orig 2013-04-10 15:00:38.715859036 +0200
|
||||||
|
+++ libaccounts-glib-1.8/libaccounts-glib/ag-service.c 2013-04-10 14:58:27.169209055 +0200
|
||||||
|
@@ -154,7 +154,7 @@
|
||||||
|
while (offset > 0)
|
||||||
|
{
|
||||||
|
if (strncmp (service->file_data + offset, element,
|
||||||
|
- sizeof (element)) == 0)
|
||||||
|
+ strlen (element)) == 0)
|
||||||
|
{
|
||||||
|
service->type_data_offset = offset;
|
||||||
|
break;
|
130
libaccounts-glib.spec
Normal file
130
libaccounts-glib.spec
Normal file
@ -0,0 +1,130 @@
|
|||||||
|
Name: libaccounts-glib
|
||||||
|
Version: 1.16
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Glib client library for the accounts and SSO (Single Sign-On) framework
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://code.google.com/p/accounts-sso/
|
||||||
|
Source: https://accounts-sso.googlecode.com/files/libaccounts-glib-%{version}.tar.gz
|
||||||
|
Patch0: libaccounts-glib-1.8-gcc-4.8.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Glib client library for the accounts and SSO (Single Sign-On) framework for Linux and POSIX based platforms.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
## note: you can add this requirement if .pc files are provided by this package
|
||||||
|
#Requires: pkg-config
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%package tools
|
||||||
|
Group: Applications/Security
|
||||||
|
Summary: Utility applications for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description tools
|
||||||
|
This package contains utility applications for %{name}.
|
||||||
|
|
||||||
|
%package apidocs
|
||||||
|
Group: Documentation
|
||||||
|
Summary: %{name} API documentation
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: gtk-doc
|
||||||
|
|
||||||
|
%description apidocs
|
||||||
|
This package includes the %{name} API documentation.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --enable-gtk-doc
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libaccounts-glib.so.*
|
||||||
|
%{_libdir}/girepository-1.0/Accounts-1.0.typelib
|
||||||
|
%{_datadir}/dbus-1/interfaces/com.google.code.AccountsSSO.Accounts.Manager.xml
|
||||||
|
%{_datadir}/xml/accounts/schema/dtd/accounts-application.dtd
|
||||||
|
%{_datadir}/xml/accounts/schema/dtd/accounts-provider.dtd
|
||||||
|
%{_datadir}/xml/accounts/schema/dtd/accounts-service-type.dtd
|
||||||
|
%{_datadir}/xml/accounts/schema/dtd/accounts-service.dtd
|
||||||
|
%{_datadir}/backup-framework/applications/accounts.conf
|
||||||
|
%{python_sitelib}/gi/overrides/Accounts.py
|
||||||
|
%{python_sitelib}/gi/overrides/Accounts.pyc
|
||||||
|
%{python_sitelib}/gi/overrides/Accounts.pyo
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/libaccounts-glib
|
||||||
|
%{_includedir}/libaccounts-glib/*.h
|
||||||
|
%{_libdir}/libaccounts-glib.la
|
||||||
|
%{_libdir}/libaccounts-glib.so
|
||||||
|
%{_libdir}/pkgconfig/libaccounts-glib.pc
|
||||||
|
%{_datadir}/gir-1.0/Accounts-1.0.gir
|
||||||
|
%dir %{_libdir}/libaccounts-glib
|
||||||
|
%{_libdir}/libaccounts-glib/*
|
||||||
|
%dir %{_datadir}/libaccounts-glib
|
||||||
|
%dir %{_datadir}/libaccounts-glib/testdata/
|
||||||
|
%{_datadir}/libaccounts-glib/testdata/*
|
||||||
|
%{_datadir}/vala/vapi/libaccounts-glib.deps
|
||||||
|
%{_datadir}/vala/vapi/libaccounts-glib.vapi
|
||||||
|
%doc ChangeLog NEWS README
|
||||||
|
|
||||||
|
%files tools
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/ag-backup
|
||||||
|
%{_bindir}/ag-tool
|
||||||
|
%{_mandir}/man1/ag-backup.1.gz
|
||||||
|
%{_mandir}/man1/ag-tool.1.gz
|
||||||
|
|
||||||
|
%files apidocs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gtk-doc/html/libaccounts-glib
|
||||||
|
%{_datadir}/gtk-doc/html/libaccounts-glib/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Mar 01 2014 Automatic Build System <autodist@mambasoft.it> 1.16-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Jan 01 2014 Automatic Build System <autodist@mambasoft.it> 1.15-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 1.12-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Jun 04 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8-2mamba
|
||||||
|
- python 2.7 rebuild
|
||||||
|
|
||||||
|
* Wed Apr 10 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8-1mamba
|
||||||
|
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user