rebuilt [release 2.0.2-2mamba;Sat Nov 27 2021]
This commit is contained in:
parent
8eec15820f
commit
7a162a2968
34
libaacplus-2.0.2-au.patch
Normal file
34
libaacplus-2.0.2-au.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
diff -ura package.orig/frontend/au_channel.h package.new/frontend/au_channel.h
|
||||||
|
--- package.orig/frontend/au_channel.h 2017-06-12 16:45:07.801636703 -0500
|
||||||
|
+++ package.new/frontend/au_channel.h 2017-06-12 18:34:47.922727878 -0500
|
||||||
|
@@ -12,7 +12,7 @@
|
||||||
|
int aFmt;
|
||||||
|
} WavInfo;
|
||||||
|
|
||||||
|
-inline FILE* AuChannelOpen (const char* filename, WavInfo* info)
|
||||||
|
+static inline FILE* AuChannelOpen (const char* filename, WavInfo* info)
|
||||||
|
{
|
||||||
|
unsigned char header[12];
|
||||||
|
unsigned char data[WAV_HEADER_SIZE];
|
||||||
|
@@ -48,18 +48,18 @@
|
||||||
|
return handle;
|
||||||
|
}
|
||||||
|
|
||||||
|
-inline void AuChannelClose (FILE *audioChannel)
|
||||||
|
+static inline void AuChannelClose (FILE *audioChannel)
|
||||||
|
{
|
||||||
|
fclose(audioChannel);
|
||||||
|
}
|
||||||
|
|
||||||
|
-inline size_t AuChannelReadShort(FILE *audioChannel, short *samples, int nSamples, int *readed)
|
||||||
|
+static inline size_t AuChannelReadShort(FILE *audioChannel, short *samples, int nSamples, int *readed)
|
||||||
|
{
|
||||||
|
*readed = fread(samples, 2, nSamples, audioChannel);
|
||||||
|
return *readed <= 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
-inline size_t AuChannelReadFloat(FILE *audioChannel, float *samples, int nSamples, int *readed)
|
||||||
|
+static inline size_t AuChannelReadFloat(FILE *audioChannel, float *samples, int nSamples, int *readed)
|
||||||
|
{
|
||||||
|
*readed = fread(samples, 4, nSamples, audioChannel);
|
||||||
|
return *readed <= 0;
|
@ -1,19 +1,20 @@
|
|||||||
Name: libaacplus
|
Name: libaacplus
|
||||||
Version: 2.0.2
|
Version: 2.0.2
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: AAC+ encoding library
|
Summary: AAC+ encoding library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://tipok.org.ua/node/17
|
URL: https://tipok.org.ua/node/17
|
||||||
Source: http://217.20.164.161/~tipok/aacplus/libaacplus-%{version}.tar.gz
|
Source: http://tipok.org.ua/downloads/media/aac+/libaacplus/libaacplus-%{version}.tar.gz
|
||||||
|
Source1: https://www.3gpp.org/ftp/Specs/archive/26_series/26.410/26410-800.zip
|
||||||
|
Patch0: libaacplus-2.0.2-au.patch
|
||||||
License: LGPL, 3GPP
|
License: LGPL, 3GPP
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libfftw-devel
|
BuildRequires: libfftw-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
AAC+ encoding library.
|
AAC+ encoding library.
|
||||||
@ -22,8 +23,7 @@ AAC+ encoding library.
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Development files for %{name}
|
Summary: Development files for %{name}
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
## note: you can add this requirement if .pc files are provided by this package
|
Requires: pkg-config
|
||||||
#Requires: pkg-config
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
@ -40,11 +40,14 @@ This package contains utility applications for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .au
|
||||||
|
cp %{SOURCE1} src
|
||||||
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
|
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
|
||||||
|
./autogen.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
|
||||||
%configure
|
%configure
|
||||||
|
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -74,8 +77,11 @@ make
|
|||||||
%files tools
|
%files tools
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/aacplusenc
|
%{_bindir}/aacplusenc
|
||||||
%{_mandir}/man1/aacplusenc.1.gz
|
%{_mandir}/man1/aacplusenc.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
* Fri Jan 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-1mamba
|
* Fri Jan 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-1mamba
|
||||||
- package created by silvan using the webbuild interface
|
- package created by silvan using the webbuild interface
|
||||||
|
Loading…
Reference in New Issue
Block a user