update to 2016.1.1 [release 2016.1.1-1mamba;Fri Mar 04 2016]

This commit is contained in:
Ercole 'ercolinux' Carpanetto 2024-01-06 03:39:15 +01:00
parent e834ceb76f
commit 450f5414dd
4 changed files with 346 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libSimGear
This package contains a tools and libraries useful for constructing simulation and visualization applications such as FlightGear or TerraGear.

View File

@ -0,0 +1,11 @@
diff -Nru SimGear-1.9.1.orig/simgear/debug/logstream.hxx SimGear-1.9.1/simgear/debug/logstream.hxx
--- SimGear-1.9.1.orig/simgear/debug/logstream.hxx 2009-01-25 13:00:32.000000000 +0100
+++ SimGear-1.9.1/simgear/debug/logstream.hxx 2009-05-04 13:01:39.000000000 +0200
@@ -33,6 +33,7 @@
#include <streambuf>
#include <ostream>
+#include <cstdio>
#include <simgear/debug/debug_types.h>

View File

@ -0,0 +1,203 @@
commit 51ff30f386ac098f477ff16c71756bcd089dcfae
Author: Tim Moore <timoore33@gmail.com>
Date: Sun Apr 19 17:11:49 2015 +0200
changes for OSG 3.3.4 and later
The public interfaces to osgText and osg::GLExtensions changed.
diff --git a/simgear/canvas/elements/CanvasText.cxx b/simgear/canvas/elements/CanvasText.cxx
index 4b7600f..ead600b 100644
--- a/simgear/canvas/elements/CanvasText.cxx
+++ b/simgear/canvas/elements/CanvasText.cxx
@@ -159,8 +159,12 @@ namespace canvas
if( empty() )
return pos;
-
+#if OSG_VERSION_LESS_THAN(3,3,4)
GlyphQuads::Coords2 const& coords = _quads->_coords;
+#else
+ GlyphQuads::Coords2 refCoords = _quads->_coords;
+ GlyphQuads::Coords2::element_type &coords = *refCoords.get();
+#endif
size_t global_i = _begin + i;
if( global_i == _begin )
@@ -194,7 +198,12 @@ namespace canvas
return cursorPos(0);
GlyphQuads::Glyphs const& glyphs = _quads->_glyphs;
+ #if OSG_VERSION_LESS_THAN(3,3,4)
GlyphQuads::Coords2 const& coords = _quads->_coords;
+#else
+ GlyphQuads::Coords2 refCoords = _quads->_coords;
+ GlyphQuads::Coords2::element_type &coords = *refCoords.get();
+#endif
float const HIT_FRACTION = 0.6;
float const character_width = _text->getCharacterHeight()
@@ -627,7 +636,13 @@ namespace canvas
const GlyphQuads& quads = _textureGlyphQuadMap.begin()->second;
const GlyphQuads::Glyphs& glyphs = quads._glyphs;
- const GlyphQuads::Coords2& coords = quads._coords;
+#if OSG_VERSION_LESS_THAN(3,3,4)
+ GlyphQuads::Coords2 const& coords = quads._coords;
+#else
+ GlyphQuads::Coords2 refCoords = quads._coords;
+ GlyphQuads::Coords2::element_type &coords = *refCoords.get();
+#endif
+
const GlyphQuads::LineNumbers& line_numbers = quads._lineNumbers;
float wr = _characterHeight / getCharacterAspectRatio();
diff --git a/simgear/scene/material/Technique.cxx b/simgear/scene/material/Technique.cxx
index 93a17b8..96856cd 100644
--- a/simgear/scene/material/Technique.cxx
+++ b/simgear/scene/material/Technique.cxx
@@ -326,9 +326,15 @@ public:
= GL2Extensions::Get(static_cast<unsigned>(contextId), true);
if (!extensions)
return;
+#if OSG_VERSION_LESS_THAN(3,3,3)
if (!extensions->isGlslSupported())
return;
value = extensions->getLanguageVersion();
+#else
+ if (!extensions->isGlslSupported)
+ return;
+ value = extensions->glslLanguageVersion;
+#endif
}
};
@@ -357,7 +363,11 @@ public:
= GL2Extensions::Get(static_cast<unsigned>(contextId), true);
if (!extensions)
return;
+#if OSG_VERSION_LESS_THAN(3,3,3)
value = extensions->isGlslSupported();
+#else
+ value = extensions->isGlslSupported;
+#endif
}
};
diff --git a/simgear/scene/sky/CloudShaderGeometry.cxx b/simgear/scene/sky/CloudShaderGeometry.cxx
index 8b4ea16..7800839 100644
--- a/simgear/scene/sky/CloudShaderGeometry.cxx
+++ b/simgear/scene/sky/CloudShaderGeometry.cxx
@@ -127,8 +127,12 @@ void CloudShaderGeometry::drawImplementation(RenderInfo& renderInfo) const
sortData.frameSorted = frameNumber;
}
-
+
+#if OSG_VERSION_LESS_THAN(3,3,3)
const Extensions* extensions = getExtensions(state.getContextID(),true);
+#else
+ const GLExtensions* extensions = GLExtensions::Get(state.getContextID(), true);
+#endif
GLfloat ua1[3] = { (GLfloat) alpha_factor,
(GLfloat) shade_factor,
(GLfloat) cloud_height };
diff --git a/simgear/scene/tgdb/ShaderGeometry.cxx b/simgear/scene/tgdb/ShaderGeometry.cxx
index 5d286c3..ac9ec93 100644
--- a/simgear/scene/tgdb/ShaderGeometry.cxx
+++ b/simgear/scene/tgdb/ShaderGeometry.cxx
@@ -47,7 +47,11 @@ void ShaderGeometry::addObject(const Vec3& position, float scale,
void ShaderGeometry::drawImplementation(osg::RenderInfo& renderInfo) const
{
State& state = *renderInfo.getState();
+#if OSG_VERSION_LESS_THAN(3,3,3)
const Extensions* extensions = getExtensions(state.getContextID(), true);
+#else
+ const GLExtensions* extensions = GLExtensions::Get(state.getContextID(), true);
+#endif
Vec4Array::const_iterator citer = _posScaleArray->begin();
Vec4Array::const_iterator cend = _posScaleArray->end();
FloatArray::const_iterator viter = _vertexAttribArray->begin();
diff --git a/simgear/scene/util/SGSceneFeatures.cxx b/simgear/scene/util/SGSceneFeatures.cxx
index 4367e45..79f182f 100644
--- a/simgear/scene/util/SGSceneFeatures.cxx
+++ b/simgear/scene/util/SGSceneFeatures.cxx
@@ -25,11 +25,13 @@
#include "SGSceneFeatures.hxx"
+#include <osg/Version>
#include <osg/FragmentProgram>
#include <osg/VertexProgram>
#include <osg/Point>
#include <osg/PointSprite>
#include <osg/Texture>
+#include <osg/GLExtensions>
#include <OpenThreads/Mutex>
#include <OpenThreads/ScopedLock>
@@ -84,12 +86,18 @@ SGSceneFeatures::setTextureCompression(osg::Texture* texture) const
bool
SGSceneFeatures::getHavePointSprites(unsigned contextId) const
{
+#if OSG_VERSION_LESS_THAN(3,3,3)
return osg::PointSprite::isPointSpriteSupported(contextId);
+#else
+ const osg::GLExtensions* ex = osg::GLExtensions::Get(contextId, true);
+ return ex && ex->isPointSpriteSupported;
+#endif
}
bool
SGSceneFeatures::getHaveFragmentPrograms(unsigned contextId) const
{
+#if OSG_VERSION_LESS_THAN(3,3,3)
const osg::FragmentProgram::Extensions* fpe;
fpe = osg::FragmentProgram::getExtensions(contextId, true);
if (!fpe)
@@ -98,11 +106,16 @@ SGSceneFeatures::getHaveFragmentPrograms(unsigned contextId) const
return false;
return true;
+#else
+ const osg::GLExtensions* ex = osg::GLExtensions::Get(contextId, true);
+ return ex && ex->isFragmentProgramSupported;
+#endif
}
bool
SGSceneFeatures::getHaveVertexPrograms(unsigned contextId) const
{
+#if OSG_VERSION_LESS_THAN(3,3,3)
const osg::VertexProgram::Extensions* vpe;
vpe = osg::VertexProgram::getExtensions(contextId, true);
if (!vpe)
@@ -111,6 +124,10 @@ SGSceneFeatures::getHaveVertexPrograms(unsigned contextId) const
return false;
return true;
+#else
+ const osg::GLExtensions* ex = osg::GLExtensions::Get(contextId, true);
+ return ex && ex->isVertexProgramSupported;
+#endif
}
bool
@@ -124,6 +141,7 @@ SGSceneFeatures::getHaveShaderPrograms(unsigned contextId) const
bool
SGSceneFeatures::getHavePointParameters(unsigned contextId) const
{
+#if OSG_VERSION_LESS_THAN(3,3,3)
const osg::Point::Extensions* pe;
pe = osg::Point::getExtensions(contextId, true);
if (!pe)
@@ -131,5 +149,9 @@ SGSceneFeatures::getHavePointParameters(unsigned contextId) const
if (!pe->isPointParametersSupported())
return false;
return true;
+#else
+ const osg::GLExtensions* ex = osg::GLExtensions::Get(contextId, true);
+ return ex && ex->isPointParametersSupported;
+#endif
}

130
libSimGear.spec Normal file
View File

@ -0,0 +1,130 @@
%define rel 2016.1
Name: libSimGear
Version: 2016.1.1
Release: 1mamba
Summary: Tools and libraries useful for FlightGear
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.simgear.org/
Source: http://netix.dl.sourceforge.net/project/flightgear/release-%{rel}/simgear-%{version}.tar.bz2
#Source: ftp://ftp.ihg.uni-duisburg.de/Mirrors/ftp.simgear.org/Source/simgear-%{version}.tar.bz2
Patch0: %{name}-1.9.1-gcc44.patch
Patch1: libSimGear-3.4.0-OpenSceneGraph-3.4.0.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXi-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libXt-devel
BuildRequires: libXmu-devel
BuildRequires: libGL-devel
BuildRequires: libGLUT-devel
BuildRequires: libopenal-devel >= 0.0
BuildRequires: libplib-devel >= 1.8.4
BuildRequires: zlib-devel >= 1.2.2
BuildRequires: OpenSceneGraph >= 3.4.0
Provides: SimGear = %{version}-%{release}
Obsoletes: SimGear
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
This package contains a tools and libraries useful for constructing simulation and visualization applications such as FlightGear or TerraGear.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Provides: SimGear-devel = %{version}-%{release}
Obsoletes: SimGear-devel
%description devel
This package contains static libraries and header files need for development.
%prep
%setup -q -n simgear-%{version}
#%patch1 -p1
%build
%cmake -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files devel
%defattr(-,root,root)
%dir %{_includedir}/simgear
%{_includedir}/simgear/*
%{_libdir}/libSimGearCore.a
%{_libdir}/libSimGearScene.a
%{_prefix}/lib/cmake/SimGear/SimGearConfig.cmake
%{_prefix}/lib/cmake/SimGear/SimGearConfigVersion.cmake
%{_prefix}/lib/cmake/SimGear/SimGearTargets-release.cmake
%{_prefix}/lib/cmake/SimGear/SimGearTargets.cmake
%doc AUTHORS COPYING
#NEWS README README.zlib TODO
%changelog
* Fri Mar 04 2016 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2016.1.1-1mamba
- update to 2016.1.1
* Sat Feb 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-2mamba
- rebuilt with OpenSceneGraph 3.4.0
* Sat Mar 21 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-1mamba
- update to 3.4.0
* Wed Mar 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.0-2mamba
- rebuilt with OpenSceneGraph 3.1.8
* Sat Feb 22 2014 Automatic Build System <autodist@mambasoft.it> 3.0.0-1mamba
- automatic update by autodist
* Wed Dec 11 2013 Automatic Build System <autodist@mambasoft.it> 2.12.1-1mamba
- automatic update by autodist
* Mon Sep 23 2013 Automatic Build System <autodist@mambasoft.it> 2.12.0-1mamba
- automatic update by autodist
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 2.10.0-1mamba
- automatic version update by autodist
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
- update to 2.8.0
* Thu Jun 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
- update to 2.0.0
* Mon May 04 2009 Automatic Build System <autodist@mambasoft.it> 1.9.1-4mamba
- automatic rebuild by autodist
* Sat Apr 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-3mamba
- automatic rebuild by autodist
* Fri Apr 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-2mamba
- automatic rebuild by autodist
* Mon Mar 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-1mamba
- automatic update by autodist
* Fri Jan 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-1mamba
- automatic update to 1.9.0 by autodist
* Mon Jan 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0-1mamba
- update to 1.0.0
- updated maintainer
* Wed Sep 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.3.8-2qilnx
- specfile fixes
- rebuilt with JPEG Factory support
* Tue Sep 06 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.3.8-1qilnx
- package created by autospec