rebuilt with debug package and patches [release 2.0.11-2mamba;Tue Feb 08 2022]
This commit is contained in:
parent
322a0f15cb
commit
1651e9a48e
@ -1,5 +1,4 @@
|
|||||||
# libSDL_ttf
|
# libSDL_ttf
|
||||||
|
|
||||||
This library allows you to use TrueType fonts to render text in SDL
|
This library allows you to use TrueType fonts to render text in SDL applications.
|
||||||
applications.
|
|
||||||
|
|
||||||
|
11
libSDL_ttf-2.0.11-bug1433.patch
Normal file
11
libSDL_ttf-2.0.11-bug1433.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- SDL_ttf.c.orig 2012-02-12 16:36:41.859977617 +0100
|
||||||
|
+++ SDL_ttf.c 2012-02-12 16:36:53.696580159 +0100
|
||||||
|
@@ -1747,7 +1747,7 @@
|
||||||
|
/* Copy the character from the pixmap */
|
||||||
|
src = glyph->pixmap.buffer;
|
||||||
|
dst = (Uint8*) textbuf->pixels;
|
||||||
|
- for ( row = 0; row < glyph->bitmap.rows; ++row ) {
|
||||||
|
+ for ( row = 0; row < glyph->pixmap.rows; ++row ) {
|
||||||
|
memcpy( dst, src, glyph->pixmap.width );
|
||||||
|
src += glyph->pixmap.pitch;
|
||||||
|
dst += textbuf->pitch;
|
46
libSDL_ttf-2.0.11-freetype-pkgconfig.patch
Normal file
46
libSDL_ttf-2.0.11-freetype-pkgconfig.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
https://bugs.gentoo.org/654758
|
||||||
|
|
||||||
|
--- SDL_ttf-2.0.11/configure.in
|
||||||
|
+++ SDL_ttf-2.0.11/configure.in
|
||||||
|
@@ -64,6 +64,7 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
+PKG_PROG_PKG_CONFIG
|
||||||
|
|
||||||
|
dnl Check for iconv (character conversion library; see iconv.m4)
|
||||||
|
dnl This isn't available on many systems
|
||||||
|
@@ -94,6 +95,17 @@
|
||||||
|
dnl
|
||||||
|
dnl Get the cflags and libraries from the freetype-config script
|
||||||
|
dnl
|
||||||
|
+PKG_CHECK_MODULES(
|
||||||
|
+ FREETYPE2,
|
||||||
|
+ freetype2,
|
||||||
|
+ [
|
||||||
|
+ ft_found=yes
|
||||||
|
+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
|
||||||
|
+ LIBS="$LIBS $FREETYPE2_LIBS"
|
||||||
|
+ ],
|
||||||
|
+ ft_found=no
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
|
||||||
|
installed (optional)],
|
||||||
|
freetype_prefix="$withval", freetype_prefix="")
|
||||||
|
@@ -101,6 +113,7 @@
|
||||||
|
where FREETYPE is installed (optional)],
|
||||||
|
freetype_exec_prefix="$withval", freetype_exec_prefix="")
|
||||||
|
|
||||||
|
+if test "x$ft_found" != "xyes" ; then
|
||||||
|
if test x$freetype_exec_prefix != x ; then
|
||||||
|
freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
|
||||||
|
if test x${FREETYPE_CONFIG+set} != xset ; then
|
||||||
|
@@ -123,6 +136,7 @@
|
||||||
|
CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
|
||||||
|
LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
|
||||||
|
fi
|
||||||
|
+fi
|
||||||
|
|
||||||
|
dnl Check for SDL
|
||||||
|
SDL_VERSION=1.2.4
|
@ -1,6 +1,6 @@
|
|||||||
Name: libSDL_ttf
|
Name: libSDL_ttf
|
||||||
Version: 2.0.11
|
Version: 2.0.11
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Simple DirectMedia Layer - Sample TrueType Font Library
|
Summary: Simple DirectMedia Layer - Sample TrueType Font Library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,60 +8,81 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.libsdl.org/projects/SDL_ttf/
|
URL: http://www.libsdl.org/projects/SDL_ttf/
|
||||||
Source: http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-%{version}.tar.gz
|
Source: http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-%{version}.tar.gz
|
||||||
|
Patch0: libSDL_ttf-2.0.11-bug1433.patch
|
||||||
|
Patch1: libSDL_ttf-2.0.11-freetype-pkgconfig.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
#ld-linux.so.3(GLIBC_2.4): .so link not found
|
||||||
|
#ld-linux.so.3: .so link not found
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libfreetype-devel >= 2.1.9
|
BuildRequires: libSDL-devel
|
||||||
BuildRequires: libSDL-devel >= 1.2.13
|
BuildRequires: libbrotli-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libdirectfb-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgraphite2-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libpcre-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libts-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This library allows you to use TrueType fonts to render text in SDL
|
This library allows you to use TrueType fonts to render text in SDL applications.
|
||||||
applications.
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Libraries, includes and more to develop SDL applications
|
Summary: Libraries, includes and more to develop SDL applications
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This library allows you to use TrueType fonts to render text in SDL
|
This library allows you to use TrueType fonts to render text in SDL applications.
|
||||||
applications.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n SDL_ttf-%{version}
|
%setup -q -n SDL_ttf-%{version}
|
||||||
|
%patch0 -p0 -b .bug1433
|
||||||
|
%patch1 -p1 -b .freetype-pkgconfig
|
||||||
|
|
||||||
|
touch AUTHORS ChangeLog NEWS
|
||||||
|
autoreconf -f -i
|
||||||
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure
|
||||||
--prefix=%{_prefix}
|
|
||||||
|
|
||||||
%make %{_smp_mflags}
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
%makeinstall DESTDIR=%{buildroot}
|
%makeinstall
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/libSDL_ttf-*.so.*
|
||||||
%doc CHANGES COPYING README
|
%doc COPYING
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/*.a
|
%{_libdir}/libSDL_ttf.a
|
||||||
%{_libdir}/*.la
|
%{_libdir}/libSDL_ttf.la
|
||||||
%{_libdir}/*.so
|
%{_libdir}/libSDL_ttf.so
|
||||||
%{_includedir}/SDL/*.h
|
%{_includedir}/SDL/*.h
|
||||||
%{_libdir}/pkgconfig/SDL_ttf.pc
|
%{_libdir}/pkgconfig/SDL_ttf.pc
|
||||||
|
%doc CHANGES README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 08 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.11-2mamba
|
||||||
|
- rebuilt with debug package and patches
|
||||||
|
|
||||||
* Mon Jan 23 2012 Automatic Build System <autodist@mambasoft.it> 2.0.11-1mamba
|
* Mon Jan 23 2012 Automatic Build System <autodist@mambasoft.it> 2.0.11-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
@ -83,6 +104,6 @@ applications.
|
|||||||
* Thu Nov 11 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.0.6-2qilnx
|
* Thu Nov 11 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.0.6-2qilnx
|
||||||
- rebuild and moved to devel official QiLinux repository
|
- rebuild and moved to devel official QiLinux repository
|
||||||
|
|
||||||
* Wed Sep 07 2004 Matteo Bernasconi <matteo.bernasconi@qilinux.it> 2.0.6-1qilnx
|
* Tue Sep 07 2004 Matteo Bernasconi <matteo.bernasconi@qilinux.it> 2.0.6-1qilnx
|
||||||
- first build
|
- first build
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user