rebuilt with current libpng [release 1.2.12-2mamba;Sun Mar 03 2013]
This commit is contained in:
parent
25aaf9b6c6
commit
ace2bc4a7e
@ -1,2 +1,5 @@
|
||||
# libSDL_image
|
||||
|
||||
SDL_image is an image file loading library.
|
||||
It loads images as SDL surfaces, and supports the following formats: BMP, PNM, XPM, LBM, PCX, GIF, JPEG, PNG, TGA.
|
||||
|
||||
|
21
libSDL_image-1.2.12-libpng-1.5.patch
Normal file
21
libSDL_image-1.2.12-libpng-1.5.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- SDL_image-1.2.10/configure.in.orig 2009-11-12 07:41:21.000000000 +0100
|
||||
+++ SDL_image-1.2.10/configure.in 2010-09-07 08:31:57.847130107 +0200
|
||||
@@ -205,15 +205,12 @@
|
||||
png_lib=[`find_lib "libpng*.dll"`]
|
||||
;;
|
||||
*)
|
||||
- png_lib=[`find_lib "libpng.so.[0-9]"`]
|
||||
+ png_lib=[`find_lib "libpng15.so.[0-9][0-9]"`]
|
||||
if test x$png_lib = x; then
|
||||
- png_lib=[`find_lib "libpng.so.[0-9]*"`]
|
||||
+ png_lib=[`find_lib "libpng12.so.[0-9]"`]
|
||||
fi
|
||||
if test x$png_lib = x; then
|
||||
- png_lib=[`find_lib "libpng*.so.[0-9]"`]
|
||||
- fi
|
||||
- if test x$png_lib = x; then
|
||||
- png_lib=[`find_lib "libpng*.so.[0-9]*"`]
|
||||
+ png_lib=[`find_lib "libpng.so.[0-9]"`]
|
||||
fi
|
||||
;;
|
||||
esac
|
12
libSDL_image-libjpeg-8.patch
Normal file
12
libSDL_image-libjpeg-8.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru SDL_image-1.2.10.orig//configure.in SDL_image-1.2.10/configure.in
|
||||
--- SDL_image-1.2.10.orig//configure.in 2010-12-16 04:00:45.561542847 +0100
|
||||
+++ SDL_image-1.2.10/configure.in 2010-12-16 04:03:49.534365936 +0100
|
||||
@@ -170,7 +170,7 @@
|
||||
jpg_lib=[`find_lib "jpeg.dll"`]
|
||||
;;
|
||||
*)
|
||||
- jpg_lib=[`find_lib "libjpeg.so.[0-9]"`]
|
||||
+ jpg_lib=[`find_lib "libjpeg.so.8"`]
|
||||
if test x$jpg_lib = x; then
|
||||
jpg_lib=[`find_lib "libjpeg.so.[0-9][0-9]"`]
|
||||
fi
|
116
libSDL_image.spec
Normal file
116
libSDL_image.spec
Normal file
@ -0,0 +1,116 @@
|
||||
Name: libSDL_image
|
||||
Version: 1.2.12
|
||||
Release: 2mamba
|
||||
Summary: SDL_image is an image file loading library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.libsdl.org/projects/SDL_image/
|
||||
Source: http://www.libsdl.org/projects/SDL_image/release/SDL_image-%{version}.tar.gz
|
||||
Patch0: %{name}-1.2.12-libpng-1.5.patch
|
||||
Patch1: %{name}-libjpeg-8.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libts-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
|
||||
%description
|
||||
SDL_image is an image file loading library.
|
||||
It loads images as SDL surfaces, and supports the following formats: BMP, PNM, XPM, LBM, PCX, GIF, JPEG, PNG, TGA.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description devel
|
||||
SDL_image is an image file loading library.
|
||||
It loads images as SDL surfaces, and supports the following formats: BMP, PNM, XPM, LBM, PCX, GIF, JPEG, PNG, TGA.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n SDL_image-%{version}
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libSDL_image-*.so.*
|
||||
%doc CHANGES COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/SDL/*.h
|
||||
%{_libdir}/libSDL_image.a
|
||||
%{_libdir}/libSDL_image.la
|
||||
%{_libdir}/libSDL_image.so
|
||||
%{_libdir}/pkgconfig/SDL_image.pc
|
||||
%doc README
|
||||
|
||||
%changelog
|
||||
* Sun Mar 03 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-2mamba
|
||||
- rebuilt with current libpng
|
||||
|
||||
* Sun Jan 22 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-1mamba
|
||||
- update to 1.2.12
|
||||
|
||||
* Fri Jan 20 2012 Automatic Build System <autodist@mambasoft.it> 1.2.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.10-3mamba
|
||||
- rebuilt with debug package
|
||||
- added patch to prefer libpng 1.4.x over 1.2.x/1.0.x
|
||||
- added patch to prefer libjpeg 8 over libjpeg 7
|
||||
|
||||
* Sun Aug 22 2010 Automatic Build System <autodist@mambasoft.it> 1.2.10-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jan 25 2010 Automatic Build System <autodist@mambasoft.it> 1.2.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Oct 21 2009 Automatic Build System <autodist@mambasoft.it> 1.2.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Dec 04 2008 gil <puntogil@libero.it> 1.2.7-1mamba
|
||||
- update to 1.2.7
|
||||
|
||||
* Fri Nov 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.6-1mamba
|
||||
- update to 1.2.6
|
||||
|
||||
* Wed Oct 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-1qilnx
|
||||
- update to version 1.2.5 by autospec
|
||||
|
||||
* Fri Aug 06 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.3-1qilnx
|
||||
- package creation
|
Loading…
Reference in New Issue
Block a user