automatic version update by autodist [release 1.2.15-1mamba;Sun Feb 12 2012]
This commit is contained in:
parent
0c980c62ab
commit
a53858a444
@ -1,2 +1,4 @@
|
||||
# libSDL
|
||||
|
||||
This is the Simple DirectMedia Layer, a generic API that provides low level access to audio, keyboard, mouse, and display framebuffer across multiple platforms.
|
||||
|
||||
|
26
libSDL-1.2.14-xio_error-rh603984.patch
Normal file
26
libSDL-1.2.14-xio_error-rh603984.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -up SDL-1.2.14/src/video/x11/SDL_x11mouse.c~ SDL-1.2.14/src/video/x11/SDL_x11mouse.c
|
||||
--- SDL-1.2.14/src/video/x11/SDL_x11mouse.c~ 2009-10-13 01:07:15.000000000 +0200
|
||||
+++ SDL-1.2.14/src/video/x11/SDL_x11mouse.c 2010-06-23 14:16:34.730381512 +0200
|
||||
@@ -230,6 +230,10 @@ void X11_CheckMouseModeNoLock(_THIS)
|
||||
char *env_override;
|
||||
int enable_relative = 1;
|
||||
|
||||
+ /* This happens when quiting after an xio error */
|
||||
+ if ( SDL_Display == NULL )
|
||||
+ return;
|
||||
+
|
||||
/* Allow the user to override the relative mouse mode.
|
||||
They almost never want to do this, as it seriously affects
|
||||
applications that rely on continuous relative mouse motion.
|
||||
diff -up SDL-1.2.14/src/video/x11/SDL_x11wm.c~ SDL-1.2.14/src/video/x11/SDL_x11wm.c
|
||||
--- SDL-1.2.14/src/video/x11/SDL_x11wm.c~ 2009-10-13 01:07:15.000000000 +0200
|
||||
+++ SDL-1.2.14/src/video/x11/SDL_x11wm.c 2010-06-23 14:11:55.596629337 +0200
|
||||
@@ -329,7 +329,7 @@ SDL_GrabMode X11_GrabInputNoLock(_THIS,
|
||||
{
|
||||
int result;
|
||||
|
||||
- if ( this->screen == NULL ) {
|
||||
+ if ( this->screen == NULL || SDL_Display == NULL ) {
|
||||
return(SDL_GRAB_OFF);
|
||||
}
|
||||
if ( ! SDL_Window ) {
|
132
libSDL.spec
Normal file
132
libSDL.spec
Normal file
@ -0,0 +1,132 @@
|
||||
Name: libSDL
|
||||
Version: 1.2.15
|
||||
Release: 1mamba
|
||||
Summary: Simple DirectMedia Layer
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.libsdl.org
|
||||
Source: http://www.libsdl.org/release/SDL-%{version}.tar.gz
|
||||
Patch0: %{name}-1.2.14-xio_error-rh603984.patch
|
||||
License: LGPL
|
||||
BuildRequires: bash
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libaudio-devel
|
||||
%endif
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This is the Simple DirectMedia Layer, a generic API that provides low level access to audio, keyboard, mouse, and display framebuffer across multiple platforms.
|
||||
|
||||
%package devel
|
||||
Summary: Libraries, includes and more to develop SDL applications.
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description devel
|
||||
This is the Simple DirectMedia Layer, a generic API that provides low level access to audio, keyboard, mouse, and display framebuffer across multiple platforms.
|
||||
|
||||
This is the libraries, include files and other resources you can use to develop SDL applications.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n SDL-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-sdl-dlopen \
|
||||
--disable-arts \
|
||||
--disable-esd \
|
||||
--disable-rpath
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
ln -s libSDL-1.2.so.0 %{buildroot}%{_libdir}/libSDL-1.1.so.0
|
||||
rm -f docs/html/Makefile*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/lib*.so.*
|
||||
%doc README README-SDL.txt CREDITS BUGS WhatsNew
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*-config
|
||||
%{_libdir}/lib*.a
|
||||
%{_libdir}/lib*.la
|
||||
%{_libdir}/lib*.so
|
||||
%{_libdir}/pkgconfig/sdl.pc
|
||||
%dir %{_includedir}/SDL/
|
||||
%{_includedir}/SDL/*
|
||||
%{_mandir}/man3/*
|
||||
%{_datadir}/aclocal/*
|
||||
%doc README README-SDL.txt CREDITS BUGS WhatsNew
|
||||
%doc docs.html docs/index.html docs/html
|
||||
|
||||
%changelog
|
||||
* Sun Feb 12 2012 Automatic Build System <autodist@mambasoft.it> 1.2.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.14-4mamba
|
||||
- rebuilt with debug package
|
||||
|
||||
* Sun Aug 22 2010 Automatic Build System <autodist@mambasoft.it> 1.2.14-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Fri Jul 02 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.2.14-2mamba
|
||||
- configure: remove unrecognized options
|
||||
- apply upstream patch: don't crash when trying to exit because of an xio-error
|
||||
http://bugzilla.libsdl.org/show_bug.cgi?id=1009
|
||||
|
||||
* Fri Oct 23 2009 Automatic Build System <autodist@mambasoft.it> 1.2.14-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 29 2009 Automatic Build System <autodist@mambasoft.it> 1.2.13-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Jul 09 2008 gil <puntogil@libero.it> 1.2.13-1mamba
|
||||
- update to 1.2.13
|
||||
|
||||
* Fri Nov 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-1mamba
|
||||
- update to 1.2.12
|
||||
- disabled arts support
|
||||
|
||||
* Wed Oct 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.11-1qilnx
|
||||
- update to version 1.2.11 by autospec
|
||||
|
||||
* Fri Dec 16 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.2.9-1qilnx
|
||||
- update to version 1.2.9 by autospec
|
||||
|
||||
* Thu Dec 23 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.8-1qilnx
|
||||
- update to version 1.2.8 by autospec
|
||||
|
||||
* Sun Jul 18 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.7-1qilnx
|
||||
- new version build
|
||||
|
||||
* Tue Oct 07 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.6-2qilnx
|
||||
- man pages directory fixed
|
||||
|
||||
* Thu Sep 04 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.6-1qilnx
|
||||
- first spec file for QiLinux distribution
|
Reference in New Issue
Block a user