package created by autospec [release 4.6.3-1mamba;Fri Dec 24 2010]
This commit is contained in:
parent
0e2f444234
commit
833f5c978a
@ -1,2 +1,4 @@
|
|||||||
# libQtAssistantClient
|
# libQtAssistantClient
|
||||||
|
|
||||||
|
Qt Assistant client library compatibility version for applications which require it.
|
||||||
|
|
||||||
|
45
libQtAssistantClient-4.6.3-build.patch
Normal file
45
libQtAssistantClient-4.6.3-build.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
--- a/compat.pro
|
||||||
|
+++ b/compat.pro
|
||||||
|
@@ -66,8 +66,6 @@ TRANSLATIONS = translations/assistant_ad
|
||||||
|
translations/assistant_adp_zh_CN.ts \
|
||||||
|
translations/assistant_adp_zh_TW.ts
|
||||||
|
|
||||||
|
-unix:!contains(QT_CONFIG, zlib):LIBS += -lz
|
||||||
|
-
|
||||||
|
contains(CONFIG, static): {
|
||||||
|
win32 {
|
||||||
|
exists($$[QT_INSTALL_PLUGINS]/imageformats/qjpeg.lib) {
|
||||||
|
@@ -81,3 +79,7 @@ contains(CONFIG, static): {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+target.path = $$[QT_INSTALL_BINS]
|
||||||
|
+INSTALLS += target
|
||||||
|
+
|
||||||
|
--- a/lib/lib.pro
|
||||||
|
+++ b/lib/lib.pro
|
||||||
|
@@ -16,8 +16,8 @@ HEADERS = qassistantclient.h \
|
||||||
|
qassistantclient_global.h
|
||||||
|
SOURCES = qassistantclient.cpp
|
||||||
|
|
||||||
|
-DESTDIR = ../../../../lib
|
||||||
|
-DLLDESTDIR = ../../../../bin
|
||||||
|
+DESTDIR = lib
|
||||||
|
+DLLDESTDIR = bin
|
||||||
|
|
||||||
|
unix {
|
||||||
|
QMAKE_CFLAGS += $$QMAKE_CFLAGS_SHLIB
|
||||||
|
@@ -62,7 +62,7 @@ win32 {
|
||||||
|
}
|
||||||
|
|
||||||
|
qt_install_headers {
|
||||||
|
- assistant_headers.files = $$SYNCQT.HEADER_FILES $$SYNCQT.HEADER_CLASSES
|
||||||
|
+ assistant_headers.files = qassistantclient.h qassistantclient_global.h
|
||||||
|
assistant_headers.path = $$[QT_INSTALL_HEADERS]/QtAssistant
|
||||||
|
INSTALLS += assistant_headers
|
||||||
|
}
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/lib/QtAssistant/qassistantclient_global.h
|
||||||
|
@@ -0,0 +1 @@
|
||||||
|
+#include "../qassistantclient_global.h"
|
75
libQtAssistantClient.spec
Normal file
75
libQtAssistantClient.spec
Normal file
@ -0,0 +1,75 @@
|
|||||||
|
Name: libQtAssistantClient
|
||||||
|
Version: 4.6.3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Qt Assistant client library compatibility version for applications which require it
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
|
||||||
|
Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-4.6.3-build.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Qt Assistant client library compatibility version for applications which require it.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Qt Assistant client library compatibility version for applications which require it.
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
cd lib
|
||||||
|
qmake-qt4
|
||||||
|
%make
|
||||||
|
cd ..
|
||||||
|
|
||||||
|
cd translations
|
||||||
|
lrelease assistant_adp_*.ts
|
||||||
|
cd ..
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
cd lib
|
||||||
|
%makeinstall INSTALL_ROOT=%{buildroot}
|
||||||
|
cd ..
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/usr/share/qt4/translations/
|
||||||
|
install -p -m 644 translations/assistant_adp_*.qm %{buildroot}/usr/share/qt4/translations/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libQtAssistantClient.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
## note: this list is just an example; modify as required
|
||||||
|
%{_includedir}/qt4/QtAssistant/qassistantclient*.h
|
||||||
|
%{_libdir}/libQtAssistantClient.so
|
||||||
|
%{_datadir}/qt4/translations/assistant_adp_*.qm
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.3-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user