automatic rebuild by autodist [release 0.95.2-2mamba;Wed Jul 31 2013]
This commit is contained in:
parent
89e08666a9
commit
42aff9498e
@ -1,2 +1,7 @@
|
||||
# lesstif
|
||||
|
||||
Lesstif is an API compatible clone of the Motif toolkit.
|
||||
Most of the Motif 1.2 API is in place.
|
||||
Motif 2.1 functionality is being improved.
|
||||
Many Motif applications compile and run out-of-the-box with LessTif, and we want to hear about those that don't.
|
||||
|
||||
|
21
lesstif-0.94.4-configure_freetype.patch
Normal file
21
lesstif-0.94.4-configure_freetype.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -ru lesstif-0.94.4/configure lesstif-0.94.4-fix/configure
|
||||
--- lesstif-0.94.4/configure 2005-03-31 21:44:45.000000000 +0200
|
||||
+++ lesstif-0.94.4-fix/configure 2005-04-07 09:45:15.000000000 +0200
|
||||
@@ -28421,6 +28421,8 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
$ac_includes_default
|
||||
+#include <ft2build.h>"
|
||||
+#include FT_FREETYPE_H"
|
||||
#include <$ac_header>
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
@@ -28465,6 +28467,8 @@
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
+#include <ft2build.h>
|
||||
+#include FT_FREETYPE_H
|
||||
#include <$ac_header>
|
||||
_ACEOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
|
38
lesstif-0.95.0-CAN-2005-0605.patch
Normal file
38
lesstif-0.95.0-CAN-2005-0605.patch
Normal file
@ -0,0 +1,38 @@
|
||||
--- lesstif-0.95.0/lib/Xm-2.1/Xpmscan.c.BAD 2006-08-29 14:34:31.000000000 -0500
|
||||
+++ lesstif-0.95.0/lib/Xm-2.1/Xpmscan.c 2006-08-29 14:36:05.000000000 -0500
|
||||
@@ -672,8 +672,8 @@
|
||||
char *dst;
|
||||
unsigned int *iptr;
|
||||
char *data;
|
||||
- unsigned int x, y, i;
|
||||
- int bits, depth, ibu, ibpp, offset;
|
||||
+ unsigned int x, y;
|
||||
+ int bits, depth, ibu, ibpp, offset, i;
|
||||
unsigned long lbt;
|
||||
Pixel pixel, px;
|
||||
|
||||
@@ -684,6 +684,9 @@
|
||||
ibpp = image->bits_per_pixel;
|
||||
offset = image->xoffset;
|
||||
|
||||
+ if (image->bitmap_unit < 0)
|
||||
+ return (XpmNoMemory);
|
||||
+
|
||||
if ((image->bits_per_pixel | image->depth) == 1) {
|
||||
ibu = image->bitmap_unit;
|
||||
for (y = 0; y < height; y++)
|
||||
--- lesstif-0.95.0/lib/Xm-2.1/Xpmcreate.c.BAD 2006-08-29 14:36:13.000000000 -0500
|
||||
+++ lesstif-0.95.0/lib/Xm-2.1/Xpmcreate.c 2006-08-29 14:36:36.000000000 -0500
|
||||
@@ -1265,10 +1265,10 @@
|
||||
register char *src;
|
||||
register char *dst;
|
||||
register unsigned int *iptr;
|
||||
- register unsigned int x, y, i;
|
||||
+ register unsigned int x, y;
|
||||
register char *data;
|
||||
Pixel pixel, px;
|
||||
- int nbytes, depth, ibu, ibpp;
|
||||
+ int nbytes, depth, ibu, ibpp, i;
|
||||
|
||||
data = image->data;
|
||||
iptr = pixelindex;
|
22
lesstif-0.95.0-linkage_decl_conflict.patch
Normal file
22
lesstif-0.95.0-linkage_decl_conflict.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- lesstif-0.95.0/include/Motif-2.1/Xm/VendorSP.h.orig 2007-12-06 16:12:48.000000000 +0100
|
||||
+++ lesstif-0.95.0/include/Motif-2.1/Xm/VendorSP.h 2007-12-06 16:13:05.000000000 +0100
|
||||
@@ -30,10 +30,6 @@
|
||||
#include <Xm/VendorS.h>
|
||||
#include <X11/ShellP.h>
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" {
|
||||
-#endif
|
||||
-
|
||||
XMLIBEXPORT extern Cardinal _XmFilterResources(XtResource *resources,
|
||||
Cardinal numResources,
|
||||
WidgetClass filterClass,
|
||||
@@ -58,8 +54,4 @@ XMLIBEXPORT extern Display *_XmGetDefaul
|
||||
XMLIBEXPORT extern VendorShellClassRec vendorShellClassRec;
|
||||
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-}
|
||||
-#endif
|
||||
-
|
||||
#endif /* _XM_VENDORSP_H */
|
241
lesstif.spec
Normal file
241
lesstif.spec
Normal file
@ -0,0 +1,241 @@
|
||||
### AUTOUPDATE-OFF: 8
|
||||
%define libname liblesstif
|
||||
|
||||
Name: lesstif
|
||||
Version: 0.95.2
|
||||
Release: 2mamba
|
||||
Summary: A free Motif clone
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.lesstif.org/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/lesstif/lesstif-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.94.4-configure_freetype.patch
|
||||
Patch1: %{name}-0.95.0-CAN-2005-0605.patch
|
||||
Patch2: %{name}-0.95.0-linkage_decl_conflict.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: bash
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXp-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Lesstif is an API compatible clone of the Motif toolkit.
|
||||
Most of the Motif 1.2 API is in place.
|
||||
Motif 2.1 functionality is being improved.
|
||||
Many Motif applications compile and run out-of-the-box with LessTif, and we want to hear about those that don't.
|
||||
|
||||
%package mwm
|
||||
Group: System/X11
|
||||
Summary: Lesstif Motif window manager clone based on fvwm
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description mwm
|
||||
Mwm window manager that adheres largely to the Motif mwm specification.
|
||||
|
||||
%package -n %{libname}
|
||||
Group: System/Libraries
|
||||
Summary: Libraries for lesstif
|
||||
|
||||
%description -n %{libname}
|
||||
Lesstif is an API compatible clone of the Motif toolkit.
|
||||
Most of the Motif 1.2 API is in place.
|
||||
Motif 2.1 functionality is being improved.
|
||||
Many Motif applications compile and run out-of-the-box with LessTif, and we want to hear about those that don't.
|
||||
|
||||
This is the libraries package.
|
||||
|
||||
%package -n %{libname}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n %{libname}-devel
|
||||
Lesstif is an API compatible clone of the Motif toolkit.
|
||||
Most of the Motif 1.2 API is in place.
|
||||
Motif 2.1 functionality is being improved.
|
||||
Many Motif applications compile and run out-of-the-box with LessTif, and we want to hear about those that don't.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n %{libname}-static
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries for %{name}
|
||||
Requires: %{libname}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n %{libname}-static
|
||||
This package contains static libraries for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--libdir=%{_libdir} \
|
||||
--enable-build-12 \
|
||||
--enable-build-20 \
|
||||
--enable-build-21 \
|
||||
--enable-default-21 \
|
||||
--enable-production \
|
||||
--enable-static \
|
||||
--with-x \
|
||||
--x-includes=%{_includedir} \
|
||||
--x-libraries=%{_libdir} \
|
||||
--with-motif-includes=%{_includedir} \
|
||||
--with-motif-libraries=%{_libdir} \
|
||||
--with-xdnd \
|
||||
--disable-build-tests \
|
||||
--disable-debug \
|
||||
--disable-maintainer-mode
|
||||
|
||||
%make \
|
||||
libdir=%{_libdir} \
|
||||
docdir=%{_datadir}/doc/LessTif-%{version} \
|
||||
appdir=%{_datadir}/X11/app-defaults \
|
||||
mwmddir=%{_sysconfdir}/mwm
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall \
|
||||
libdir=%{_libdir} \
|
||||
docdir=%{_datadir}/doc/LessTif-%{version} \
|
||||
appdir=%{_datadir}/X11/app-defaults \
|
||||
mwmddir=%{_sysconfdir}/mwm
|
||||
|
||||
mv %{buildroot}/usr/LessTif/* \
|
||||
%{buildroot}%{_datadir}/doc/LessTif-%{version}/
|
||||
rmdir %{buildroot}/usr/LessTif/
|
||||
cp NEWS %{buildroot}%{_datadir}/doc/LessTif-%{version}/
|
||||
|
||||
rm -f %{buildroot}%{_sysconfdir}/mwm/{README,alt.map}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/motif-config
|
||||
%{_bindir}/mxmkmf
|
||||
%{_bindir}/uil
|
||||
%{_bindir}/xmbind
|
||||
%{_datadir}/doc/LessTif-%{version}/AUTHORS
|
||||
%{_datadir}/doc/LessTif-%{version}/BUG-REPORTING
|
||||
%{_datadir}/doc/LessTif-%{version}/COPYING.LIB
|
||||
%{_datadir}/doc/LessTif-%{version}/CREDITS
|
||||
%{_datadir}/doc/LessTif-%{version}/NEWS
|
||||
%{_datadir}/doc/LessTif-%{version}/README
|
||||
|
||||
%files mwm
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mwm
|
||||
%{_datadir}/X11/app-defaults/Mwm
|
||||
%dir %{_sysconfdir}/mwm/
|
||||
%config(noreplace) %{_sysconfdir}/mwm/system.mwmrc
|
||||
%{_mandir}/man1/mwm.*
|
||||
%doc clients/Motif-2.1/mwm/README clients/Motif-2.1/mwm/alt.map
|
||||
|
||||
%files -n %{libname}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libDtPrint.so.*
|
||||
%{_libdir}/libMrm.so.*
|
||||
%{_libdir}/libUil.so.*
|
||||
%{_libdir}/libXm.so.*
|
||||
%{_mandir}/man1/*
|
||||
%exclude %{_mandir}/man1/mwm.*
|
||||
|
||||
%files -n %{libname}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/LessTif/config/*
|
||||
%{_datadir}/aclocal/ac_find_motif.m4
|
||||
%dir %{_includedir}/Xm
|
||||
%{_includedir}/Xm/*
|
||||
%dir %{_includedir}/Mrm
|
||||
%{_includedir}/Mrm/*
|
||||
%dir %{_includedir}/uil
|
||||
%{_includedir}/uil/*
|
||||
%dir %{_includedir}/Dt
|
||||
%{_includedir}/Dt/*
|
||||
%dir %{_datadir}/doc/LessTif-%{version}
|
||||
%{_datadir}/doc/LessTif-%{version}/*
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/AUTHORS
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/BUG-REPORTING
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/COPYING.LIB
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/CREDITS
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/NEWS
|
||||
%exclude %{_datadir}/doc/LessTif-%{version}/README
|
||||
%{_mandir}/man3/*
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%files -n %{libname}-static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libDtPrint.a
|
||||
%{_libdir}/libMrm.a
|
||||
%{_libdir}/libUil.a
|
||||
%{_libdir}/libXm.a
|
||||
|
||||
%changelog
|
||||
* Wed Jul 31 2013 Automatic Build System <autodist@mambasoft.it> 0.95.2-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jul 13 2009 Automatic Build System <autodist@mambasoft.it> 0.95.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue May 19 2009 Automatic Build System <autodist@mambasoft.it> 0.95.0-7mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Sat Sep 27 2008 gil <puntogil@libero.it> 0.95.0-6mamba
|
||||
- create subpackage liblesstif-static (packge xephem requires libXm.a)
|
||||
|
||||
* Thu Dec 06 2007 Aleph0 <aleph0@openmamba.org> 0.95.0-5mamba
|
||||
- fixed C/C++ linkage declarations conflict error using gcc 4.2
|
||||
|
||||
* Fri Oct 31 2007 Aleph0 <aleph0@openmamba.org> 0.95.0-4mamba
|
||||
- security fix against CAN-2005-0605
|
||||
- create subpackage mwm
|
||||
|
||||
* Tue Oct 30 2007 Aleph0 <aleph0@openmamba.org> 0.95.0-3mamba
|
||||
- documentation moved to devel package
|
||||
- moved Mwm to %{_datadir}/X11/app-defaults
|
||||
|
||||
* Thu Dec 28 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.0-2qilnx
|
||||
- add X.Org 7.1 build requirement and install into modular X.Org dirs
|
||||
|
||||
* Wed Aug 30 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.94.4-2qilnx
|
||||
- update to version 0.95.0 by autospec
|
||||
- rebuilt with 'enable-build-12' and 'enable-default-21'
|
||||
|
||||
* Thu Apr 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.94.4-1qilnx
|
||||
- update to version 0.94.4 by autospec
|
||||
- also fix security issue QSA-2005-037 (CAN-2004-068[7,8], CAN-2004-0914)
|
||||
- added a few missing build requirements
|
||||
- fixed package groups
|
||||
- fixed check of freetype library and header files
|
||||
|
||||
* Sun May 25 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.9.41-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user