187 lines
6.2 KiB
RPMSpec
187 lines
6.2 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: kwayland
|
|
Version: 5.45.0
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 Qt-style API to interact with the wayland-client and wayland-server API.
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
Source: http://download.kde.org/stable/frameworks/%{majver}/kwayland-%{version}.tar.xz
|
|
# Source: http://download.kde.org/stable/frameworks/%{majver}/...-%{version}.tar.xz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libGL-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libwayland-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
KWayland is a Qt-style API to interact with the wayland-client and wayland-server API.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_kde5_libdir}/libKF5WaylandClient.so.*
|
|
%{_kde5_libdir}/libKF5WaylandServer.so.*
|
|
%{_libexecdir}/*
|
|
%doc COPYING.LIB
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/xdg/org_kde_kwayland.categories
|
|
%dir %{_kde5_includedir}/KWayland
|
|
%dir %{_kde5_includedir}/KWayland/Client
|
|
%{_kde5_includedir}/KWayland/Client/*
|
|
%dir %{_kde5_includedir}/KWayland/Server
|
|
%{_kde5_includedir}/KWayland/Server/*
|
|
%{_kde5_includedir}/kwayland_version.h
|
|
%dir %{_kde5_libdir}/cmake/KF5Wayland
|
|
%{_kde5_libdir}/cmake/KF5Wayland/KF5Wayland*.cmake
|
|
%{_kde5_libdir}/libKF5WaylandClient.so
|
|
%{_kde5_libdir}/libKF5WaylandServer.so
|
|
%{_kde5_mkspecsdir}/qt_KWaylandClient.pri
|
|
%{_kde5_mkspecsdir}/qt_KWaylandServer.pri
|
|
|
|
%changelog
|
|
* Tue Apr 17 2018 Automatic Build System <autodist@mambasoft.it> 5.45.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 16 2018 Automatic Build System <autodist@mambasoft.it> 5.44.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 27 2018 Automatic Build System <autodist@mambasoft.it> 5.43.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 17 2018 Automatic Build System <autodist@mambasoft.it> 5.42.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 23 2017 Automatic Build System <autodist@mambasoft.it> 5.41.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 14 2017 Automatic Build System <autodist@mambasoft.it> 5.40.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 21 2017 Automatic Build System <autodist@mambasoft.it> 5.39.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 11 2017 Automatic Build System <autodist@mambasoft.it> 5.38.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 18 2017 Automatic Build System <autodist@mambasoft.it> 5.37.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 05 2017 Automatic Build System <autodist@mambasoft.it> 5.36.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 02 2017 Automatic Build System <autodist@mambasoft.it> 5.35.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 14 2017 Automatic Build System <autodist@mambasoft.it> 5.32.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 03 2017 Automatic Build System <autodist@mambasoft.it> 5.31.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 24 2017 Automatic Build System <autodist@mambasoft.it> 5.30.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 18 2016 Automatic Build System <autodist@mambasoft.it> 5.29.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 20 2016 Automatic Build System <autodist@mambasoft.it> 5.28.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 13 2016 Automatic Build System <autodist@mambasoft.it> 5.27.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 22 2016 Automatic Build System <autodist@mambasoft.it> 5.26.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 20 2016 Automatic Build System <autodist@mambasoft.it> 5.25.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 13 2016 Automatic Build System <autodist@mambasoft.it> 5.24.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.23.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 29 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.22.0-1mamba
|
|
- update to 5.22.0
|
|
|
|
* Wed May 11 2016 Automatic Build System <autodist@mambasoft.it> 5.6.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 19 2016 Automatic Build System <autodist@mambasoft.it> 5.6.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 05 2016 Automatic Build System <autodist@mambasoft.it> 5.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 30 2016 Automatic Build System <autodist@mambasoft.it> 5.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 27 2016 Automatic Build System <autodist@mambasoft.it> 5.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 01 2016 Automatic Build System <autodist@mambasoft.it> 5.5.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 27 2016 Automatic Build System <autodist@mambasoft.it> 5.5.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 07 2016 Automatic Build System <autodist@mambasoft.it> 5.5.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 02 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.5.2-1mamba
|
|
- package created using the webbuild interface
|