421 lines
14 KiB
RPMSpec
421 lines
14 KiB
RPMSpec
%define libname libktorrent
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
%define libver 1.%(echo %version | cut -d. -f2-3)
|
|
|
|
Name: ktorrent
|
|
Version: 24.08.3
|
|
Release: 1mamba
|
|
Summary: BitTorrent client for KDE
|
|
Group: Graphical Desktop/Applications/Networking
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://kde.org
|
|
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/ktorrent-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libQt6Core
|
|
BuildRequires: libQt6DBus
|
|
BuildRequires: libQt6Gui
|
|
BuildRequires: libQt6Network
|
|
BuildRequires: libQt6OpenGL
|
|
BuildRequires: libQt6PrintSupport
|
|
BuildRequires: libQt6Widgets
|
|
BuildRequires: libQt6Xml
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgcrypt-devel
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libgmp-devel
|
|
BuildRequires: libkf6-karchive-devel
|
|
BuildRequires: libkf6-kbookmarks-devel
|
|
BuildRequires: libkf6-kcmutils-devel
|
|
BuildRequires: libkf6-kcolorscheme-devel
|
|
BuildRequires: libkf6-kcompletion-devel
|
|
BuildRequires: libkf6-kconfig-devel
|
|
BuildRequires: libkf6-kconfigwidgets-devel
|
|
BuildRequires: libkf6-kcoreaddons-devel
|
|
BuildRequires: libkf6-kcrash-devel
|
|
BuildRequires: libkf6-kdbusaddons-devel
|
|
BuildRequires: libkf6-kdnssd-devel
|
|
BuildRequires: libkf6-kglobalaccel-devel
|
|
BuildRequires: libkf6-ki18n-devel
|
|
BuildRequires: libkf6-kiconthemes-devel
|
|
BuildRequires: libkf6-kio-devel
|
|
BuildRequires: libkf6-kitemviews-devel
|
|
BuildRequires: libkf6-kjobwidgets-devel
|
|
BuildRequires: libkf6-knotifications-devel
|
|
BuildRequires: libkf6-knotifyconfig-devel
|
|
BuildRequires: libkf6-kparts-devel
|
|
BuildRequires: libkf6-kplotting-devel
|
|
BuildRequires: libkf6-kservice-devel
|
|
BuildRequires: libkf6-kstatusnotifieritem-devel
|
|
BuildRequires: libkf6-ktextwidgets-devel
|
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
|
BuildRequires: libkf6-kwindowsystem-devel
|
|
BuildRequires: libkf6-kxmlgui-devel
|
|
BuildRequires: libkf6-solid-devel
|
|
BuildRequires: libkf6-sonnet-devel
|
|
BuildRequires: libkf6-syndication-devel
|
|
BuildRequires: libktorrent-devel
|
|
BuildRequires: libmaxminddb-devel
|
|
BuildRequires: libphonon-qt6-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libtag-devel
|
|
BuildRequires: qt6-qt5compat-devel
|
|
BuildRequires: qt6-qtdeclarative-devel
|
|
BuildRequires: qt6-qtpositioning-devel
|
|
BuildRequires: qt6-qtwebchannel-devel
|
|
BuildRequires: qt6-qtwebengine-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: gettext-devel
|
|
BuildRequires: libxml2-utils
|
|
BuildRequires: %{libname} >= %{libver}
|
|
Provides: ktorrent4
|
|
Obsoletes: ktorrent4 < 22.04.0
|
|
|
|
%description
|
|
KTorrent is a BitTorrent program for KDE. It's main features are :
|
|
- downloads torrent files
|
|
- upload speed capping, seeing that most people can't upload infinite amounts of data
|
|
- internet searching using The Bittorrent website's search engine
|
|
- UDP Trackers
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kf6
|
|
|
|
%cmake_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%cmake_install
|
|
%find_lang ktorrent --with-html
|
|
|
|
rm -f %{buildroot}%{_kde4_libdir}/libktcore.so
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%posttrans
|
|
gtk-update-icon-cache %{_kf6_icondir}/hicolor &>/dev/null
|
|
update-desktop-database -q &>/dev/null
|
|
exit 0
|
|
|
|
%postun
|
|
if [ $1 -eq 0 ] ; then
|
|
touch --no-create %{_kf6_icondir}/hicolor &>/dev/null
|
|
gtk-update-icon-cache %{_kf6_icondir}/hicolor &>/dev/null
|
|
update-desktop-database -q &>/dev/null
|
|
fi
|
|
exit 0
|
|
|
|
%files -f ktorrent.lang
|
|
%defattr(-,root,root)
|
|
%{_kf6_bindir}/ktorrent
|
|
%{_kf6_bindir}/ktmagnetdownloader
|
|
%{_kf6_bindir}/ktupnptest
|
|
%{_datadir}/applications/org.kde.ktorrent.desktop
|
|
%{_datadir}/knotifications6/ktorrent.notifyrc
|
|
%{_datadir}/metainfo/org.kde.ktorrent.appdata.xml
|
|
%dir %{_libdir}/qt6/plugins/ktorrent_plugins
|
|
%{_qt6_plugindir}/ktorrent_plugins/*.so
|
|
%ifnarch %{ix86}
|
|
%dir %{_kf6_datadir}/ktorrent
|
|
%{_kf6_datadir}/ktorrent/*
|
|
%endif
|
|
%dir %{_datadir}/kxmlgui5/ktorrent
|
|
%{_datadir}/kxmlgui5/ktorrent/*.rc
|
|
%{_kf6_icondir}/hicolor/*/apps/ktorrent.png
|
|
%{_kf6_icondir}/hicolor/*/actions/*.png
|
|
%{_kf6_icondir}/hicolor/*/actions/*.svgz
|
|
%{_kf6_libdir}/libktcore.so.*
|
|
%doc LICENSES
|
|
|
|
%changelog
|
|
* Thu Nov 07 2024 Automatic Build System <autodist@openmamba.org> 24.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 11 2024 Automatic Build System <autodist@openmamba.org> 24.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 13 2024 Automatic Build System <autodist@openmamba.org> 24.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 23 2024 Automatic Build System <autodist@openmamba.org> 24.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 04 2024 Automatic Build System <autodist@openmamba.org> 24.05.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 13 2024 Automatic Build System <autodist@openmamba.org> 24.05.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 24 2024 Automatic Build System <autodist@openmamba.org> 24.05.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 13 2024 Automatic Build System <autodist@openmamba.org> 24.02.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 24 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 03 2024 Automatic Build System <autodist@openmamba.org> 24.02.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 08 2023 Automatic Build System <autodist@mambasoft.it> 23.08.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 10 2023 Automatic Build System <autodist@mambasoft.it> 23.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 12 2023 Automatic Build System <autodist@mambasoft.it> 23.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 15 2023 Automatic Build System <autodist@mambasoft.it> 23.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 25 2023 Automatic Build System <autodist@mambasoft.it> 23.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 07 2023 Automatic Build System <autodist@mambasoft.it> 23.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 10 2023 Automatic Build System <autodist@mambasoft.it> 23.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 12 2023 Automatic Build System <autodist@mambasoft.it> 23.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 20 2023 Automatic Build System <autodist@mambasoft.it> 23.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 03 2023 Automatic Build System <autodist@mambasoft.it> 22.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 03 2023 Automatic Build System <autodist@mambasoft.it> 22.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 06 2023 Automatic Build System <autodist@mambasoft.it> 22.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 09 2022 Automatic Build System <autodist@mambasoft.it> 22.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 04 2022 Automatic Build System <autodist@mambasoft.it> 22.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 14 2022 Automatic Build System <autodist@mambasoft.it> 22.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 09 2022 Automatic Build System <autodist@mambasoft.it> 22.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 20 2022 Automatic Build System <autodist@mambasoft.it> 22.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 08 2022 Automatic Build System <autodist@mambasoft.it> 22.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 10 2022 Automatic Build System <autodist@mambasoft.it> 22.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 12 2022 Automatic Build System <autodist@mambasoft.it> 22.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 24 2022 Automatic Build System <autodist@mambasoft.it> 22.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 03 2022 Automatic Build System <autodist@mambasoft.it> 21.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 04 2022 Automatic Build System <autodist@mambasoft.it> 21.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 07 2022 Automatic Build System <autodist@mambasoft.it> 21.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 11 2021 Automatic Build System <autodist@mambasoft.it> 21.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 04 2021 Automatic Build System <autodist@mambasoft.it> 21.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 08 2021 Automatic Build System <autodist@mambasoft.it> 21.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 03 2021 Automatic Build System <autodist@mambasoft.it> 21.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 13 2021 Automatic Build System <autodist@mambasoft.it> 21.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 08 2021 Automatic Build System <autodist@mambasoft.it> 21.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 10 2021 Automatic Build System <autodist@mambasoft.it> 21.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 13 2021 Automatic Build System <autodist@mambasoft.it> 21.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 22 2021 Automatic Build System <autodist@mambasoft.it> 21.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 05 2021 Automatic Build System <autodist@mambasoft.it> 20.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 05 2021 Automatic Build System <autodist@mambasoft.it> 20.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20.12.1-1mamba
|
|
- update to 20.12.1
|
|
|
|
* Tue Sep 10 2019 Automatic Build System <autodist@mambasoft.it> 5.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 07 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.1-1mamba
|
|
- update to 5.1.1
|
|
|
|
* Sun Jan 14 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.0-1mamba
|
|
- update to 5.1.0
|
|
|
|
* Sat Nov 14 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.1-2mamba
|
|
- rebuilt with libtag 1.9.1
|
|
|
|
* Sun Jan 20 2013 Automatic Build System <autodist@mambasoft.it> 4.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 27 2012 Automatic Build System <autodist@mambasoft.it> 4.3.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 20 2012 Automatic Build System <autodist@mambasoft.it> 4.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Apr 11 2012 Automatic Build System <autodist@mambasoft.it> 4.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 23 2011 Automatic Build System <autodist@mambasoft.it> 4.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 16 2011 Automatic Build System <autodist@mambasoft.it> 4.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 15 2011 Automatic Build System <autodist@mambasoft.it> 4.1.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Dec 29 2010 Automatic Build System <autodist@mambasoft.it> 4.0.5-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Oct 17 2010 Automatic Build System <autodist@mambasoft.it> 4.0.4-1mamba
|
|
- automatic update to 4.0.4 by autodist
|
|
|
|
* Mon Aug 30 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.0.3-2mamba
|
|
- specfile cleanups
|
|
- update icon cache and desktop database
|
|
|
|
* Mon Aug 30 2010 Automatic Build System <autodist@mambasoft.it> 4.0.3-1mamba
|
|
- automatic update to 4.0.3 by autodist
|
|
|
|
* Fri Jul 09 2010 Automatic Build System <autodist@mambasoft.it> 4.0.2-1mamba
|
|
- automatic update to 4.0.2 by autodist
|
|
|
|
* Sun Jun 20 2010 Automatic Build System <autodist@mambasoft.it> 4.0.1-1mamba
|
|
- update to 4.0.1
|
|
|
|
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 4.0.0-1mamba
|
|
- update to 4.0.0
|
|
|
|
* Sun Feb 07 2010 Automatic Build System <autodist@mambasoft.it> 3.3.4-1mamba
|
|
- automatic update to 3.3.4 by autodist
|
|
|
|
* Mon Jan 18 2010 Automatic Build System <autodist@mambasoft.it> 3.3.3-1mamba
|
|
- automatic update to 3.3.3 by autodist
|
|
|
|
* Sat Dec 19 2009 Automatic Build System <autodist@mambasoft.it> 3.3.2-1mamba
|
|
- automatic update to 3.3.2 by autodist
|
|
|
|
* Thu Dec 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.1-2mamba
|
|
- rebuilt with kde 4.2.4
|
|
|
|
* Mon Nov 23 2009 Automatic Build System <autodist@mambasoft.it> 3.3.1-1mamba
|
|
- automatic update to 3.3.1 by autodist
|
|
|
|
* Mon Nov 09 2009 Automatic Build System <autodist@mambasoft.it> 3.3-1mamba
|
|
- automatic update to 3.3 by autodist
|
|
|
|
* Tue Oct 20 2009 Automatic Build System <autodist@mambasoft.it> 3.2.5-1mamba
|
|
- automatic update to 3.2.5 by autodist
|
|
|
|
* Thu Sep 24 2009 Automatic Build System <autodist@mambasoft.it> 3.2.4-1mamba
|
|
- automatic update to 3.2.4 by autodist
|
|
|
|
* Tue Aug 11 2009 Automatic Build System <autodist@mambasoft.it> 3.2.3-1mamba
|
|
- automatic update to 3.2.3 by autodist
|
|
|
|
* Tue Jun 30 2009 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
|
- automatic update to 3.2.2 by autodist
|
|
|
|
* Mon Apr 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-1mamba
|
|
- automatic update to 3.2.1 by autodist
|
|
|
|
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2-1mamba
|
|
- automatic update to 3.2 by autodist
|
|
|
|
* Sat Jan 24 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.6-1mamba
|
|
- automatic update to 3.1.6 by autodist
|
|
|
|
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.5-1mamba
|
|
- automatic update to 3.1.5 by autodist
|
|
|
|
* Fri Oct 24 2008 Aleph0 <aleph0@openmamba.org> 3.1.4-1mamba
|
|
- update to 3.1.4
|
|
|
|
* Wed Apr 30 2008 Aleph0 <aleph0@openmamba.org> 2.2.6-1mamba
|
|
- update to 2.2.6
|
|
|
|
* Wed Dec 05 2007 Aleph0 <aleph0@openmamba.org> 2.2.4-2mamba
|
|
- created subpackages %{libname} and %{libname}-devel
|
|
|
|
* Thu Nov 22 2007 Aleph0 <aleph0@openmamba.org> 2.2.4-1mamba
|
|
- update to 2.2.4
|
|
|
|
* Mon Nov 19 2007 Aleph0 <aleph0@openmamba.org> 2.2.3-1mamba
|
|
- update to 2.2.3
|
|
|
|
* Wed Sep 05 2007 Aleph0 <aleph0@openmamba.org> 2.2.2-1mamba
|
|
- update to 2.2.2
|
|
|
|
* Wed Jul 25 2007 Aleph0 <aleph0@openmamba.org> 2.2.1-1mamba
|
|
- update to 2.2.1
|
|
|
|
* Wed Jul 04 2007 Aleph0 <aleph0@openmamba.org> 2.2-1mamba
|
|
- update to 2.2
|
|
|
|
* Tue Jul 03 2007 Aleph0 <aleph0@openmamba.org> 2.1.4-1mamba
|
|
- update to 2.1.4
|
|
|
|
* Tue Apr 10 2007 Aleph0 <aleph0@openmamba.org> 2.1.3-1mamba
|
|
- update to version 2.1.3 by autospec
|
|
|
|
* Fri Mar 30 2007 Aleph0 <aleph0@openmamba.org> 2.1.2-1mamba
|
|
- update to version 2.1.2 by autospec
|
|
|
|
* Fri Oct 13 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.0.3-1qilnx
|
|
- update to version 2.0.3 by autospec
|
|
|
|
* Tue Sep 05 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.0.2-1qilnx
|
|
- update to version 2.0.2 by autospec
|
|
|
|
* Fri May 12 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.2-1qilnx
|
|
- update to version 1.2 by autospec
|
|
- added missing build requirements
|
|
|
|
* Tue Sep 06 2005 Massimo Pintore <massimo.pintore@qilinux.it> 1.1rc1-1qilnx
|
|
- package created by autospec
|