automatic version update by autodist [release 2.1.0-1mamba;Tue Nov 05 2024]
This commit is contained in:
parent
9c16c9882a
commit
bd760fda35
@ -1,11 +0,0 @@
|
||||
--- kst-plot-2.0.8.20210516git/src/datasources/hdf5/hdf5.cpp.orig 2021-05-16 19:33:50.708519324 +0200
|
||||
+++ kst-plot-2.0.8.20210516git/src/datasources/hdf5/hdf5.cpp 2021-05-16 19:35:21.563204551 +0200
|
||||
@@ -308,7 +308,7 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
- status = H5Oget_info_by_name(id, name, &infobuf, H5P_DEFAULT);
|
||||
+ status = H5Oget_info_by_name(id, name, &infobuf, H5P_DEFAULT, H5O_INFO_BASIC);
|
||||
if(status == 0){
|
||||
if(infobuf.type == H5O_TYPE_DATASET){
|
||||
H5::DataSet dataset = h5Source->_hdfFile->openDataSet(name);
|
29
kst.spec
29
kst.spec
@ -1,5 +1,5 @@
|
||||
Name: kst
|
||||
Version: 2.0.8.20210516git
|
||||
Version: 2.1.0
|
||||
Release: 1mamba
|
||||
Summary: An application used to display scientific data
|
||||
Group: Graphical Desktop/Applications/Scientific
|
||||
@ -9,22 +9,25 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kst-plot.kde.org/
|
||||
Source: https://invent.kde.org/graphics/kst-plot.git/master/kst-plot-%{version}.tar.bz2
|
||||
Patch0: kst-2.0.8.20200427git-libhdf5-1.10.5.patch
|
||||
Patch1: kst-2.0.8.20210516git-libhdf5-1.12.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Core
|
||||
BuildRequires: libQt5Gui
|
||||
BuildRequires: libQt5Network
|
||||
BuildRequires: libQt5PrintSupport
|
||||
BuildRequires: libQt5Svg-devel
|
||||
BuildRequires: libQt5Widgets
|
||||
BuildRequires: libQt5Xml
|
||||
BuildRequires: libcfitsio-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgsl-devel
|
||||
BuildRequires: libhdf5-devel
|
||||
BuildRequires: libmatio-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libmatio-devel >= 1.5.21
|
||||
BuildRequires: libmatio-devel >= 1.5.27
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
@ -45,16 +48,18 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n kst-plot-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} -std=c++17" \
|
||||
-DGSL_INCLUDEDIR=/usr/include \
|
||||
-Dkst_qt4=OFF \
|
||||
-Dkst_qt5=ON \
|
||||
-Dkst_install_prefix=%{_prefix}
|
||||
@ -68,9 +73,6 @@ This package contains libraries and header files for developing applications tha
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/kst2
|
||||
@ -101,6 +103,9 @@ This package contains libraries and header files for developing applications tha
|
||||
%doc ChangeLog NEWS README README.kstScript README.md
|
||||
|
||||
%changelog
|
||||
* Tue Nov 05 2024 Automatic Build System <autodist@openmamba.org> 2.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun May 16 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.8.20210516git-1mamba
|
||||
- update to 2.0.8.20210516git
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user