154 lines
4.7 KiB
RPMSpec
154 lines
4.7 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: kscreenlocker
|
|
Version: 5.5.5
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 screen locker
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
Source: http://download.kde.org/stable/plasma/%{version}/kscreenlocker-%{version}.tar.xz
|
|
# Source: http://download.kde.org/stable/frameworks/%{majver}/...-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXcursor-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXi-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libkauth-devel
|
|
BuildRequires: libkbookmarks-devel
|
|
BuildRequires: libkcodecs-devel
|
|
BuildRequires: libkcompletion-devel
|
|
BuildRequires: libkconfig-devel
|
|
BuildRequires: libkconfigwidgets-devel
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libkcrash-devel
|
|
BuildRequires: libkdeclarative-devel
|
|
BuildRequires: libkdelibs4support-devel
|
|
BuildRequires: libkglobalaccel-devel
|
|
BuildRequires: libkguiaddons-devel
|
|
BuildRequires: libki18n-devel
|
|
BuildRequires: libkiconthemes-devel
|
|
BuildRequires: libkidletime-devel
|
|
BuildRequires: libkio-devel
|
|
BuildRequires: libkitemviews-devel
|
|
BuildRequires: libkjobwidgets-devel
|
|
BuildRequires: libknotifications-devel
|
|
BuildRequires: libkpackage-devel
|
|
BuildRequires: libkparts-devel
|
|
BuildRequires: libkservice-devel
|
|
BuildRequires: libktextwidgets-devel
|
|
BuildRequires: libkunitconversion-devel
|
|
BuildRequires: libkwayland-devel
|
|
BuildRequires: libkwidgetsaddons-devel
|
|
BuildRequires: libkwindowsystem-devel
|
|
BuildRequires: libkxmlgui-devel
|
|
BuildRequires: libpam-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libsolid-devel
|
|
BuildRequires: libsonnet-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libwayland-devel
|
|
BuildRequires: libxcb-devel
|
|
BuildRequires: libxcb-keysyms-devel
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
KDE Frameworks 5 screen locker.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%find_lang %{name}5_qt --with-qt --all-name || touch %{name}5_qt.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -f %{name}5_qt.lang
|
|
%defattr(-,root,root)
|
|
%{_datadir}/dbus-1/interfaces/kf5_org.freedesktop.ScreenSaver.xml
|
|
%{_datadir}/kconf_update/kscreenlocker.upd
|
|
%{_datadir}/kconf_update/ksreenlocker_5_3_separate_autologin.pl
|
|
%{_datadir}/knotifications5/ksmserver.notifyrc
|
|
%{_datadir}/kservices5/plasma-screenlocker_kcm-screenlocker_kcm.desktop
|
|
%{_datadir}/kservices5/screenlocker.desktop
|
|
%{_datadir}/ksmserver/screenlocker/org.kde.passworddialog/metadata.desktop
|
|
%{_datadir}/plasma/kcms/screenlocker_kcm/contents/ui/main.qml
|
|
%{_datadir}/plasma/kcms/screenlocker_kcm/metadata.desktop
|
|
%doc COPYING
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libKScreenLocker.so.*
|
|
%{_libdir}/qt5/plugins/screenlocker_kcm.so
|
|
%{_libexecdir}/kcheckpass
|
|
%{_libexecdir}/kscreenlocker_greet
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/KScreenLocker
|
|
%dir %{_includedir}/KScreenLocker/KScreenLocker
|
|
%{_includedir}/KScreenLocker/KScreenLocker/*
|
|
%dir %{_libdir}/cmake/KScreenLocker
|
|
%{_libdir}/cmake/KScreenLocker/KScreenLocker*.cmake
|
|
%{_libdir}/cmake/ScreenSaverDBusInterface/ScreenSaverDBusInterfaceConfig.cmake
|
|
%{_libdir}/libKScreenLocker.so
|
|
|
|
%changelog
|
|
* Tue Mar 01 2016 Automatic Build System <autodist@mambasoft.it> 5.5.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 27 2016 Automatic Build System <autodist@mambasoft.it> 5.5.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 07 2016 Automatic Build System <autodist@mambasoft.it> 5.5.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 02 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.5.2-1mamba
|
|
- package created using the webbuild interface
|