188 lines
6.1 KiB
RPMSpec
188 lines
6.1 KiB
RPMSpec
%define pkgver %(echo %version | tr _ -)
|
|
Name: krusader
|
|
Version: 2.9.0
|
|
Release: 1mamba
|
|
Summary: An advanced twin panel (commander style) file manager for KDE
|
|
Group: Graphical Desktop/Applications/Utilities
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://krusader.org/
|
|
Source: http://download.kde.org/stable/krusader/%{version}/krusader-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libQt6Concurrent
|
|
BuildRequires: libQt6Core
|
|
BuildRequires: libQt6DBus
|
|
BuildRequires: libQt6Gui
|
|
BuildRequires: libQt6Network
|
|
BuildRequires: libQt6PrintSupport
|
|
BuildRequires: libQt6Widgets
|
|
BuildRequires: libQt6Xml
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libacl-devel
|
|
BuildRequires: libattr-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libkf6-karchive-devel
|
|
BuildRequires: libkf6-kbookmarks-devel
|
|
BuildRequires: libkf6-kcodecs-devel
|
|
BuildRequires: libkf6-kcolorscheme-devel
|
|
BuildRequires: libkf6-kcompletion-devel
|
|
BuildRequires: libkf6-kconfig-devel
|
|
BuildRequires: libkf6-kconfigwidgets-devel
|
|
BuildRequires: libkf6-kcoreaddons-devel
|
|
BuildRequires: libkf6-kcrash-devel
|
|
BuildRequires: libkf6-kglobalaccel-devel
|
|
BuildRequires: libkf6-kguiaddons-devel
|
|
BuildRequires: libkf6-ki18n-devel
|
|
BuildRequires: libkf6-kiconthemes-devel
|
|
BuildRequires: libkf6-kio-devel
|
|
BuildRequires: libkf6-kitemviews-devel
|
|
BuildRequires: libkf6-kjobwidgets-devel
|
|
BuildRequires: libkf6-knotifications-devel
|
|
BuildRequires: libkf6-kparts-devel
|
|
BuildRequires: libkf6-kservice-devel
|
|
BuildRequires: libkf6-kstatusnotifieritem-devel
|
|
BuildRequires: libkf6-ktextwidgets-devel
|
|
BuildRequires: libkf6-kwallet-devel
|
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
|
BuildRequires: libkf6-kwindowsystem-devel
|
|
BuildRequires: libkf6-kxmlgui-devel
|
|
BuildRequires: libkf6-solid-devel
|
|
BuildRequires: libkf6-sonnet-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libz-devel
|
|
BuildRequires: qt6-qt5compat-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: gettext-devel
|
|
BuildRequires: libxml2-utils
|
|
Requires: kget
|
|
Requires: kompare
|
|
Requires: xxdiff
|
|
Requires: krename
|
|
Requires: md5deep
|
|
Requires: lzma
|
|
Requires: /usr/bin/md5sum
|
|
Requires: /usr/bin/cfv
|
|
Requires: /bin/tar
|
|
Requires: /bin/gzip
|
|
Requires: /usr/bin/bzip2
|
|
Requires: /usr/bin/zip
|
|
Requires: /usr/bin/unzip
|
|
Requires: /usr/bin/arj
|
|
Requires: /usr/bin/unrar
|
|
Requires: /bin/cpio
|
|
Requires: /usr/bin/rpm
|
|
Requires: /usr/bin/7z
|
|
Requires: /usr/bin/locate
|
|
|
|
%description
|
|
Krusader is an advanced twin panel (commander style) file manager for KDE and other desktops in the *nix world, similar to Midnight or Total Commander.
|
|
It provides all the file management features you could possibly want:
|
|
* extensive archive handling
|
|
* mounted filesystem support
|
|
* FTP
|
|
* advanced search module
|
|
* viewer/editor
|
|
* directory synchronisation
|
|
* file content comparisons
|
|
* powerful batch renaming
|
|
and much much more.
|
|
It supports the following archive formats: tar, zip, bzip2, gzip, rar, ace, arj and rpm and can handle other KIOSlaves such as smb or fish.
|
|
|
|
%prep
|
|
%setup -q -n %{name}-%{pkgver}
|
|
|
|
%build
|
|
%cmake_kf6
|
|
|
|
%cmake_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%cmake_install
|
|
|
|
%find_lang %{name} --with-qt --with-man --all-name || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_kde5_bindir}/krusader
|
|
%{_kf6_plugindir}/kio/kio_iso.so
|
|
%{_kf6_plugindir}/kio/kio_krarc.so
|
|
%{_datadir}/metainfo/org.kde.krusader.appdata.xml
|
|
%{_datadir}/applications/org.kde.krusader*.desktop
|
|
%dir %{_datadir}/kxmlgui5/krusader
|
|
%{_datadir}/kxmlgui5/krusader/*
|
|
%{_kde5_datadir}/krusader
|
|
%{_kde5_configdir}/kio_isorc
|
|
%doc %lang(en) %{_kde5_htmldir}/*/krusader
|
|
%{_kde5_icondir}/hicolor/*/*/*.png
|
|
%{_mandir}/man1/krusader.1*
|
|
%doc AUTHORS LICENSES
|
|
|
|
%changelog
|
|
* Thu Jan 02 2025 Automatic Build System <autodist@openmamba.org> 2.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 12 2024 Automatic Build System <autodist@openmamba.org> 2.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 23 2022 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 29 2019 Automatic Build System <autodist@mambasoft.it> 2.7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 12 2018 Automatic Build System <autodist@mambasoft.it> 2.7.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 05 2018 Automatic Build System <autodist@mambasoft.it> 2.7.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 08 2017 Automatic Build System <autodist@mambasoft.it> 2.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 17 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.0-1mamba
|
|
- update to 2.5.0
|
|
|
|
* Fri Sep 06 2013 Automatic Build System <autodist@mambasoft.it> 2.4.0_beta3-1mamba
|
|
- update to 2.4.0_beta3
|
|
|
|
* Fri Dec 31 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-4mamba
|
|
- require /usr/bin/rpm instead of /bin/rpm
|
|
- added gcc 4.5 build patch
|
|
|
|
* Fri May 29 2009 Automatic Build System <autodist@mambasoft.it> 2.0.0-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Apr 20 2009 Davide Madrisan <davide.madrisan@gmail.com> 2.0.0-2mamba
|
|
- remove unused macro %%kdedir
|
|
- remove build requirements for kde3 packages
|
|
- update the list of build requirements and static requirements
|
|
|
|
* Wed Apr 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
|
|
- automatic update to 2.0.0 by autodist
|
|
|
|
* Mon May 05 2008 Aleph0 <aleph0@openmamba.org> 1.90-1mamba
|
|
- update to 1.90
|
|
|
|
* Sun Jul 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.80.0-1mamba
|
|
- update to 1.80.0
|
|
|
|
* Thu Sep 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.70.1-1qilnx
|
|
- update to version 1.70.1 by autospec
|
|
- also fixes a security issue (bugtraq#203)
|
|
- added a requirement for md5deep
|
|
|
|
* Tue Feb 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.70.0-1qilnx
|
|
- update to version 1.70.0 by autospec
|
|
- added some requirements for the exernal utilities used by krusader
|
|
|
|
* Sun Nov 28 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.50-1qilnx
|
|
- package created by autospec
|