update to 2.4.0_beta3 [release 2.4.0_beta3-1mamba;Fri Sep 06 2013]
This commit is contained in:
parent
0484cb622b
commit
21c9ca45c9
14
README.md
14
README.md
@ -1,2 +1,16 @@
|
|||||||
# krusader
|
# krusader
|
||||||
|
|
||||||
|
Krusader is an advanced twin panel (commander style) file manager for KDE and other desktops in the *nix world, similar to Midnight or Total Commander.
|
||||||
|
It provides all the file management features you could possibly want:
|
||||||
|
* extensive archive handling
|
||||||
|
* mounted filesystem support
|
||||||
|
* FTP
|
||||||
|
* advanced search module
|
||||||
|
* viewer/editor
|
||||||
|
* directory synchronisation
|
||||||
|
* file content comparisons
|
||||||
|
* powerful batch renaming
|
||||||
|
and much much more.
|
||||||
|
|
||||||
|
It supports the following archive formats: tar, zip, bzip2, gzip, rar, ace, arj and rpm and can handle other KIOSlaves such as smb or fish.
|
||||||
|
|
||||||
|
10
krusader-2.0.0-gcc44.patch
Normal file
10
krusader-2.0.0-gcc44.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- krusader-2.0.0/krusader/VFS/kiojobwrapper.cpp.orig 2009-04-11 21:40:15.000000000 +0200
|
||||||
|
+++ krusader-2.0.0/krusader/VFS/kiojobwrapper.cpp 2009-04-20 00:54:02.000000000 +0200
|
||||||
|
@@ -37,6 +37,7 @@
|
||||||
|
#include <kio/jobuidelegate.h>
|
||||||
|
#include <kio/job.h>
|
||||||
|
#include <qapplication.h>
|
||||||
|
+#include <cstdio>
|
||||||
|
#include <iostream>
|
||||||
|
#include <klocale.h>
|
||||||
|
#include "virtualcopyjob.h"
|
24
krusader-2.0.0-gcc45.patch
Normal file
24
krusader-2.0.0-gcc45.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru krusader-2.0.0.orig//krusader/krslots.cpp krusader-2.0.0/krusader/krslots.cpp
|
||||||
|
--- krusader-2.0.0.orig//krusader/krslots.cpp 2009-04-11 21:40:25.000000000 +0200
|
||||||
|
+++ krusader-2.0.0/krusader/krslots.cpp 2010-12-31 00:33:34.517505884 +0100
|
||||||
|
@@ -450,7 +450,7 @@
|
||||||
|
KrSearchDialog::SearchDialog->raise();
|
||||||
|
KrSearchDialog::SearchDialog->activateWindow();
|
||||||
|
} else
|
||||||
|
- KrSearchDialog::SearchDialog = new KrSearchDialog();
|
||||||
|
+ KrSearchDialog::SearchDialog = new KrSearchDialog( QString::null );
|
||||||
|
}
|
||||||
|
|
||||||
|
void KRslots::locate()
|
||||||
|
diff -Nru krusader-2.0.0.orig//krusader/MountMan/kmountmangui.h krusader-2.0.0/krusader/MountMan/kmountmangui.h
|
||||||
|
--- krusader-2.0.0.orig//krusader/MountMan/kmountmangui.h 2009-04-11 21:40:19.000000000 +0200
|
||||||
|
+++ krusader-2.0.0/krusader/MountMan/kmountmangui.h 2010-12-31 00:34:01.519436467 +0100
|
||||||
|
@@ -112,7 +112,7 @@
|
||||||
|
/////////////////////////////////////////////////////////////////
|
||||||
|
class fsData {
|
||||||
|
public:
|
||||||
|
- fsData() : Name( 0 ), Type( 0 ), MntPoint( 0 ), TotalBlks( 0 ),
|
||||||
|
+ fsData() : Name( QString::null ), Type( QString::null ), MntPoint( QString::null ), TotalBlks( 0 ),
|
||||||
|
FreeBlks( 0 ), Mounted( false ) {}
|
||||||
|
|
||||||
|
// get information
|
129
krusader.spec
Normal file
129
krusader.spec
Normal file
@ -0,0 +1,129 @@
|
|||||||
|
%define pkgver %(echo %version | tr _ -)
|
||||||
|
Name: krusader
|
||||||
|
Version: 2.4.0_beta3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: An advanced twin panel (commander style) file manager for KDE
|
||||||
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://krusader.sourceforge.net/
|
||||||
|
Source: http://downloads.sourceforge.net/project/krusader/krusader/%{pkgver}/krusader-%{pkgver}.tar.bz2
|
||||||
|
Patch0: %{name}-2.0.0-gcc44.patch
|
||||||
|
Patch1: %{name}-2.0.0-gcc45.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: libxml2-utils
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs4-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: kget
|
||||||
|
Requires: kompare
|
||||||
|
Requires: xxdiff
|
||||||
|
Requires: krename
|
||||||
|
Requires: md5deep
|
||||||
|
Requires: lzma
|
||||||
|
Requires: /usr/bin/md5sum
|
||||||
|
Requires: /usr/bin/cfv
|
||||||
|
Requires: /bin/tar
|
||||||
|
Requires: /bin/gzip
|
||||||
|
Requires: /usr/bin/bzip2
|
||||||
|
Requires: /usr/bin/zip
|
||||||
|
Requires: /usr/bin/unzip
|
||||||
|
Requires: /usr/bin/arj
|
||||||
|
Requires: /usr/bin/unrar
|
||||||
|
Requires: /bin/cpio
|
||||||
|
Requires: /usr/bin/rpm
|
||||||
|
Requires: /usr/bin/7z
|
||||||
|
Requires: /usr/bin/locate
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Krusader is an advanced twin panel (commander style) file manager for KDE and other desktops in the *nix world, similar to Midnight or Total Commander.
|
||||||
|
It provides all the file management features you could possibly want:
|
||||||
|
* extensive archive handling
|
||||||
|
* mounted filesystem support
|
||||||
|
* FTP
|
||||||
|
* advanced search module
|
||||||
|
* viewer/editor
|
||||||
|
* directory synchronisation
|
||||||
|
* file content comparisons
|
||||||
|
* powerful batch renaming
|
||||||
|
and much much more.
|
||||||
|
|
||||||
|
It supports the following archive formats: tar, zip, bzip2, gzip, rar, ace, arj and rpm and can handle other KIOSlaves such as smb or fish.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{pkgver}
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake_kde4 -d build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%{find_lang} %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_kde4_bindir}/krusader
|
||||||
|
%{_kde4_libdir}/kde4/*.so
|
||||||
|
%{_kde4_xdgappsdir}/krusader.desktop
|
||||||
|
%{_kde4_xdgappsdir}/krusader_root-mode.desktop
|
||||||
|
%{_kde4_datadir}/krusader
|
||||||
|
%{_kde4_configdir}/kio_isorc
|
||||||
|
%doc %lang(en) %{_kde4_htmldir}/*/krusader
|
||||||
|
%{_kde4_icondir}/locolor/*/apps/krusader*.png
|
||||||
|
%{_kde4_icondir}/hicolor/*/*/*.png
|
||||||
|
%{_kde4_servicesdir}/*.protocol
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
#ChangeLog README TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Sep 06 2013 Automatic Build System <autodist@mambasoft.it> 2.4.0_beta3-1mamba
|
||||||
|
- update to 2.4.0_beta3
|
||||||
|
|
||||||
|
* Fri Dec 31 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-4mamba
|
||||||
|
- require /usr/bin/rpm instead of /bin/rpm
|
||||||
|
- added gcc 4.5 build patch
|
||||||
|
|
||||||
|
* Fri May 29 2009 Automatic Build System <autodist@mambasoft.it> 2.0.0-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Apr 20 2009 Davide Madrisan <davide.madrisan@gmail.com> 2.0.0-2mamba
|
||||||
|
- remove unused macro %%kdedir
|
||||||
|
- remove build requirements for kde3 packages
|
||||||
|
- update the list of build requirements and static requirements
|
||||||
|
|
||||||
|
* Wed Apr 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
|
||||||
|
- automatic update to 2.0.0 by autodist
|
||||||
|
|
||||||
|
* Mon May 05 2008 Aleph0 <aleph0@openmamba.org> 1.90-1mamba
|
||||||
|
- update to 1.90
|
||||||
|
|
||||||
|
* Sun Jul 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.80.0-1mamba
|
||||||
|
- update to 1.80.0
|
||||||
|
|
||||||
|
* Thu Sep 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.70.1-1qilnx
|
||||||
|
- update to version 1.70.1 by autospec
|
||||||
|
- also fixes a security issue (bugtraq#203)
|
||||||
|
- added a requirement for md5deep
|
||||||
|
|
||||||
|
* Tue Feb 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.70.0-1qilnx
|
||||||
|
- update to version 1.70.0 by autospec
|
||||||
|
- added some requirements for the exernal utilities used by krusader
|
||||||
|
|
||||||
|
* Sun Nov 28 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.50-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user