automatic version update by autodist [release 4.13.0-1mamba;Thu Apr 17 2014]
This commit is contained in:
parent
c35f82d27c
commit
9104424e2f
10
kross-interpreters-4.10.5-ruby-2.0.patch
Normal file
10
kross-interpreters-4.10.5-ruby-2.0.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- kross-interpreters-4.10.5/ruby/CMakeLists.txt.orig 2013-07-05 11:40:28.345712586 +0200
|
||||
+++ kross-interpreters-4.10.5/ruby/CMakeLists.txt 2013-07-05 11:39:17.141389267 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
find_package(Ruby 1.9 QUIET)
|
||||
|
||||
-if( RUBY_VERSION VERSION_GREATER "1.10" )
|
||||
+if( RUBY_VERSION VERSION_GREATER "2.1" )
|
||||
message(STATUS "Found Ruby: ${RUBY_EXECUTABLE} (found version \"${RUBY_VERSION}\") but only 1.9.x supported")
|
||||
set(RUBY_FOUND False)
|
||||
else()
|
11
kross-interpreters-4.7.2-krossjava_jbyte_conversion.patch
Normal file
11
kross-interpreters-4.7.2-krossjava_jbyte_conversion.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- kross-interpreters-4.7.2/java/krossjava/jvmvariant.h 2011-08-22 15:25:39.000000000 +0200
|
||||
+++ kross-interpreters-4.7.2/java/krossjava/jvmvariant.h.conversion_fix 2011-10-28 21:42:30.000000000 +0200
|
||||
@@ -126,7 +126,7 @@
|
||||
QVarLengthArray<jbyte, 1024> bytes(count);
|
||||
for(int i = 0; i < count; ++i)
|
||||
bytes[i] = array[i];
|
||||
- env->SetByteArrayRegion(bytearray, 0, count, bytes.constData());
|
||||
+ env->SetByteArrayRegion(bytearray, 0, count, (jbyte*)bytes.constData());
|
||||
return bytearray;
|
||||
}
|
||||
inline static QByteArray toVariant(jobject value, JNIEnv* env) {
|
204
kross-interpreters.spec
Normal file
204
kross-interpreters.spec
Normal file
@ -0,0 +1,204 @@
|
||||
%define java 1
|
||||
%define javarootdir %_jvmdir/jdk/
|
||||
|
||||
Name: kross-interpreters
|
||||
Version: 4.13.0
|
||||
Release: 1mamba
|
||||
Summary: Kross interpreters
|
||||
Group: Graphical Desktop/Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://www.kde.org
|
||||
Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kross-interpreters-%{version}.tar.xz
|
||||
Patch0: %{name}-4.7.2-krossjava_jbyte_conversion.patch
|
||||
Patch1: kross-interpreters-4.10.5-ruby-2.0.patch
|
||||
License: LGPL
|
||||
BuildRequires: cmake
|
||||
%if 0%{?java}
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: gcc-java
|
||||
BuildRequires: java-gcj-compat
|
||||
BuildRequires: java-openjdk
|
||||
BuildRequires: java-openjdk-runtime
|
||||
%endif
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: kdelibs-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: ruby-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: falcon-devel
|
||||
#Requires: kross-falcon
|
||||
Requires: kross-java = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: kross-python = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: kross-ruby = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package -n kross-falcon
|
||||
Summary: Kross plugin for falcon
|
||||
Group: Development/Languages
|
||||
Requires: falcon >= 0.8.12
|
||||
Provides: kross(falcon) = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n kross-falcon
|
||||
Falcon plugin for the Kross architecture in KDE4.
|
||||
|
||||
%package -n kross-java
|
||||
Summary: Kross plugin for java
|
||||
Group: Development/Languages
|
||||
Provides: kross(java) = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n kross-java
|
||||
Java plugin for the Kross architecture in KDE4.
|
||||
|
||||
%package -n kross-python
|
||||
Summary: Kross plugin for python
|
||||
Group: Development/Languages
|
||||
Provides: kross(python) = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n kross-python
|
||||
Python plugin for the Kross architecture in KDE4.
|
||||
|
||||
%package -n kross-ruby
|
||||
Summary: Kross plugin for ruby
|
||||
Group: Development/Languages
|
||||
Requires: ruby
|
||||
Provides: kross(ruby) = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n kross-ruby
|
||||
Ruby plugin for the Kross architecture in KDE4.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde4 -d build
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
|
||||
#%files -n kross-falcon
|
||||
#%defattr(-,root,root)
|
||||
#%{_kde4_libdir}/kde4/kross/krossfalcon.so
|
||||
|
||||
%files -n kross-java
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_libdir}/kde4/kross/kross.jar
|
||||
%{_kde4_libdir}/kde4/krossjava.so
|
||||
|
||||
%files -n kross-python
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_libdir}/kde4/krosspython.so
|
||||
|
||||
%files -n kross-ruby
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_libdir}/kde4/krossruby.so
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Thu Apr 17 2014 Automatic Build System <autodist@mambasoft.it> 4.13.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 03 2014 Automatic Build System <autodist@mambasoft.it> 4.12.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Feb 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 4.12.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 19 2013 Automatic Build System <autodist@mambasoft.it> 4.12.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 05 2013 Automatic Build System <autodist@mambasoft.it> 4.11.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Nov 06 2013 Automatic Build System <autodist@mambasoft.it> 4.11.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 02 2013 Automatic Build System <autodist@mambasoft.it> 4.11.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 04 2013 Automatic Build System <autodist@mambasoft.it> 4.11.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 14 2013 Automatic Build System <autodist@mambasoft.it> 4.11.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jul 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jun 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 07 2013 Automatic Build System <autodist@mambasoft.it> 4.10.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 03 2013 Automatic Build System <autodist@mambasoft.it> 4.10.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Feb 13 2013 Automatic Build System <autodist@mambasoft.it> 4.10.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 4.9.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 05 2012 Automatic Build System <autodist@mambasoft.it> 4.9.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 08 2012 Automatic Build System <autodist@mambasoft.it> 4.9.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Sep 06 2012 Automatic Build System <autodist@mambasoft.it> 4.9.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 17 2012 Automatic Build System <autodist@mambasoft.it> 4.9.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 10 2012 Automatic Build System <autodist@mambasoft.it> 4.8.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 05 2012 Automatic Build System <autodist@mambasoft.it> 4.8.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Apr 07 2012 Automatic Build System <autodist@mambasoft.it> 4.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 28 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 14 2011 Automatic Build System <autodist@mambasoft.it> 4.7.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 03 2011 Automatic Build System <autodist@mambasoft.it> 4.7.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 16 2011 Davide Madrisan <davide.madrisan@gmail.com> 4.7.2-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user