62 lines
1.9 KiB
RPMSpec
62 lines
1.9 KiB
RPMSpec
%define gitver %(echo %version | cut -d. -f3)
|
|
Name: krop
|
|
Version: 0.6.1
|
|
Release: 1mamba
|
|
Summary: A tool to crop PDF files, with an eye towards eReaders
|
|
Group: Graphical Desktop/Applications/Publishing
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://arminstraub.com/software/krop
|
|
Source: https://github.com/PunkPangolin/krop.git/qt6-%{gitver}/krop-%{version}.tar.bz2
|
|
#Source: https://github.com/arminstraub/krop.git/v%{version}/krop-%{version}.tar.bz2
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(setuptools)
|
|
## AUTOBUILDREQ-END
|
|
Requires: PyQt6-py3
|
|
Requires: PyQt6-sip-py3
|
|
Requires: python-pypdf-py3
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python3} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python3} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{_includedir}/python \
|
|
--install-lib=%{python3_sitearch} \
|
|
--record=%{name}.filelist
|
|
|
|
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|
|
|
install -D -m0644 %{name}.desktop %{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
|
|
%files -f %{name}.filelist
|
|
%defattr(-,root,root)
|
|
%dir %{python3_sitearch}/krop-%{version}-py*.egg-info
|
|
%{python3_sitearch}/krop-%{version}-py*.egg-info/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Wed Jun 26 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
|
|
- update to 0.6.1
|
|
|
|
* Wed Jan 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0-2mamba
|
|
- rebuilt with python3 == 3.11
|
|
|
|
* Mon Dec 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0-1mamba
|
|
- update to 0.6.0
|
|
|
|
* Thu Aug 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1-1mamba
|
|
- package created by silvan using the webbuild interface
|