automatic version update by autodist [release 5.2.2-1mamba;Mon Feb 05 2024]

This commit is contained in:
Automatic Build System 2024-02-06 12:48:58 +01:00
parent 46d3e5befc
commit e5de74ad0d
3 changed files with 134 additions and 8 deletions

View File

@ -0,0 +1,93 @@
From ace7edcca6ad322581ab39620f21ccf3ffbd3b5a Mon Sep 17 00:00:00 2001
From: Timo Gurr <timo.gurr@gmail.com>
Date: Fri, 5 Jan 2024 14:04:50 +0000
Subject: [PATCH] Fix build with libjxl 0.9.0
Fix build with libjxl 0.9.0
BUG:478987
Test Plan
---------
* Upgrade to libjxl 0.9.0
* Apply patch from MR and build krita (5.2.2)
* Open/Display a sample image e.g. https://jpegxl.info/test-page/red-room.jxl
Formalities Checklist
---------------------
- [x] I confirmed this builds.
- [x] I confirmed Krita ran and the relevant functions work (Could successfully open/display a sample image https://jpegxl.info/test-page/red-room.jxl).
- [ ] I tested the relevant unit tests and can confirm they are not broken. (If not possible, don't hesitate to ask for help!)
- [x] I made sure my commits build individually and have good descriptions as per [KDE guidelines](https://community.kde.org/Policies/Commit_Policy).
- [x] I made sure my code conforms to the standards set in the HACKING file.
- [x] I can confirm the code is licensed and attributed appropriately, and that unattributed code is mine, as per [KDE Licensing Policy](https://community.kde.org/Policies/Licensing_Policy).
_**Reminder: the reviewer is responsible for merging the patch, this is to ensure at the least two people can build the patch. In case a patch breaks the build, both the author and the reviewer should be contacted to fix the build.**_
_**If this is not possible, the commits shall be reverted, and a notification with the reasoning and any relevant logs shall be sent to the mailing list, kimageshop@kde.org.**_
---
plugins/impex/jxl/JPEGXLImport.cpp | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
diff --git a/plugins/impex/jxl/JPEGXLImport.cpp b/plugins/impex/jxl/JPEGXLImport.cpp
index 573bae41247..f5b989b3b70 100644
--- a/plugins/impex/jxl/JPEGXLImport.cpp
+++ b/plugins/impex/jxl/JPEGXLImport.cpp
@@ -511,7 +511,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
JxlColorEncoding colorEncoding{};
if (JXL_DEC_SUCCESS
== JxlDecoderGetColorAsEncodedProfile(dec.get(),
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0, 9, 0)
nullptr,
+#endif
JXL_COLOR_PROFILE_TARGET_DATA,
&colorEncoding)) {
const TransferCharacteristics transferFunction = [&]() {
@@ -635,7 +637,12 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
size_t iccSize = 0;
QByteArray iccProfile;
if (JXL_DEC_SUCCESS
- != JxlDecoderGetICCProfileSize(dec.get(), nullptr, JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
+ != JxlDecoderGetICCProfileSize(dec.get(),
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
+ nullptr,
+#endif
+ JXL_COLOR_PROFILE_TARGET_DATA,
+ &iccSize)) {
errFile << "ICC profile size retrieval failed";
document->setErrorMessage(i18nc("JPEG-XL errors", "Unable to read the image profile."));
return ImportExportCodes::ErrorWhileReading;
@@ -643,7 +650,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
iccProfile.resize(static_cast<int>(iccSize));
if (JXL_DEC_SUCCESS
!= JxlDecoderGetColorAsICCProfile(dec.get(),
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
nullptr,
+#endif
JXL_COLOR_PROFILE_TARGET_DATA,
reinterpret_cast<uint8_t *>(iccProfile.data()),
static_cast<size_t>(iccProfile.size()))) {
@@ -657,7 +666,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
if (!d.m_info.uses_original_profile) {
if (JXL_DEC_SUCCESS
!= JxlDecoderGetICCProfileSize(dec.get(),
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
nullptr,
+#endif
JXL_COLOR_PROFILE_TARGET_ORIGINAL,
&iccTargetSize)) {
errFile << "ICC profile size retrieval failed";
@@ -667,7 +678,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
iccTargetProfile.resize(static_cast<int>(iccTargetSize));
if (JXL_DEC_SUCCESS
!= JxlDecoderGetColorAsICCProfile(dec.get(),
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
nullptr,
+#endif
JXL_COLOR_PROFILE_TARGET_ORIGINAL,
reinterpret_cast<uint8_t *>(iccTargetProfile.data()),
static_cast<size_t>(iccTargetProfile.size()))) {
--
GitLab

View File

@ -0,0 +1,13 @@
diff --git a/cmake/modules/pyproject.toml.in b/cmake/modules/pyproject.toml.in
index 090b2d4b0c..085ddf4179 100644
--- a/cmake/modules/pyproject.toml.in
+++ b/cmake/modules/pyproject.toml.in
@@ -9,7 +9,7 @@ name = "@module_name_toml@"
sip-module = "@sip_name@"
sip-include-dirs = @sip_include_dirs@
sip-files-dir = "@module_srcs@"
-abi-version = "12"
+abi-version = "12.8"
[tool.sip.bindings.@module_name_toml@]
tags = @module_tags@

View File

@ -2,48 +2,57 @@
%define dirver %(echo %version | cut -d. -f1-3)
Name: krita
Version: 5.1.5
Release: 2mamba
Version: 5.2.2
Release: 1mamba
Summary: A free and open source painting tool
Group: Graphical Desktop/Applications/Graphics
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://kde.org/
URL: https://krita.org/en/
Source: https://download.kde.org/stable/krita/%{version}/krita-%{version}.tar.xz
Patch0: krita-5.0.0-gcc-11.2.0.patch
Patch1: krita-5.2.2-sip-6.8.2.patch
Patch2: krita-5.2.2-libjxl-0.9.1.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libICE-devel
BuildRequires: libQt5Multimedia-devel
BuildRequires: libQt5Svg-devel
BuildRequires: libQt5X11Extras-devel
BuildRequires: libSDL2-devel
BuildRequires: libSM-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXi-devel
BuildRequires: libboost-devel
BuildRequires: libbzip2-devel
BuildRequires: libexiv2-devel
BuildRequires: libfftw-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
BuildRequires: libgcc
BuildRequires: libgif-devel
BuildRequires: libglib-devel
BuildRequires: libgsl-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libheif-devel
BuildRequires: libimath-devel
BuildRequires: libjpeg-devel
BuildRequires: libjson-c-devel
BuildRequires: libjxl-devel
BuildRequires: libkcompletion-devel
BuildRequires: libkconfig-devel
BuildRequires: libkcoreaddons-devel
BuildRequires: libkcrash-devel
BuildRequires: libkdcraw-devel
BuildRequires: libkguiaddons-devel
BuildRequires: libki18n-devel
BuildRequires: libkitemviews-devel
BuildRequires: libkwidgetsaddons-devel
BuildRequires: libkwindowsystem-devel
BuildRequires: liblcms2-devel
BuildRequires: libmlt-devel
BuildRequires: libmypaint-devel
BuildRequires: libopencolorio-devel
BuildRequires: libopenexr-devel
@ -51,21 +60,25 @@ BuildRequires: libopenjpeg-devel
BuildRequires: libpng-devel
BuildRequires: libpoppler-devel
BuildRequires: libpoppler-qt5-devel
BuildRequires: libpython310-devel
BuildRequires: libpython3-devel
BuildRequires: libquazip-devel
BuildRequires: libraw-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtiff-devel
BuildRequires: libunibreak-devel
BuildRequires: libwebp-devel
BuildRequires: libz-devel
BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qtdeclarative-devel
## AUTOBUILDREQ-END
BuildRequires: libquazip-devel >= 0:1.4-1mamba
BuildRequires: libopencolorio-devel >= 2.3.2
BuildRequires: libpoppler-devel >= 22.06.0-1mamba
BuildRequires: cmake
BuildRequires: immer-devel
BuildRequires: rpm-macros-kde5
BuildRequires: extra-cmake-modules
BuildRequires: lager-devel
BuildRequires: zug-devel
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: calligra-krita
Obsoletes: calligra-krita < 4.4.3
@ -101,7 +114,11 @@ This package contains the color schemes provided with %{name}.
%prep
%setup -q
%patch0 -p1
#-D -T
#:<< _EOF
%patch 0 -p1
%patch 1 -p1 -b .sip-6.8.2
%patch 2 -p1 -b .libjxl-0.9.1
%build
%cmake_kde5 -d build \
@ -165,6 +182,9 @@ This package contains the color schemes provided with %{name}.
%{_datadir}/color-schemes/Krita*.colors
%changelog
* Mon Feb 05 2024 Automatic Build System <autodist@openmamba.org> 5.2.2-1mamba
- automatic version update by autodist
* Wed Feb 15 2023 Sdk Build System <sdk@mambasoft.it> 5.1.5-2mamba
- rebuilt by autoport with build requirements: libquazip-devel>=0:1.4-1mamba